summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-power/athcool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-power/athcool')
-rw-r--r--sys-power/athcool/Manifest1
-rw-r--r--sys-power/athcool/athcool-0.3.12.ebuild44
-rwxr-xr-xsys-power/athcool/files/athcool15
-rw-r--r--sys-power/athcool/files/athcool-0.3.11-build.patch36
-rw-r--r--sys-power/athcool/metadata.xml5
5 files changed, 101 insertions, 0 deletions
diff --git a/sys-power/athcool/Manifest b/sys-power/athcool/Manifest
new file mode 100644
index 000000000000..da60cad2248d
--- /dev/null
+++ b/sys-power/athcool/Manifest
@@ -0,0 +1 @@
+DIST athcool-0.3.12.tar.gz 18384 SHA256 8a80654cb616064d60e6188fe6d426fe104a439930fceab865930bf1c9ffbbc9
diff --git a/sys-power/athcool/athcool-0.3.12.ebuild b/sys-power/athcool/athcool-0.3.12.ebuild
new file mode 100644
index 000000000000..51f56589f5a1
--- /dev/null
+++ b/sys-power/athcool/athcool-0.3.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="small utility to toggle Powersaving mode for AMD Athlon/Duron processors"
+HOMEPAGE="http://members.jcom.home.ne.jp/jacobi/linux/softwares.html#athcool"
+SRC_URI="http://members.jcom.home.ne.jp/jacobi/linux/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+
+DEPEND="sys-apps/pciutils"
+RDEPEND=""
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.3.11-build.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ doinitd "${FILESDIR}"/athcool
+ dodoc README ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "WARNING: Depending on your motherboard and/or hardware components,"
+ ewarn "enabling powersaving mode may cause:"
+ ewarn " * noisy or distorted sound playback"
+ ewarn " * a slowdown in harddisk performance"
+ ewarn " * system locks or unpredictable behavior"
+ ewarn " * file system corruption"
+ ewarn "If you met those problems, you should not use athcool. Please use"
+ ewarn "athcool AT YOUR OWN RISK!"
+}
diff --git a/sys-power/athcool/files/athcool b/sys-power/athcool/files/athcool
new file mode 100755
index 000000000000..c6eddd95bf72
--- /dev/null
+++ b/sys-power/athcool/files/athcool
@@ -0,0 +1,15 @@
+#!/sbin/runscript
+# $Id$
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ athcool on >/dev/null 2>&1
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ athcool off >/dev/null 2>&1
+ eend $?
+}
+
diff --git a/sys-power/athcool/files/athcool-0.3.11-build.patch b/sys-power/athcool/files/athcool-0.3.11-build.patch
new file mode 100644
index 000000000000..8b8e619dd71f
--- /dev/null
+++ b/sys-power/athcool/files/athcool-0.3.11-build.patch
@@ -0,0 +1,36 @@
+--- Makefile
++++ Makefile
+@@ -14,13 +14,13 @@
+ SRCS = athcool.c scanpci.c
+ OBJS = $(SRCS:.c=.o)
+
+-CC = gcc
++CC ?= gcc
+ RM = rm -f
+-CFLAGS = -O2 -Wall
+-DEFS = -I. -I$(includedir) -DPACKAGE=\"$(PACKAGE)\" -DVERSION=\"$(VERSION)\"
++CFLAGS += -Wall
++DEFS = -I. -DPACKAGE=\"$(PACKAGE)\" -DVERSION=\"$(VERSION)\"
+ #DEFS += -DENABLE_FORCEID=1
+ #DEFS += -DDISABLE_WRITE_REG=1
+-LIBS = -lpci
++LIBS = -lpci -lz
+
+ ### rules ###
+
+@@ -30,13 +30,13 @@
+ all: $(PACKAGE)
+
+ $(PACKAGE): $(OBJS)
+- $(CC) $(CFLAGS) $(OBJS) $(LIBS) -o $@
++ $(CC) $(CFLAGS) $(OBJS) $(LIBS) -o $@ $(LDFLAGS)
+
+ install: install-program install-man # install-script
+
+ install-program:
+ [ -d $(sbindir) ] || install -m 755 -d $(sbindir)
+- install -s $(PACKAGE) $(sbindir)
++ install $(PACKAGE) $(sbindir)
+
+ install-man:
+ [ -d $(mandir)/man8 ] || install -m 755 -d $(mandir)/man8
diff --git a/sys-power/athcool/metadata.xml b/sys-power/athcool/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-power/athcool/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>