summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-power/bbswitch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-power/bbswitch')
-rw-r--r--sys-power/bbswitch/Manifest2
-rw-r--r--sys-power/bbswitch/bbswitch-0.7.ebuild36
-rw-r--r--sys-power/bbswitch/bbswitch-0.8.ebuild38
-rw-r--r--sys-power/bbswitch/files/bbswitch.modprobe1
-rw-r--r--sys-power/bbswitch/metadata.xml24
5 files changed, 101 insertions, 0 deletions
diff --git a/sys-power/bbswitch/Manifest b/sys-power/bbswitch/Manifest
new file mode 100644
index 000000000000..e2fad107250b
--- /dev/null
+++ b/sys-power/bbswitch/Manifest
@@ -0,0 +1,2 @@
+DIST bbswitch-0.7.tar.gz 20963 SHA256 bc21377c165aa2851b85c6a2e398c94be70a0519ba8241ea92aedcbaad7b4659 SHA512 4ba648012dc0e55210944f56d038ee90b4b61e4a38cdf35b33d9fd4777c93e07c53c43d18764c7c11aefea165a2152b766387d0d3267153983491dec6abe1493 WHIRLPOOL 5e4780c82393105e66d5949ac1470d7613807901d034d59042ccf64e36ce2b2512a78e354763793413fbc966d2181475629e749540b49fa8b161734a7808e95d
+DIST bbswitch-0.8.tar.gz 15800 SHA256 76cabd3f734fb4fe6ebfe3ec9814138d0d6f47d47238521ecbd6a986b60d1477 SHA512 11ab163931feb6c0e202d04c4552b848e999fedea9990390c26b28abdb4a69081ccfb5a22d1e390cc274f1c0cfc9adedc719c5fece14738b17aaa93e28865b7c WHIRLPOOL 4215bb74779d5bfaacd1177f89636a9006fbce369c381e620868e7012092756417f7df732b373341254fad75e08f6de4536921f5478f0032d2961d22d56a3c15
diff --git a/sys-power/bbswitch/bbswitch-0.7.ebuild b/sys-power/bbswitch/bbswitch-0.7.ebuild
new file mode 100644
index 000000000000..b03f0e2af1ba
--- /dev/null
+++ b/sys-power/bbswitch/bbswitch-0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils linux-mod
+
+DESCRIPTION="Toggle discrete NVIDIA Optimus graphics card"
+HOMEPAGE="https://github.com/Bumblebee-Project/bbswitch"
+SRC_URI="https://github.com/Bumblebee-Project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="virtual/linux-sources
+ sys-kernel/linux-headers"
+RDEPEND=""
+
+MODULE_NAMES="bbswitch(acpi)"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="default"
+ BUILD_PARAMS="KVERSION=${KV_FULL}"
+}
+
+src_install() {
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/bbswitch.modprobe bbswitch.conf
+ dodoc NEWS
+
+ linux-mod_src_install
+}
diff --git a/sys-power/bbswitch/bbswitch-0.8.ebuild b/sys-power/bbswitch/bbswitch-0.8.ebuild
new file mode 100644
index 000000000000..bedd8989e904
--- /dev/null
+++ b/sys-power/bbswitch/bbswitch-0.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils linux-mod
+
+DESCRIPTION="Toggle discrete NVIDIA Optimus graphics card"
+HOMEPAGE="https://github.com/Bumblebee-Project/bbswitch"
+SRC_URI="https://github.com/Bumblebee-Project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ virtual/linux-sources
+ sys-kernel/linux-headers
+"
+RDEPEND=""
+
+MODULE_NAMES="bbswitch(acpi)"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="default"
+ BUILD_PARAMS="KVERSION=${KV_FULL}"
+}
+
+src_install() {
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/bbswitch.modprobe bbswitch.conf
+ dodoc NEWS README.md
+
+ linux-mod_src_install
+}
diff --git a/sys-power/bbswitch/files/bbswitch.modprobe b/sys-power/bbswitch/files/bbswitch.modprobe
new file mode 100644
index 000000000000..dd6500c77131
--- /dev/null
+++ b/sys-power/bbswitch/files/bbswitch.modprobe
@@ -0,0 +1 @@
+options bbswitch load_state=-1 unload_state=-1 \ No newline at end of file
diff --git a/sys-power/bbswitch/metadata.xml b/sys-power/bbswitch/metadata.xml
new file mode 100644
index 000000000000..2c9726db7a94
--- /dev/null
+++ b/sys-power/bbswitch/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+ <maintainer>
+ <email>mva@mva.name</email>
+ <name>Vadim A. Misbakh-Soloviov</name>
+ </maintainer>
+ <maintainer>
+ <email>rei4dan@gmail.com</email>
+ <name>My Th</name>
+ </maintainer>
+ <longdescription>
+ Kernel module which automatically detects the required ACPI calls for two
+ kinds of Optimus laptops for safe disabling/enabling the discrete graphics card.
+</longdescription>
+ <upstream>
+ <remote-id type="github">Bumblebee-Project/bbswitch</remote-id>
+ </upstream>
+</pkgmetadata>