summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gmail.com>2015-08-13 11:35:02 +0300
committerAndrew Savchenko <bircoph@gmail.com>2015-08-13 11:43:51 +0300
commitc89cc97d9a8f30e5762f1f32cf9c16a859de8c0d (patch)
treeb1603a000692e761a27ca0fa424651b103aad947 /sys-power/suspend
parentdev-dotnet/gnome-sharp 2.24.2-r1 (monolithic) (diff)
downloadgentoo-c89cc97d9a8f30e5762f1f32cf9c16a859de8c0d.tar.gz
gentoo-c89cc97d9a8f30e5762f1f32cf9c16a859de8c0d.tar.bz2
gentoo-c89cc97d9a8f30e5762f1f32cf9c16a859de8c0d.zip
sys-power/suspend: fix bug 556954
Fix build with fbsplash support in case when mediag-gfx/splashutils are compiled with media-libs/freetype support which is compiled with app-arch/bzip2 support. This issue is a combination of multiple bugs: 1. media-gfx/splashutils provides incomplete list of libraries for static linking. See bug 408283. 2. media-gfx/splashutils contains bogus entry in the list of static libraries. See bug 557126. 3. suspend asks splashutils for a list of dynamic libs instead of static. This is fixed in this commit. Signed-off-by: Andrew Savchenko <bircoph@gmail.com>
Diffstat (limited to 'sys-power/suspend')
-rw-r--r--sys-power/suspend/Manifest1
-rw-r--r--sys-power/suspend/suspend-1.0_p20150810.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-power/suspend/Manifest b/sys-power/suspend/Manifest
index 3c4fdccd2310..16d1f7f6f39f 100644
--- a/sys-power/suspend/Manifest
+++ b/sys-power/suspend/Manifest
@@ -1,3 +1,4 @@
DIST suspend-1.0_p20120915.tar.xz 111080 SHA256 4fa7551ec5ce3ed5d7412ad14e01f5fbac3a541db9d94ad6adf20b87d9c32eca SHA512 bb714b4a7c0f5749c4b711a5c38ca5d8cb5078176a75387957123f75cfe8348adc3aa4e96335eb65c14ad1dd2f99fd6dbca3b415525dd39b3c547f9b13b775be WHIRLPOOL 6f5ea4a17572bc1e30d70258a0439b40a29ea67f0251cecec81bdd3dee92e7801645c37dbb868b0f498c093193bd574f361dc015810965c09f53d75cfb391e7f
DIST suspend-1.0_p20150622.patch.xz 6052 SHA256 bc05a8896b89520b70a5c3b1a9903d94b75bc82756f6edbdddf53c6d1120af14 SHA512 8ca6d51e96b4d405133b4ee3bc246d79e4270052fe10202f94a85075dad314a33bb586ebbcf3a04c2ab93c74eb5f8d4e1dfca1c88fc56467d347eda147e4d3aa WHIRLPOOL 09f07d6ece378715c0bb1017ade8b97277f818e00accec0f2b5b4573664aafb68dc3713fe1780d4b38707120c0b62c35ec6d6818aec0f59ad3c14247b4cf1a7b
+DIST suspend-1.0_p20150810.patch.xz 6172 SHA256 5a07235c805dd3bb043ccc5ec1c18a3ca195912ea05fd3c007845825ebe3ed78 SHA512 cb186bdb0619ed4852e2ba12d6048f26fa23c7556d7c95713f14a4258fbb014bbec2281edee6478ebf5916600b674d47d8ba53e7644391de933b03e9fd1b96e9 WHIRLPOOL b1d9ba65f02ed4b507a586b5df71b897c147599db51905285cf55037e7c316f0392df432c81c99660abd7616dd60a816c4c2234bac3745eda84f6499cff7bdf4
DIST suspend-utils-1.0.tar.bz2 408451 SHA256 0206ba6332860b6da57acc79cc0f8604150ef0835ff9633fd42d59d181a6c85d SHA512 481f7ab6e6d43b963cf7abf4d16a9911035dbce13d96e11eeadd50bbd2b9671c597eab0e3060536dcb0d6d848e30ac0e7ff534275fc2d66d2064b75066a4adb8 WHIRLPOOL 4321dcaeda4b5b7d822a1cade82b88094d8706d0daaa06b72d3c053a4bac14ed85b55a4681e0a52f116a63e3b8f4255c57e55fb43961f77149faf1b8aa918d58
diff --git a/sys-power/suspend/suspend-1.0_p20150810.ebuild b/sys-power/suspend/suspend-1.0_p20150810.ebuild
new file mode 100644
index 000000000000..14f03d9383fb
--- /dev/null
+++ b/sys-power/suspend/suspend-1.0_p20150810.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+BASE_PV="1.0_p20120915"
+
+DESCRIPTION="Userspace Software Suspend and S2Ram"
+HOMEPAGE="http://suspend.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~bircoph/distfiles/${PN}-${BASE_PV}.tar.xz
+ http://dev.gentoo.org/~bircoph/patches/${P}.patch.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt fbsplash +lzo threads"
+
+RDEPEND="
+ dev-libs/libx86
+ crypt? (
+ >=dev-libs/libgcrypt-1.6.3:0[static-libs]
+ dev-libs/libgpg-error[static-libs] )
+ fbsplash? ( >=media-gfx/splashutils-1.5.4.4-r6 )
+ lzo? ( >=dev-libs/lzo-2[static-libs] ) "
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.10
+ >=sys-apps/pciutils-2.2.4
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${WORKDIR}/${P}.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable crypt encrypt) \
+ $(use_enable fbsplash) \
+ $(use_enable lzo compress) \
+ $(use_enable threads)
+}
+
+src_install() {
+ dodir etc
+ emake DESTDIR="${D}" install
+ rm "${D}/usr/share/doc/${PF}"/COPYING* || die
+}
+
+pkg_postinst() {
+ elog "In order to make this package work with genkernel see:"
+ elog "http://bugs.gentoo.org/show_bug.cgi?id=156445"
+}