summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-02-19 16:25:54 +0100
committerDavid Seifert <soap@gentoo.org>2018-02-19 16:25:54 +0100
commit5bd1a263f1ff2ea09ea5e1774a55ab344673f283 (patch)
treee0b3cc47579307205f6eeadd42806e5272c111cf /sys-power
parentdev-php/PEAR-Image_Color2: Revbump for EAPI and adding tests (diff)
downloadgentoo-5bd1a263f1ff2ea09ea5e1774a55ab344673f283.tar.gz
gentoo-5bd1a263f1ff2ea09ea5e1774a55ab344673f283.tar.bz2
gentoo-5bd1a263f1ff2ea09ea5e1774a55ab344673f283.zip
sys-power/thermald: Version bump to 1.7.1
Closes: https://bugs.gentoo.org/555368 Closes: https://bugs.gentoo.org/618948 Closes: https://bugs.gentoo.org/642220 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-1.7.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index 4532586c3f6a..4fd6599436d9 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -2,3 +2,4 @@ DIST thermald-1.4.2.tar.gz 89080 BLAKE2B 7dd2b734c46e006570ce8cd3ac11d922bcba6dc
DIST thermald-1.5.3.tar.gz 335067 BLAKE2B 209ef4e798ace8521f9164cf796cdf94efdd3c47ed71c18d52728070686ae10ad4d3c10d6c0a7bd727bfc6d834214d6876dcc406ce0877a903bbc175b40beec3 SHA512 aab4ade4dc50985cd5d45bcce6ea9b75cce22504eb113c86b8733c8be88a701c8812b8b0f3202f084a8128d50ec794ebe1c73312c0a5a5fd1dbc87eedf02df16
DIST thermald-1.5.4.tar.gz 336768 BLAKE2B c56f091bf0034f794ad3aad16d5f9ed0480822d4505efbaed65c413621f3f5da74032da25cfbd9ea6fbb46656e1a9f1626ddab288486e104f013791e4c462ccc SHA512 c23b4aabc59f11fe93074459d8343f587275771268d9c71c871da6bb46d8533a46ab9ac0b495c22771d9064288872abfd3180e3bc92dbe5842cff53046e543d6
DIST thermald-1.6.tar.gz 331682 BLAKE2B 2e8f18134f49cee618323438478b43b36454ebdeb9f50e972f3b4eefb4c01e40e01384e54c5c15d84e4d2ba9b7fd11f67fbe7b0839df2f2fc31bc42b200e1b85 SHA512 ddcd01dcd2f6b5666ffa16ba635734e4c146244b5df7c3f0deb8120f8ee7ebf1f4ee302d49db2b7e9a4950045650922977bd40bf6b38ccea9896f81e06df1d49
+DIST thermald-1.7.1.tar.gz 420725 BLAKE2B 99e176e978e56d453fe5ff409f048122d18b9c554ed3128dac1c704a61ab483ab3ca21c2c360d1dc763de9770f877948d62d8c2216072d23fa1b828913a8e766 SHA512 a78f8aa9ef0f3e3b57fc1ebbd7ad7e67985676ad7adf5b6a6d23e4aed4e2ccb8273fb67ccd9a2133f91f7f6b19f793c9ba68e41208aabde4248ca666061fe5e0
diff --git a/sys-power/thermald/thermald-1.7.1.ebuild b/sys-power/thermald/thermald-1.7.1.ebuild
new file mode 100644
index 000000000000..d3ca3808cb98
--- /dev/null
+++ b/sys-power/thermald/thermald-1.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon"
+SRC_URI="https://github.com/01org/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ # bug 618948
+ append-cxxflags -std=c++14
+
+ ECONF_SOURCE="${S}" econf \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED%/}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}