summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-06-05 15:27:33 +0800
committerYixun Lan <dlan@gentoo.org>2021-06-05 15:44:43 +0800
commita8cc1be6b352b2a8fbfc614a6f5b71e91c6517ab (patch)
tree8e5392ab1fe21c162f12ef8d1a1416b6ca1e3ab7 /sys-power
parentapp-misc/cmatrix: revbump, fix mtx font installation (diff)
downloadgentoo-a8cc1be6b352b2a8fbfc614a6f5b71e91c6517ab.tar.gz
gentoo-a8cc1be6b352b2a8fbfc614a6f5b71e91c6517ab.tar.bz2
gentoo-a8cc1be6b352b2a8fbfc614a6f5b71e91c6517ab.zip
sys-power/thermald: version bump, 2.4.5
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-2.4.5.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index d30db0a13c4d..b644a42d2802 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1,3 +1,4 @@
DIST thermald-2.4.1.tar.gz 455735 BLAKE2B ee4d6bc590bc50639c0b19adbba7e243358174a837b2ff155dea060b1cd09171d4fb77b18b785dc9f64a633f680358cb1d7b36e3bd438e5267e0a0a27e18497e SHA512 2dab7d57e028037208034ab4be95dc138ce028d4a47a0151c69816e1502065d801d52990641544b5d246144e654c15c663fa78af6cea094cf9a107f2fb29c1ef
DIST thermald-2.4.2.tar.gz 455797 BLAKE2B 5be01fa67defe738d2e9109388ab440ee93fea63e2fb56c2f5294095b14077330f1af4cba454e0f39bde69726f358513bec123f1eb7815afac469fb2385b6c9a SHA512 96d5cb9bf4f04b6ec5763d499416c246077b2d6dbc623de3fbb2b1fb8dc8b702d417852119240496f28f0a69c52be1b2a47e5d9ee7e952a123c621bda4d809ef
DIST thermald-2.4.3.tar.gz 455850 BLAKE2B 2348a5ce9175049e3cb2436ee6d7773af50ace9693956f5a0e64f9fbb28826004f5cf599887d7b4a8405680ecdf90dc04c054082bcca484151373e91d64eab1b SHA512 eda313aa91235ae024a673e9933267c3aa97a3a8e3e6501bf7daac24be747174b223c2f297e7b301477899d099878aa46c58cda936507c8d4683c4f14df009c0
+DIST thermald-2.4.5.tar.gz 455875 BLAKE2B f080dc065f5a0227cabed8e88d44c85c6e8ac932a6042b095a91840ea586213fe1b8ca93a04ee872f3e971d1efdd95c0f50357727d70b8e4fecd735e9c840f73 SHA512 8b7d75b3f1d7a98a9985c7552963cde19c81053d12fa39974c1129315fc23e66a432d9ada5d9e385989976453a83cf6418f410d3ce3317e23133d15d2ec37695
diff --git a/sys-power/thermald/thermald-2.4.5.ebuild b/sys-power/thermald/thermald-2.4.5.ebuild
new file mode 100644
index 000000000000..2683a9652ea6
--- /dev/null
+++ b/sys-power/thermald/thermald-2.4.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon https://github.com/intel/thermal_daemon"
+SRC_URI="https://github.com/intel/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ dev-libs/libevdev
+ sys-power/upower
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_prepare() {
+ sed -i -e "/group=/s/power/wheel/g" \
+ data/org.freedesktop.thermald.conf || die
+
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-werror \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}
+
+pkg_postinst() {
+ if ! has_version sys-power/dptfxtract; then
+ elog "dptfxtract can be used to generate a more specific"
+ elog "thermald configuration for your system"
+ fi
+}