summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteev Klimaszewski <steev@gentoo.org>2016-07-04 14:04:49 -0500
committerSteev Klimaszewski <steev@gentoo.org>2016-07-04 14:04:49 -0500
commit3129d67a8391aa393e56622410f0d94d61259bde (patch)
tree37c7f702ea08a1e5e601c8d3fd329ef8da064842 /sys-process/criu
parentdev-libs/log4cplus: Drop maintainership as announced on Wed, 16 Mar 2016 at t... (diff)
downloadgentoo-3129d67a8391aa393e56622410f0d94d61259bde.tar.gz
gentoo-3129d67a8391aa393e56622410f0d94d61259bde.tar.bz2
gentoo-3129d67a8391aa393e56622410f0d94d61259bde.zip
sys-process/criu: Fix passing arch to fix build on arm64
Upstream wants to do the aarch64 replacement themselves, so don't pass aarch64 in the ebuild, otherwise we end up with the following type error: make -j8 -l10 CC=aarch64-unknown-linux-gnu-gcc LD=aarch64-unknown-linux-gnu-ld OBJCOPY=aarch64-unknown-linux-gnu-objcopy LIBDIR=/usr/lib64 ARCH=aarch64 V=1 WERROR=0 DEBUG=0 SETPROCTITLE=no PYCRIU=no all docs Makefile:29: *** "The architecture aarch64 isn't supported". Stop. Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-process/criu')
-rw-r--r--sys-process/criu/criu-2.3.ebuild1
1 files changed, 0 insertions, 1 deletions
diff --git a/sys-process/criu/criu-2.3.ebuild b/sys-process/criu/criu-2.3.ebuild
index 971a67044fb9..d67ab0785488 100644
--- a/sys-process/criu/criu-2.3.ebuild
+++ b/sys-process/criu/criu-2.3.ebuild
@@ -47,7 +47,6 @@ criu_arch() {
# criu infers the arch from $(uname -m). We never want this to happen.
case ${ARCH} in
amd64) echo "x86";;
- arm64) echo "aarch64";;
*) echo "${ARCH}";;
esac
}