summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-12-01 22:56:16 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-12-19 17:12:32 -0800
commitb502abf5429ff3fe2972634f77136dd6d2d4201e (patch)
treee32bb4ef3bdab7cd55bebee2afb75539c536d588 /sys-process/numad
parentsys-process/numad: add service files (diff)
downloadgentoo-b502abf5429ff3fe2972634f77136dd6d2d4201e.tar.gz
gentoo-b502abf5429ff3fe2972634f77136dd6d2d4201e.tar.bz2
gentoo-b502abf5429ff3fe2972634f77136dd6d2d4201e.zip
sys-process/numad: revbump 0.5, install service files
This commit adds openrc service file, installs upstream provided systemd unit and also installs logrotate conf. Closes: https://github.com/gentoo/gentoo/pull/10536 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-process/numad')
-rw-r--r--sys-process/numad/numad-0.5-r3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-process/numad/numad-0.5-r3.ebuild b/sys-process/numad/numad-0.5-r3.ebuild
new file mode 100644
index 000000000000..9c3e8ee12be6
--- /dev/null
+++ b/sys-process/numad/numad-0.5-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd toolchain-funcs
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://pagure.io/numad.git"
+ inherit git-r3
+else
+ EGIT_COMMIT="334278ff3d774d105939743436d7378a189e8693"
+ SRC_URI="mirror://gentoo/numad-0.5-${EGIT_COMMIT:0:7}.tar.bz2"
+ KEYWORDS="~amd64 -arm ~arm64 -s390 ~x86"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT:0:7}"
+fi
+
+DESCRIPTION="The NUMA daemon that manages application locality"
+HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="~NUMA ~CPUSETS"
+
+PATCHES=(
+ "${FILESDIR}/0001-Fix-man-page-directory-creation.patch"
+ "${FILESDIR}/${PN}-0.5-ldlibs.patch"
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -std=gnu99"
+}
+
+src_install() {
+ emake prefix="${ED}/usr" install
+
+ newinitd "${FILESDIR}/numad.initd" numad
+ newconfd "${FILESDIR}/numad.confd" numad
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/numad.logrotated" numad
+
+ insinto /etc
+ doins numad.conf
+ systemd_dounit numad.service
+}