summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-04-27 17:36:40 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-04-27 17:56:46 +0300
commit3957d060aaf844999a121e2128e3cd3bd92e6dfc (patch)
treeeb76b3e575777c00386c16ee7bde9b74b993031c /sys-process
parentsys-kernel/pf-sources: bump to 5.6-pf5 (diff)
downloadgentoo-3957d060aaf844999a121e2128e3cd3bd92e6dfc.tar.gz
gentoo-3957d060aaf844999a121e2128e3cd3bd92e6dfc.tar.bz2
gentoo-3957d060aaf844999a121e2128e3cd3bd92e6dfc.zip
sys-process/uksmd: 2020-04-20 snapshot
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/uksmd/Manifest1
-rw-r--r--sys-process/uksmd/uksmd-0_pre20200420.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-process/uksmd/Manifest b/sys-process/uksmd/Manifest
index 62b393ac65dd..02cadc21c898 100644
--- a/sys-process/uksmd/Manifest
+++ b/sys-process/uksmd/Manifest
@@ -1 +1,2 @@
DIST uksmd-0_pre20190726.tar.bz2 13445 BLAKE2B 4d16b9e7dff80269561c61cf8ea4177e6ceaa2540a3ee5bb3a36684e8364d0a4abdfb494fd0dbb3e6d5d2c074601a0c39f9f0570448e3d5769e50184c8ef7975 SHA512 812217a067c2fe70a17a321b507071f369efa38ca12d566cde66b1fc6e2e3ffa7e4d3fd3904f2f3cf409e313d03ab06829cef23fffadd785282cb602dbd5f06e
+DIST uksmd-0_pre20200420.tar.bz2 13464 BLAKE2B 717bb4c54ce3d56ec89ff08e0a60ff3e1f2f260c3e63f7821842f7c1216aeee4efb1cad693db4f9c03000dbde7c47b880356f175cb35b9c3861f3511090e4f32 SHA512 ed1d44c41f2f8731d1dad8a13c17cf412a6f735a68087969cb667f85945705b93ac716f010aae24825c0b32d43c38dad5661c7a36fc59fa89d553471d806d1ee
diff --git a/sys-process/uksmd/uksmd-0_pre20200420.ebuild b/sys-process/uksmd/uksmd-0_pre20200420.ebuild
new file mode 100644
index 000000000000..c90b24e862ef
--- /dev/null
+++ b/sys-process/uksmd/uksmd-0_pre20200420.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+MY_COMMIT="9b6a6e55e07c524ba0a36eb25c869b47655010ee"
+MY_P="${PN}-${MY_COMMIT}"
+
+DESCRIPTION="Userspace KSM helper daemon"
+HOMEPAGE="https://gitlab.com/post-factum/uksmd"
+SRC_URI="https://gitlab.com/post-factum/uksmd/-/archive/${MY_COMMIT}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-process/procps:="
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~KSM"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/uksmd-0_pre20190726-respect-cflags-ldflags.patch" )
+
+src_install() {
+ default
+ einstalldocs
+
+ newinitd "${FILESDIR}/uksmd.init" uksmd
+ systemd_dounit distro/uksmd.service
+}