summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-06-09 12:54:27 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-06-09 12:54:27 +0200
commit864f7ee07715bdaf3a5681e042b7d93c814c5021 (patch)
treef17964a611d3a72b2d91e723a6e15b442fd51a45 /sys-process
parentgames-fps/urbanterror: Security cleanup (bug #606702) (diff)
downloadgentoo-864f7ee07715bdaf3a5681e042b7d93c814c5021.tar.gz
gentoo-864f7ee07715bdaf3a5681e042b7d93c814c5021.tar.bz2
gentoo-864f7ee07715bdaf3a5681e042b7d93c814c5021.zip
sys-process/fcron: Add v3.3.0 beta (bug #621200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/fcron/Manifest1
-rw-r--r--sys-process/fcron/fcron-3.3.0_beta.ebuild260
2 files changed, 261 insertions, 0 deletions
diff --git a/sys-process/fcron/Manifest b/sys-process/fcron/Manifest
index 405a72e3c834..3669e99fdccf 100644
--- a/sys-process/fcron/Manifest
+++ b/sys-process/fcron/Manifest
@@ -1 +1,2 @@
DIST fcron-3.2.1.src.tar.gz 601142 SHA256 6114d0a39a32853669c0c0ba0f96d92920e7cabca3ff1edf37d25750403e5f6a SHA512 ddfd3e3a297b843c924aacccffaa5c1c6b300497f39daa1cdb90dc4cf4bc757042b0b2c1f055c119c8128c64d830ee0e8757091610432f5ffcacca25d369e5cd WHIRLPOOL 39b44f88b09be40705ca5d1f421aa4bff6d9a00fbcb572b9012fb1dd65a24c3b1b746196e722bc544a6c0db062625d9981c60956a7fb7c34e6cb630202bd5a2b
+DIST fcron-3.3.0_beta.tar.gz 592481 SHA256 9aead33a0926e2eec123698c502114c6d67b483fe1ec232969fae6809b0bab60 SHA512 e5b76e23af774997d9ee1ef58d17009cea95d10b19a2d22b550b178a39bb7c439c055b440eb99c4286db6622901e5deb029318e4425e8cd098766452ffc15bc6 WHIRLPOOL ec814a8d23263539623ef6f3415313b80f22353c5ca72d556a537e4c46ca98818dbebf79966138c1de9e1f071478e782e01d9e3139fc9b75e981b3807e069a91
diff --git a/sys-process/fcron/fcron-3.3.0_beta.ebuild b/sys-process/fcron/fcron-3.3.0_beta.ebuild
new file mode 100644
index 000000000000..0ec297cae218
--- /dev/null
+++ b/sys-process/fcron/fcron-3.3.0_beta.ebuild
@@ -0,0 +1,260 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+WANT_AUTOMAKE=none
+
+inherit cron pam flag-o-matic user autotools versionator systemd
+
+MY_PV=${PV/_beta/}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="A command scheduler with extended capabilities over cron and anacron"
+HOMEPAGE="http://fcron.free.fr/"
+SRC_URI="http://fcron.free.fr/archives/${MY_P}.src.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS=""
+IUSE="audit debug pam selinux l10n_fr +mta +system-crontab readline"
+
+DEPEND="audit? ( sys-process/audit )
+ pam? ( virtual/pam )
+ readline? ( sys-libs/readline:= )
+ selinux? ( sys-libs/libselinux )"
+
+RDEPEND="${DEPEND}
+ app-misc/editor-wrapper
+ mta? ( virtual/mta )
+ pam? ( sys-auth/pambase )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-noreadline.patch
+ "${FILESDIR}"/${PN}-3.2.1-configure-fix-audit-parameter-check.patch
+)
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup fcron
+ enewuser fcron -1 -1 -1 fcron
+ rootuser=$(egetent passwd 0 | cut -d ':' -f 1)
+ [[ ${rootuser} ]] || rootuser=root
+ rootgroup=$(egetent group 0 | cut -d ':' -f 1)
+ [[ ${rootgroup} ]] || rootgroup=root
+}
+
+src_prepare() {
+ default
+
+ # respect LDFLAGS
+ sed -i "s:\(@LIBS@\):\$(LDFLAGS) \1:" Makefile.in || die "sed failed"
+
+ # Adjust fcrontab path
+ sed -i -e 's:/etc/fcrontab:/etc/fcron/fcrontab:' script/check_system_crontabs.sh || die
+
+ mv configure.in configure.ac || die
+
+ cp "${FILESDIR}"/crontab.2 "${WORKDIR}"/crontab || die
+
+ eautoconf
+}
+
+src_configure() {
+ # Don't try to pass --with-debug as it'll play with cflags as
+ # well, and run foreground which is a _very_ nasty idea for
+ # Gentoo.
+ use debug && append-cppflags -DDEBUG
+
+ # bindir is used just for calling fcronsighup
+ econf \
+ --with-cflags="${CFLAGS}" \
+ --bindir=/usr/libexec \
+ --sbindir=/usr/libexec \
+ $(use_with audit) \
+ $(use_with mta sendmail) \
+ $(use_with pam) \
+ $(use_with readline) \
+ $(use_with selinux) \
+ --sysconfdir=/etc/fcron \
+ --with-username=fcron \
+ --with-groupname=fcron \
+ --with-piddir=/run \
+ --with-spooldir=/var/spool/fcron \
+ --with-fifodir=/run \
+ --with-fcrondyn=yes \
+ --disable-checks \
+ --with-editor=/usr/libexec/editor \
+ --with-shell=/bin/sh \
+ --without-db2man \
+ --without-dsssl-dir \
+ --with-rootname=${rootuser} \
+ --with-rootgroup=${rootgroup} \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_compile() {
+ default
+
+ # bug #216460
+ sed -i \
+ -e 's:/usr/local/etc/fcron:/etc/fcron/fcron:g' \
+ -e 's:/usr/local/etc:/etc:g' \
+ -e 's:/usr/local/:/usr/:g' \
+ doc/*/*/*.{txt,1,5,8,html} \
+ || die "unable to fix documentation references"
+}
+
+src_install() {
+ keepdir /var/spool/fcron
+
+ exeinto /usr/libexec
+ doexe fcron fcronsighup
+
+ dobin fcrondyn fcrontab
+
+ insinto /etc/fcron
+ doins files/fcron.{allow,deny,conf}
+
+ if use system-crontab; then
+ dosym fcrontab /usr/bin/crontab
+
+ exeinto /usr/libexec
+ newexe script/check_system_crontabs.sh check_system_crontabs
+
+ insinto /etc/fcron
+ newins "${FILESDIR}"/fcrontab.2 fcrontab
+
+ fowners ${rootuser}:fcron /etc/fcron/fcrontab
+ fperms 0640 /etc/fcron/fcrontab
+
+ insinto /etc
+ newins "${FILESDIR}"/crontab.2 crontab
+ fi
+
+ fowners fcron:fcron \
+ /var/spool/fcron \
+ /usr/bin/fcron{dyn,tab}
+
+ # fcronsighup needs to be suid root, because it sends a HUP to the
+ # running fcron daemon, but only has to be called by the fcron group
+ # anyway
+ fowners ${rootuser}:fcron \
+ /usr/libexec/fcronsighup \
+ /etc/fcron/fcron.{allow,deny,conf} \
+ /etc/fcron
+
+ fperms 6770 /var/spool/fcron
+ fperms 6775 /usr/bin/fcron{dyn,tab}
+
+ fperms 4710 /usr/libexec/fcronsighup
+
+ fperms 0750 /etc/fcron
+ fperms 0640 /etc/fcron/fcron.{allow,deny,conf}
+
+ pamd_mimic system-services fcron auth account session
+ cat > "${T}"/fcrontab.pam <<- EOF
+ # Don't ask for the user's password; fcrontab will only allow to
+ # change user if running as root.
+ auth sufficient pam_permit.so
+
+ # Still use the system-auth stack for account and session as the
+ # sysadmin might have set up stuff properly, and also avoids
+ # sidestepping limits (since fcrontab will run \$EDITOR).
+ account include system-auth
+ session include system-auth
+ EOF
+ newpamd "${T}"/fcrontab.pam fcrontab
+
+ newinitd "${FILESDIR}"/fcron.init.4 fcron
+ systemd_newunit "${S}/script/fcron.init.systemd" fcron.service
+
+ local DOCS=( MANIFEST VERSION "${WORKDIR}/crontab")
+ DOCS+=( doc/en/txt/{readme,thanks,faq,todo,relnotes,changes}.txt )
+
+ local HTML_DOCS=( doc/en/HTML/. )
+
+ einstalldocs
+
+ newdoc files/fcron.conf fcron.conf.sample
+ doman doc/en/man/*.{1,5,8}
+
+ for lang in fr; do
+ use l10n_${lang} || continue
+
+ doman -i18n=${lang} doc/${lang}/man/*.{1,5,8}
+
+ docinto html/${lang}
+ dodoc -r doc/${lang}/HTML/.
+ done
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "Make sure you execute"
+ elog ""
+ elog " # emerge --config ${CATEGORY}/${PN}"
+ elog ""
+ elog "to install the default systab on this system."
+ else
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least "3.2.1" ${v}; then
+ # This is an upgrade
+
+ elog "fcron's default systab was updated since your last installation."
+ elog "You can use"
+ elog ""
+ elog " # emerge --config ${CATEGORY}/${PN}"
+ elog ""
+ elog "to re-install systab (do not call this command before you"
+ elog "have merged your configuration files)."
+
+ # Show this elog only once
+ break
+ fi
+ done
+ fi
+
+ if ! use system-crontab; then
+ echo ""
+ ewarn "Remember that fcron will *not* use /etc/cron.d in this configuration"
+ ewarn "due to USE=-system-crontab!"
+ echo ""
+ fi
+}
+
+pkg_config() {
+ if [[ $(fcrontab -l -u systab 2>/dev/null) ]]; then
+ eerror "We're not going to make any change to your systab as long as"
+ eerror "it contains data; please clear it before proceeding."
+ eerror "You can do that with"
+ eerror ""
+ eerror " # fcrontab -u systab -r"
+ eerror ""
+ eerror "However you are advised to do this by hand to review existing"
+ eerror "systab just in case."
+ return 1
+ fi
+
+ if use system-crontab; then
+ elog "This is going to set up fcron to execute check_system_crontabs."
+ elog "In this configuration, /etc/crontab and /etc/cron.d are respected."
+ elog "Per default fcron will check for modifications every 10 minutes."
+ /usr/libexec/check_system_crontabs -v -i -f
+ else
+ elog "This is going to set up fcron to set up a default systab that"
+ elog "executes /etc/cron.{hourly,daily,weekly,monthly} but will ignore"
+ elog "/etc/crontab and /etc/cron.d."
+ fcrontab -u systab - <<- EOF
+ !serial(true)
+ 00 * * * * /bin/rm -f /var/spool/cron/lastrun/cron.hourly
+ 00 00 * * * /bin/rm -f /var/spool/cron/lastrun/cron.daily
+ 00 00 * * 6 /bin/rm -f /var/spool/cron/lastrun/cron.weekly
+ 00 00 1 * * /bin/rm -f /var/spool/cron/lastrun/cron.monthly
+ */10 * * * * /usr/bin/test -x /usr/sbin/run-crons && /usr/sbin/run-crons
+ !serial(false)
+ EOF
+ fi
+}