summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-02-07 20:56:57 -0500
committerCraig Andrews <candrews@gentoo.org>2020-02-07 21:00:52 -0500
commit2709573762f25f18d999ab75c3cf821708d08196 (patch)
treeccc4718e47b5eb14927fb31d7f565413dee995fc /www-apache/mod_h2
parentnet-p2p/cpuminer-opt: 3.12.0.1 version bump (diff)
downloadgentoo-2709573762f25f18d999ab75c3cf821708d08196.tar.gz
gentoo-2709573762f25f18d999ab75c3cf821708d08196.tar.bz2
gentoo-2709573762f25f18d999ab75c3cf821708d08196.zip
www-apache/mod_h2: 1.15.6 version bump
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache/mod_h2')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-1.15.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index ea772dbbf534..aaaa9be7bdc4 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_http2-1.15.5.tar.gz 1041643 BLAKE2B 59591d919451a96595c8e75155f84e63876e95b13940af5473fe4cf0a29ac91f57d3df22911397de213482c5a81d093ce81ce3835136ace50de0d4f70f2a936a SHA512 6255a46a22e5df6f8fed9ce65079979a3c613cccf1a95559ff0832ab2efe5fb98d51abfe83c006b9a3c7452bb4e78e3e67e94d7c14618fa312c7236a34e6b280
+DIST mod_http2-1.15.6.tar.gz 1028795 BLAKE2B 4f323b00a133de13f547fd5b0402ce48d681289675cfd85dbef25b8432598772ddbb1fa78abd7905c2c4337a41340078efe903fc7cb4203cabdad10f71ef387a SHA512 2d27de99108d444e3095cf84d5ccf1b281bd09e2d2d4c4ba4ecc7b6519119d4d42e9379285bd68ce7f56349a9f27062b516df8b7612df7551a46e8a4b4b634ef
diff --git a/www-apache/mod_h2/mod_h2-1.15.6.ebuild b/www-apache/mod_h2/mod_h2-1.15.6.ebuild
new file mode 100644
index 000000000000..b5be17b7ca7d
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-1.15.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}