summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-01-07 10:26:59 -0500
committerCraig Andrews <candrews@gentoo.org>2019-01-07 10:28:36 -0500
commita6bfbef9dcc81f366ad063879623444d4a58e714 (patch)
tree496cf7f8b15ef35e7178554cfadb10e8b0f036d1 /www-apache/mod_h2
parentRevert "net-libs/gnutls: build with guile-2.2" (diff)
downloadgentoo-a6bfbef9dcc81f366ad063879623444d4a58e714.tar.gz
gentoo-a6bfbef9dcc81f366ad063879623444d4a58e714.tar.bz2
gentoo-a6bfbef9dcc81f366ad063879623444d4a58e714.zip
www-apache/mod_h2: 1.12.0 version bump
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache/mod_h2')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-1.12.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 0f88842496cb..a8249f526ef9 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1,3 +1,4 @@
DIST mod_http2-1.10.10.tar.gz 528560 BLAKE2B 7389441b1d30d0448bb17fc02a73957cf20365020796ce7260c1d63d1468537ecdeab83db12d1b245af1e760236da8e8d0ccf9ffb222d2dec1e55491ac77dc11 SHA512 b4b9e734ed35ca63fa114462f1adb358bb73e4cbd8df95ab28c4518b8f7db40233f4ba13bc2194847eb9c1adbc3eb86fc63cbb56389fc0867767658d4d8ba77b
DIST mod_http2-1.11.3.tar.gz 1028467 BLAKE2B 3a5d644f87104e1f7baae05396fefe94975e86e9289bb9c4e6d7ed94e45e1d9b38dfc79d0e0d9ee9270efedcd811db2374c898e419d4c16f73b38f53512e91ed SHA512 b97697f44eab9984b7dcaa7d941f23375cd5c2c81405842e17910a37dc2c952fc36a37e0802755457ccedd196c5fd2fb5b60467cb0ed16ed7aeb88cce4eabd2f
DIST mod_http2-1.11.4.tar.gz 1028706 BLAKE2B f2c662913a30e96fe28d68690cf0fe33e4de2d7072bb46016f063a9aa979dfdbb9e39f88110c56bc3a319e1220365159fd0c15356bfbf981ae57377e137c1e96 SHA512 1347e8fe4d88d8d87ca547270a27ac63c7b7804b57a06a225ab4199a24a55ad3048cb4c7a50fb7cc2ea2a78b2cf0f1dd8f5bad6191d2854df30042f0d64e6a1c
+DIST mod_http2-1.12.0.tar.gz 1029587 BLAKE2B 10578491ce39b91e1d6363cb98d45c2c3ca74c5126af489b1c4261e80aef907b9b737a9322a54a144af7cd0892b8d0c0a86ba4467aeaf826199b989226593154 SHA512 50d8d8e44ba8d4516fac642aea9c2ce5afe766aaa1bb930ca64fd9fdb4983ee5db9677d4e9d10d88391d39b9a9be127594a90670493c39ef6368e073456034f0
diff --git a/www-apache/mod_h2/mod_h2-1.12.0.ebuild b/www-apache/mod_h2/mod_h2-1.12.0.ebuild
new file mode 100644
index 000000000000..3e6d435d3f82
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-1.12.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}