summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-02-07 16:39:17 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-02-07 16:41:37 -0800
commit3d44e2d5ebd9837924b766627ab58d55cec43afa (patch)
tree103b9f433379c8a962907df59bd387e253bbcc47 /www-apache/mod_perl
parentmedia-sound/wavpack: ppc stable (bug 607054). (diff)
downloadgentoo-3d44e2d5ebd9837924b766627ab58d55cec43afa.tar.gz
gentoo-3d44e2d5ebd9837924b766627ab58d55cec43afa.tar.bz2
gentoo-3d44e2d5ebd9837924b766627ab58d55cec43afa.zip
www-apache/mod_perl: missing DEPEND
mod_perl needs the APR_ECRYPT header definition which was introduced in apr-util-1.4.x. Any box with only apr-util-1.3.x would fail to compile otherwise. Compile failure found during infra upgrades, as nothing else brought in newer apr-util on old systems. Package-Manager: portage-2.3.2
Diffstat (limited to 'www-apache/mod_perl')
-rw-r--r--www-apache/mod_perl/mod_perl-2.0.10.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/www-apache/mod_perl/mod_perl-2.0.10.ebuild b/www-apache/mod_perl/mod_perl-2.0.10.ebuild
index 000d701bca8..61a70b44413 100644
--- a/www-apache/mod_perl/mod_perl-2.0.10.ebuild
+++ b/www-apache/mod_perl/mod_perl-2.0.10.ebuild
@@ -29,6 +29,7 @@ RDEPEND="
dev-lang/perl[ithreads=]
>=dev-perl/Apache-Test-1.400.0
>=www-servers/apache-2.0.47
+ >=dev-libs/apr-util-1.4
!ithreads? ( www-servers/apache[-apache2_mpms_event,-apache2_mpms_worker,apache2_mpms_prefork] )
"
DEPEND="${RDEPEND}