summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-22 00:38:43 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-22 00:39:12 +0100
commita51f0209d1d749e4749c6bab33ba130549892f66 (patch)
treee947a3747a54addc88b62e657908aa810c03e6c7 /www-apache/mod_perl
parentsys-fs/ecryptfs-utils: add support for USE=nls (diff)
downloadgentoo-a51f0209d1d749e4749c6bab33ba130549892f66.tar.gz
gentoo-a51f0209d1d749e4749c6bab33ba130549892f66.tar.bz2
gentoo-a51f0209d1d749e4749c6bab33ba130549892f66.zip
www-apache/mod_perl: Partly fix tests, bug 614684
Partly fix tests; the breakage was *not* caused by Perl, but by Apache 2.4 (as opposed to Apache 2.2). Patches from Debian. Still fails with a similar problem (syntax error in test config file, bc. of old Apache syntax). Bug: https://bugs.gentoo.org/614684 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'www-apache/mod_perl')
-rw-r--r--www-apache/mod_perl/files/mod_perl-2.0.10-apache24-tests-1.patch33
-rw-r--r--www-apache/mod_perl/files/mod_perl-2.0.10-apache24-tests-2.patch23
-rw-r--r--www-apache/mod_perl/mod_perl-2.0.10.ebuild4
3 files changed, 59 insertions, 1 deletions
diff --git a/www-apache/mod_perl/files/mod_perl-2.0.10-apache24-tests-1.patch b/www-apache/mod_perl/files/mod_perl-2.0.10-apache24-tests-1.patch
new file mode 100644
index 000000000000..822fb4e87550
--- /dev/null
+++ b/www-apache/mod_perl/files/mod_perl-2.0.10-apache24-tests-1.patch
@@ -0,0 +1,33 @@
+From f4dd0394f0975892b51a889f023d0e207553a656 Mon Sep 17 00:00:00 2001
+From: Niko Tyni <ntyni@debian.org>
+Date: Fri, 23 Dec 2016 18:27:23 +0200
+Subject: [PATCH 1/2] Fix t/apache/read.t HTTP syntax for Apache 2.4.25
+ compatibility
+
+HTTP/1.1 RFC 7230, section 2.6. "Protocol Versioning" says the HTTP name
+is case sensitive. Starting with Apache 2.4.25, using lower case will
+make the server issue a 400 Bad request response, causing a test failure.
+
+https://tools.ietf.org/html/rfc7230#section-2.6
+
+Bug-Debian: https://bugs.debian.org/849082
+---
+ t/apache/read.t | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/apache/read.t b/t/apache/read.t
+index 83670c9..9f7f504 100644
+--- a/t/apache/read.t
++++ b/t/apache/read.t
+@@ -24,7 +24,7 @@ close $fh;
+
+ my $size = length $data;
+
+-for my $string ("POST $location http/1.0",
++for my $string ("POST $location HTTP/1.0",
+ "Content-length: $size",
+ "") {
+ my $line = "$string\r\n";
+--
+2.11.0
+
diff --git a/www-apache/mod_perl/files/mod_perl-2.0.10-apache24-tests-2.patch b/www-apache/mod_perl/files/mod_perl-2.0.10-apache24-tests-2.patch
new file mode 100644
index 000000000000..29e24cc770d6
--- /dev/null
+++ b/www-apache/mod_perl/files/mod_perl-2.0.10-apache24-tests-2.patch
@@ -0,0 +1,23 @@
+Author: Stefan Fritsch <sf@sfritsch.de>
+Source: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=849082
+
+--- ./t/filter/TestFilter/in_bbs_inject_header.pm.orig 2016-10-27 22:11:16.000000000 +0200
++++ ./t/filter/TestFilter/in_bbs_inject_header.pm 2016-12-24 06:55:19.049606491 +0100
+@@ -181,7 +181,7 @@
+
+ if ($data and $data =~ /^POST/) {
+ # demonstrate how to add a header while processing other headers
+- my $header = "$header1_key: $header1_val\n";
++ my $header = "$header1_key: $header1_val\r\n";
+ push @{ $ctx->{buckets} }, APR::Bucket->new($c->bucket_alloc, $header);
+ debug "queued header [$header]";
+ }
+@@ -199,7 +199,7 @@
+ # we hit the headers and body separator, which is a good
+ # time to add extra headers:
+ for my $key (keys %headers) {
+- my $header = "$key: $headers{$key}\n";
++ my $header = "$key: $headers{$key}\r\n";
+ push @{ $ctx->{buckets} }, APR::Bucket->new($c->bucket_alloc, $header);
+ debug "queued header [$header]";
+ }
diff --git a/www-apache/mod_perl/mod_perl-2.0.10.ebuild b/www-apache/mod_perl/mod_perl-2.0.10.ebuild
index f83252b19f5f..ea0cffbccc06 100644
--- a/www-apache/mod_perl/mod_perl-2.0.10.ebuild
+++ b/www-apache/mod_perl/mod_perl-2.0.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -60,6 +60,8 @@ PATCHES=(
"${FILESDIR}/${PN}"-2.0.4-inline.patch # 550244
"${FILESDIR}/${PN}"-2.0.10_rc1-bundled-Apache-Test.patch # 352724
"${FILESDIR}/${PN}"-2.0.10_rc1-Gentoo-not-Unix.patch
+ "${FILESDIR}/${PN}"-2.0.10-apache24-tests-1.patch # 614684
+ "${FILESDIR}/${PN}"-2.0.10-apache24-tests-2.patch # 614684
)
src_prepare() {