summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-02-03 22:43:23 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-02-03 22:44:03 -0800
commite27754fd8b411c54786f4eeec67283913e38b991 (patch)
tree3e6fc3be5d9f6274e7335eb916cdbc3bceb85a2b /www-apache/passenger
parentnet-dns/libidn2-0.16-r0: keyworded for ~arm64 (diff)
downloadgentoo-e27754fd8b411c54786f4eeec67283913e38b991.tar.gz
gentoo-e27754fd8b411c54786f4eeec67283913e38b991.tar.bz2
gentoo-e27754fd8b411c54786f4eeec67283913e38b991.zip
www-apache/passenger: bug#580078 isnan compile fix.
Fixes: https://bugs.gentoo.org/show_bug.cgi?id=580078 Package-Manager: portage-2.3.2 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'www-apache/passenger')
-rw-r--r--www-apache/passenger/files/passenger-5.1.1-isnan.patch14
-rw-r--r--www-apache/passenger/passenger-5.0.30.ebuild1
-rw-r--r--www-apache/passenger/passenger-5.1.0.ebuild3
-rw-r--r--www-apache/passenger/passenger-5.1.1.ebuild1
-rw-r--r--www-apache/passenger/passenger-5.1.2.ebuild1
5 files changed, 19 insertions, 1 deletions
diff --git a/www-apache/passenger/files/passenger-5.1.1-isnan.patch b/www-apache/passenger/files/passenger-5.1.1-isnan.patch
new file mode 100644
index 000000000000..02f7fe76df06
--- /dev/null
+++ b/www-apache/passenger/files/passenger-5.1.1-isnan.patch
@@ -0,0 +1,14 @@
+diff -uNr passenger-5.1.1.orig/src/cxx_supportlib/vendor-modified/boost/math/special_functions/fpclassify.hpp passenger-5.1.1/src/cxx_supportlib/vendor-modified/boost/math/special_functions/fpclassify.hpp
+--- passenger-5.1.1.orig/src/cxx_supportlib/vendor-modified/boost/math/special_functions/fpclassify.hpp 2013-10-26 15:00:00.000000000 -0700
++++ passenger-5.1.1/src/cxx_supportlib/vendor-modified/boost/math/special_functions/fpclassify.hpp 2017-01-12 19:21:39.696285758 -0800
+@@ -134,8 +134,8 @@
+ inline bool is_nan_helper(__float128 f, const boost::true_type&) { return ::isnanq(f); }
+ inline bool is_nan_helper(__float128 f, const boost::false_type&) { return ::isnanq(f); }
+ #else
+-inline bool is_nan_helper(__float128 f, const boost::true_type&) { return ::isnan(static_cast<double>(f)); }
+-inline bool is_nan_helper(__float128 f, const boost::false_type&) { return ::isnan(static_cast<double>(f)); }
++inline bool is_nan_helper(__float128 f, const boost::true_type&) { return std::isnan(static_cast<double>(f)); }
++inline bool is_nan_helper(__float128 f, const boost::false_type&) { return std::isnan(static_cast<double>(f)); }
+ #endif
+ #endif
+ }
diff --git a/www-apache/passenger/passenger-5.0.30.ebuild b/www-apache/passenger/passenger-5.0.30.ebuild
index f40d4a1bcbde..c78c96306207 100644
--- a/www-apache/passenger/passenger-5.0.30.ebuild
+++ b/www-apache/passenger/passenger-5.0.30.ebuild
@@ -43,6 +43,7 @@ pkg_setup() {
all_ruby_prepare() {
epatch "${FILESDIR}"/${PN}-5.0.20-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-5.1.1-isnan.patch
# Change these with sed instead of a patch so that we can easily use
# the toolchain-funcs methods.
diff --git a/www-apache/passenger/passenger-5.1.0.ebuild b/www-apache/passenger/passenger-5.1.0.ebuild
index e230887dc8c6..ed1c2645c8fe 100644
--- a/www-apache/passenger/passenger-5.1.0.ebuild
+++ b/www-apache/passenger/passenger-5.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -43,6 +43,7 @@ pkg_setup() {
all_ruby_prepare() {
epatch "${FILESDIR}"/${PN}-5.0.20-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-5.1.1-isnan.patch
# Change these with sed instead of a patch so that we can easily use
# the toolchain-funcs methods.
diff --git a/www-apache/passenger/passenger-5.1.1.ebuild b/www-apache/passenger/passenger-5.1.1.ebuild
index 4d3390bcfb51..ed1c2645c8fe 100644
--- a/www-apache/passenger/passenger-5.1.1.ebuild
+++ b/www-apache/passenger/passenger-5.1.1.ebuild
@@ -43,6 +43,7 @@ pkg_setup() {
all_ruby_prepare() {
epatch "${FILESDIR}"/${PN}-5.0.20-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-5.1.1-isnan.patch
# Change these with sed instead of a patch so that we can easily use
# the toolchain-funcs methods.
diff --git a/www-apache/passenger/passenger-5.1.2.ebuild b/www-apache/passenger/passenger-5.1.2.ebuild
index 12ff286c38c1..07eca2ff1204 100644
--- a/www-apache/passenger/passenger-5.1.2.ebuild
+++ b/www-apache/passenger/passenger-5.1.2.ebuild
@@ -43,6 +43,7 @@ pkg_setup() {
all_ruby_prepare() {
epatch "${FILESDIR}"/${PN}-5.0.20-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-5.1.1-isnan.patch
# Change these with sed instead of a patch so that we can easily use
# the toolchain-funcs methods.