summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-03 14:04:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-03 14:11:51 +0200
commitc86b235dd20616fa9f5f70ca763c237d68c5eb76 (patch)
tree7a95074b6d4fbd43409773d54f53ee7cbd85a14a /www-apache
parentnet-p2p/amule: Fix compilation with libupnp 1.14. (diff)
downloadgentoo-c86b235dd20616fa9f5f70ca763c237d68c5eb76.tar.gz
gentoo-c86b235dd20616fa9f5f70ca763c237d68c5eb76.tar.bz2
gentoo-c86b235dd20616fa9f5f70ca763c237d68c5eb76.zip
www-apache/mod_wsgi: Bump to version 4.7.1
- Bumped to EAPI-6 - Added python3_8 support - Explicitly call python-single-r1_pkg_setup - Worked around apache-modules.eclass annoyances - Forced bash as config shell because configure script contains bashisms Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_wsgi/Manifest1
-rw-r--r--www-apache/mod_wsgi/mod_wsgi-4.7.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/www-apache/mod_wsgi/Manifest b/www-apache/mod_wsgi/Manifest
index c706d88013e..689110d93b0 100644
--- a/www-apache/mod_wsgi/Manifest
+++ b/www-apache/mod_wsgi/Manifest
@@ -1,3 +1,4 @@
DIST mod_wsgi-4.5.13.tar.gz 679121 BLAKE2B 310a6a56495883439fad4a5ee7b30e749aaec4131bc039fd378018c30c9b61f1cb2c8b0ed6339c4a9cf556571e2713ff356b04007f1e2a10bcac52ddd5e5d14f SHA512 94bf6ae0d76ece67682a8ca3b7f202bb08a1f3e09e42c33f52b561a57ac8265ca2f5431f839bfe731eb014f279b0d865fd007f14a4839c934d372390d24a44a2
DIST mod_wsgi-4.6.5.tar.gz 693825 BLAKE2B 1564c331505706548ed171a6f57ad8947eea257295ecae56c0d3e87c4d15743ea4bb0275ae94a6168912ff27fcfcd06eec823b8332d19895ed803ad6164da77b SHA512 5f1526b74ea59c8ef897b49b1b2f2de42d9d0144277fd74f9f8e1f3e0198735f98ec30f726883a3192d0ed33a4013232cb2adf8db9d817b4de0198890eaa7044
DIST mod_wsgi-4.7.0.tar.gz 695658 BLAKE2B 4332e5c30219cde9cf44c8633f3052faa104524d5a2ccd151fe9675364760cb9c447001289094c57cef21df4e364962c93e85f3a3eef36325e9b96e7715dfc19 SHA512 4c40a07301ef7f42ff175cfd5efd9c4916ba90749780cdc470cc0c62b190af810ba4284504f2b342c1e92801637aa52ba5719e0b114a072fd50d68754abdf36f
+DIST mod_wsgi-4.7.1.tar.gz 696111 BLAKE2B 69fea421077f1ecbf1cef5c9eac4ba296fa676e0bfbb860ca8a7cb701701f405edb3760486b87e8d9dd93efcb4c23385197d770ca32e16a473d5d252d292fb76 SHA512 cbb5ec53d55e47a83f2b0630527c6a52b48ef21d5d2c18adcb875fc455795b39b3c93f4a86dfbf9738c0bd554d86cc4912cc9ff83c428af302ab94a61f66b5b4
diff --git a/www-apache/mod_wsgi/mod_wsgi-4.7.1.ebuild b/www-apache/mod_wsgi/mod_wsgi-4.7.1.ebuild
new file mode 100644
index 00000000000..9415402eae8
--- /dev/null
+++ b/www-apache/mod_wsgi/mod_wsgi-4.7.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit apache-module eutils python-single-r1
+
+DESCRIPTION="An Apache2 module for running Python WSGI applications"
+HOMEPAGE="https://github.com/GrahamDumpleton/mod_wsgi"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="WSGI"
+APACHE2_MOD_FILE="${S}/src/server/.libs/${PN}.so"
+
+DOCFILES="README.rst"
+
+need_apache2
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ # Calling depend.apache_pkg_setup fails because we do not have
+ # "apache2" in IUSE but the function expects this in order to call
+ # _init_apache2_late which sets the APACHE_MODULESDIR variable.
+ _init_apache2
+ _init_apache2_late
+}
+
+src_configure() {
+ # configure.ac contains bashisms
+ # (https://github.com/GrahamDumpleton/mod_wsgi/issues/567)
+ CONFIG_SHELL="/bin/bash" \
+ econf --with-apxs="${APXS}" --with-python="${PYTHON}"
+}
+
+src_compile() {
+ default
+}