summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/ampache
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/ampache')
-rw-r--r--www-apps/ampache/Manifest3
-rw-r--r--www-apps/ampache/ampache-3.4.3.ebuild37
-rw-r--r--www-apps/ampache/ampache-3.5.3-r1.ebuild41
-rw-r--r--www-apps/ampache/ampache-3.5.4.ebuild47
-rw-r--r--www-apps/ampache/files/installdoc.txt6
-rw-r--r--www-apps/ampache/metadata.xml8
6 files changed, 142 insertions, 0 deletions
diff --git a/www-apps/ampache/Manifest b/www-apps/ampache/Manifest
new file mode 100644
index 000000000000..b5d87cb47a8c
--- /dev/null
+++ b/www-apps/ampache/Manifest
@@ -0,0 +1,3 @@
+DIST ampache-3.4.3.tar.gz 1414765 SHA256 001b34abb77a830ce5f67d9823b8fbeba75a517b577c650349843854deb8d0eb
+DIST ampache-3.5.3.tar.gz 1962048 SHA256 b4c0d58754007c19dc959659cf43442d9f0cf3ebdbeb35b8e2845870bca0ca4c
+DIST ampache-3.5.4.tar.gz 1961555 SHA256 f5ee6906d2af60ea8dcbd1b3a18119ffbe6b92c21c0b0c59a1ba01e5bead5f74
diff --git a/www-apps/ampache/ampache-3.4.3.ebuild b/www-apps/ampache/ampache-3.4.3.ebuild
new file mode 100644
index 000000000000..d108331ed3a4
--- /dev/null
+++ b/www-apps/ampache/ampache-3.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit webapp depend.php
+
+DESCRIPTION="Ampache is a PHP-based tool for managing, updating and playing your audio files via a web interface"
+HOMEPAGE="http://www.ampache.org/"
+SRC_URI="http://www.ampache.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_php_with_use pcre session unicode iconv xml mysql gd zlib
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc docs/*
+ rm -rf docs/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}"/installdoc.txt
+ webapp_src_install
+}
diff --git a/www-apps/ampache/ampache-3.5.3-r1.ebuild b/www-apps/ampache/ampache-3.5.3-r1.ebuild
new file mode 100644
index 000000000000..3b818d75193e
--- /dev/null
+++ b/www-apps/ampache/ampache-3.5.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit webapp
+
+DESCRIPTION="Ampache is a PHP-based tool for managing, updating and playing your audio files via a web interface"
+HOMEPAGE="http://www.ampache.org/"
+SRC_URI="http://www.ampache.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="dev-lang/php[gd,hash,iconv,mysql,session,unicode,xml,zlib]
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )"
+DEPEND=""
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc docs/*
+ rm -rf docs/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}"/installdoc.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "Install and upgrade instructions can be found here:"
+ elog " /usr/share/doc/${P}/INSTALL.bz2"
+ elog " /usr/share/doc/${P}/MIGRATION.bz2"
+ webapp_pkg_postinst
+}
diff --git a/www-apps/ampache/ampache-3.5.4.ebuild b/www-apps/ampache/ampache-3.5.4.ebuild
new file mode 100644
index 000000000000..1040dd0bc445
--- /dev/null
+++ b/www-apps/ampache/ampache-3.5.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit webapp
+
+DESCRIPTION="Ampache is a PHP-based tool for managing, updating and playing your audio files via a web interface"
+HOMEPAGE="http://www.ampache.org/"
+SRC_URI="http://www.ampache.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="aac flac mp3 ogg transcode"
+
+RDEPEND="dev-lang/php[gd,hash,iconv,mysql,session,unicode,xml,zlib]
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ transcode? ( media-sound/lame
+ aac? ( || ( media-libs/faad2 media-sound/alac_decoder ) )
+ flac? ( media-libs/flac )
+ mp3? ( media-sound/mp3splt )
+ ogg? ( media-sound/mp3splt media-sound/vorbis-tools )
+ )"
+DEPEND=""
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc docs/*
+ rm -rf docs/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}"/installdoc.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "Install and upgrade instructions can be found here:"
+ elog " /usr/share/doc/${P}/INSTALL.bz2"
+ elog " /usr/share/doc/${P}/MIGRATION.bz2"
+ webapp_pkg_postinst
+}
diff --git a/www-apps/ampache/files/installdoc.txt b/www-apps/ampache/files/installdoc.txt
new file mode 100644
index 000000000000..cdd6e118238e
--- /dev/null
+++ b/www-apps/ampache/files/installdoc.txt
@@ -0,0 +1,6 @@
+Install and upgrade instructions can be found here:
+/usr/share/doc/ampache-<version>/INSTALL.gz
+/usr/share/doc/ampache-<version>/MIGRATION.gz
+
+For general information please read:
+/usr/share/doc/ampache-<version>/README.gz
diff --git a/www-apps/ampache/metadata.xml b/www-apps/ampache/metadata.xml
new file mode 100644
index 000000000000..c87b0e76868e
--- /dev/null
+++ b/www-apps/ampache/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <use>
+ <flag name='transcode'>Install optional dependencies for transcoding support</flag>
+ </use>
+</pkgmetadata>