summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-04-22 02:12:04 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-04-22 02:12:27 +0000
commitd34e0d9b24de1160f4dc263e8982cf37a4bf2c7a (patch)
tree08aed30a300d1a3bba6e31bba2c9b16e5497314c /www-apps/drupal
parentdev-util/gertty: add git master version (diff)
downloadgentoo-d34e0d9b24de1160f4dc263e8982cf37a4bf2c7a.tar.gz
gentoo-d34e0d9b24de1160f4dc263e8982cf37a4bf2c7a.tar.bz2
gentoo-d34e0d9b24de1160f4dc263e8982cf37a4bf2c7a.zip
www-apps/drupal: Security bump - SA-CORE-2019-006.
Bug: https://bugs.gentoo.org/683820 Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-8.5.15.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 5061da861c8d..f8f1020feba0 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,2 +1,3 @@
DIST drupal-7.66.tar.gz 3300183 BLAKE2B 89d82c7018ecade0f798df92087d704ca9f5847780a1c3106e69afda62b43c414d57f01584e2869e72fc3687370b0bad84c2a7ffc0ca90537be55cb36ce6edac SHA512 c348eeeabfb5fef05b28aa87c9885231bd5e676b1ced64a2f51cc2aefa122b5ce142aae2ede5c1479608c893195450ae25168bae971b8e77cc741b18650f75c8
+DIST drupal-8.5.15.tar.gz 15828193 BLAKE2B 3a90ad525da3d81f555461e28decea7977cb51eda5f2e3be89dcd38f05b94cc6743967e19d21d89572babc05c38ab4d3585e4b7ffb52677b50b19844400fbcdf SHA512 aa09a28d7dcba51e193bba2a714eef091773d5e12a3a7388db8925c791a7153a4333db6150a8a68fe21b04009887dcf60f16f237a86d52bd2cc7d28ada301221
DIST drupal-8.6.15.tar.gz 17137689 BLAKE2B 098847cc4a3a52a6c5d9af23c31e5dca43c2f9cbb4ac0f7d2724cf6b6ce98598b75750742c695e666000843f6fa855e2ba414ceb0d9b46f9baff244cc583ef64 SHA512 9a8d9c73f7812b6deca4bcfee0e04d485bfac5efa6e9112379fdacc727ecf0e40703ce9b141c7414357c296eb621a015aa1c97ab8e6bbe4d35c38b2f1c323337
diff --git a/www-apps/drupal/drupal-8.5.15.ebuild b/www-apps/drupal/drupal-8.5.15.ebuild
new file mode 100644
index 000000000000..a8514d07dfe0
--- /dev/null
+++ b/www-apps/drupal/drupal-8.5.15.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}