summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2019-03-15 10:14:19 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-15 23:42:15 +0100
commit881a87b77006ad27a9a2e47930276a11df182529 (patch)
tree85ccb96d781e459b112baf76116c858a37facc59 /www-apps/gitea
parentwww-apps/gitea: bump to 1.7.4. (diff)
downloadgentoo-881a87b77006ad27a9a2e47930276a11df182529.tar.gz
gentoo-881a87b77006ad27a9a2e47930276a11df182529.tar.bz2
gentoo-881a87b77006ad27a9a2e47930276a11df182529.zip
www-apps/gitea: drop old.
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'www-apps/gitea')
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.5.2.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 4065ddacc5de..4ed8383cb255 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,2 +1 @@
-DIST gitea-1.5.2.tar.gz 18866286 BLAKE2B a9a31fa6a310dcb6debd9399f234262214021d72adda52af959e6d9d692d5902ff6955a9802bf60212cecb2a0146c4905952d44643aa83e49c645d32541907c2 SHA512 ef91c881b3cb81d79d182b78c95624f24d63e21daa2d6e561fca79edba0ad588fae7c55503f900a8f05c566ed3bff92a9c4385fc7e5c701a80749d2a8c58b599
DIST gitea-1.7.4.tar.gz 20858340 BLAKE2B 81d896d313abe25bc1a5becd16249c2ce39ab45d9f40ccf3a565b6777847c7256d5b131f597be237df57513a207978e23480ad3c6087bbc588afe8bbcd46d5c9 SHA512 eede6d410529b1facf65061256e48fee7d459aa12d8c55346d3ad78004a45b7bf667536979fe92270a85901102fd9cddb8183490e16f912b742e799ca912e370
diff --git a/www-apps/gitea/gitea-1.5.2.ebuild b/www-apps/gitea/gitea-1.5.2.ebuild
deleted file mode 100644
index 49bba0eddfbc..000000000000
--- a/www-apps/gitea/gitea-1.5.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-build golang-vcs-snapshot systemd user
-
-EGO_PN="code.gitea.io/gitea"
-KEYWORDS="~amd64 ~arm"
-
-DESCRIPTION="A painless self-hosted Git service, written in Go"
-HOMEPAGE="https://github.com/go-gitea/gitea"
-SRC_URI="https://github.com/go-gitea/gitea/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-
-DEPEND="
- dev-go/go-bindata
- sys-libs/pam
-"
-RDEPEND="
- dev-vcs/git
- sys-libs/pam
-"
-
-pkg_setup() {
- enewgroup git
- enewuser git -1 /bin/bash /var/lib/gitea git
-}
-
-src_prepare() {
- default
- sed -i -e "s/\"main.Version.*$/\"main.Version=${PV}\"/"\
- -e "s/-ldflags '-s/-ldflags '/" src/${EGO_PN}/Makefile || die
-}
-
-src_compile() {
- GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} generate
- TAGS="bindata pam sqlite" LDFLAGS="" CGO_LDFLAGS="" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} build
-}
-
-src_install() {
- diropts -m0750 -o git -g git
- keepdir /var/log/gitea /var/lib/gitea /var/lib/gitea/data
- pushd src/${EGO_PN} >/dev/null || die
- dobin gitea
- insinto /var/lib/gitea/conf
- newins custom/conf/app.ini.sample app.ini.example
- popd >/dev/null || die
- newinitd "${FILESDIR}"/gitea.initd-r1 gitea
- newconfd "${FILESDIR}"/gitea.confd gitea
- systemd_dounit "${FILESDIR}/gitea.service"
-}
-
-pkg_postinst() {
- if [[ ! -e "${EROOT}/var/lib/gitea/conf/app.ini" ]]; then
- elog "No app.ini found, copying initial config over"
- cp "${FILESDIR}"/app.ini "${EROOT}"/var/lib/gitea/conf/ || die
- chown git:git /var/lib/gitea/conf/app.ini
- else
- elog "app.ini found, please check example file for possible changes"
- ewarn "Please note that environment variables have been changed:"
- ewarn "GITEA_WORK_DIR is set to /var/lib/gitea (previous value: unset)"
- ewarn "GITEA_CUSTOM is set to '\$GITEA_WORK_DIR/custom' (previous: /var/lib/gitea)"
- fi
-}