summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2024-07-07 13:00:42 +0200
committerLouis Sautier <sbraz@gentoo.org>2024-07-07 13:10:04 +0200
commit81c1c05d0f573e6b3e9967187ad4873b21c2a467 (patch)
tree737f217746249520cd39a720bf17dcde0d6fce05 /www-apps/icingadb-web/icingadb-web-1.1.2.ebuild
parentapp-misc/fastfetch: Stabilize 2.15.0 arm64, #935707 (diff)
downloadgentoo-81c1c05d0f573e6b3e9967187ad4873b21c2a467.tar.gz
gentoo-81c1c05d0f573e6b3e9967187ad4873b21c2a467.tar.bz2
gentoo-81c1c05d0f573e6b3e9967187ad4873b21c2a467.zip
www-apps/icingadb-web: add 1.1.2 with PHP 8.3 and ~arm64 support
According to https://github.com/Icinga/icingadb-web/commit/a109548c40d, PHP 8.3 has been tested since v1.1.1. This new version also fixes the VariableOrderWrong warning. Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'www-apps/icingadb-web/icingadb-web-1.1.2.ebuild')
-rw-r--r--www-apps/icingadb-web/icingadb-web-1.1.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/www-apps/icingadb-web/icingadb-web-1.1.2.ebuild b/www-apps/icingadb-web/icingadb-web-1.1.2.ebuild
new file mode 100644
index 000000000000..d9db43ff3342
--- /dev/null
+++ b/www-apps/icingadb-web/icingadb-web-1.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="UI for Icinga DB"
+HOMEPAGE="https://icinga.com/docs/icinga-db-web/"
+SRC_URI="https://github.com/Icinga/icingadb-web/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ || (
+ dev-lang/php:8.1[curl,xml]
+ dev-lang/php:8.2[curl,xml]
+ dev-lang/php:8.3[curl,xml]
+ )
+ >=dev-libs/icinga-php-library-0.13.2
+ >=dev-libs/icinga-php-thirdparty-0.12
+ >=www-apps/icingaweb2-2.9.0
+"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/icingadb/"
+ doins -r "${S}"/*
+}