summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2018-04-06 14:22:38 +0300
committerJonas Stein <jstein@gentoo.org>2018-04-07 01:52:28 +0200
commit9154b9b57ad586e4f19ba5d6d1ace9ee53b20034 (patch)
tree687400a7577fbba0a2cd52774accb83692b9c5b6 /www-apps/mirmon
parentapp-cdr/xbiso: Clean up old (diff)
downloadgentoo-9154b9b57ad586e4f19ba5d6d1ace9ee53b20034.tar.gz
gentoo-9154b9b57ad586e4f19ba5d6d1ace9ee53b20034.tar.bz2
gentoo-9154b9b57ad586e4f19ba5d6d1ace9ee53b20034.zip
www-apps/mirmon: Clean up old
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'www-apps/mirmon')
-rw-r--r--www-apps/mirmon/Manifest1
-rw-r--r--www-apps/mirmon/files/0001-Add-rsync-monitoring-support-to-mirmon.patch87
-rw-r--r--www-apps/mirmon/mirmon-1.38-r4.ebuild47
3 files changed, 0 insertions, 135 deletions
diff --git a/www-apps/mirmon/Manifest b/www-apps/mirmon/Manifest
index 7a0f0cf88f0b..19755d9932c5 100644
--- a/www-apps/mirmon/Manifest
+++ b/www-apps/mirmon/Manifest
@@ -1,2 +1 @@
-DIST mirmon-1.38.tar.gz 33021 BLAKE2B b46778fa3cb5e54ecb5ac5951b26a4b17662b58e99fd78e701a588aa76e7d2033b8c02ed6584737c20e7269bd043a1c508d516007cbc10bca87b581455f84b9f SHA512 a879f7ac979ad31d24a27940600c7a95e0f9db6cc8654fd36f830f9a9cfb9d3a7e86fcb27870da3889ad159028a6807203664038e985c12a5f59a6b19b473b08
DIST mirmon-2.10.tar.gz 72212 BLAKE2B e1f6a68369bd97110d88d3171d552133f48ed8234b06c632f9798b5fd51dcf59e048d900f116fbd185adb86e8c9ee9ff63152a8dddf41dda6b01310644575d8b SHA512 e6e371e1b78b9a7e8e27dd1a68b07436430d9d1cbaa96ee6738049c4878c70b8736e24d86be2571f0a08b263b763c2d8883d78925ac703336f7a297903413d4d
diff --git a/www-apps/mirmon/files/0001-Add-rsync-monitoring-support-to-mirmon.patch b/www-apps/mirmon/files/0001-Add-rsync-monitoring-support-to-mirmon.patch
deleted file mode 100644
index 0c8c69d7795f..000000000000
--- a/www-apps/mirmon/files/0001-Add-rsync-monitoring-support-to-mirmon.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=289942
-
-From d91f1f17be33dfc5ed771829639791b5463417a2 Mon Sep 17 00:00:00 2001
-From: Jeremy Olexa <darkside@gentoo.org>
-Date: Wed, 28 Oct 2009 20:58:45 -0500
-Subject: [PATCH 1/2] Add rsync monitoring support to mirmon.
-
-You will also need to modify mirmon.conf to use probe-mirmon instead
-Original patch located at: http://www.tug.org/texlive/mirmon/probe-mirmon
----
- mirmon | 2 +-
- probe-mirmon | 50 ++++++++++++++++++++++++++++++++++++++++++++++++++
- 2 files changed, 51 insertions(+), 1 deletions(-)
- create mode 100644 probe-mirmon
-
-diff --git a/mirmon b/mirmon
-index a1261f5..6c0aaa8 100755
---- a/mirmon
-+++ b/mirmon
-@@ -384,7 +384,7 @@ sub get_ccs
- sub type_site
- { my $url = shift ;
- my ( $type, $site, $home ) ;
-- if ( $url =~ m!^(ftp|http)://([^/:]+)(:\d+)?/! )
-+ if ( $url =~ m!^(ftp|https?|rsync)://([^/:]+)(:\d+)?/! )
- { $type = $1 ; $site = $2 ; $home = $& ; }
- return $type, $site, $home ;
- }
-diff --git a/probe-mirmon b/probe-mirmon
-new file mode 100644
-index 0000000..a7fe513
---- /dev/null
-+++ b/probe-mirmon
-@@ -0,0 +1,50 @@
-+#!/usr/bin/env perl
-+# $Id$
-+# public domain. Originally written by Karl Berry, 2009.
-+#
-+# Probe rsync url's for mirmon; use wget for anything else.
-+# From description at http://people.cs.uu.nl/henkp/mirmon.
-+#
-+# Also requires a patch to mirmon itself to accept rsync urls
-+# (and I wanted https too):
-+# --- /usr/local/share/mirmon/ORIG/mirmon 2007-08-18 18:05:47.000000000 +0200
-+# +++ /usr/local/share/mirmon/mirmon 2009-07-03 22:38:00.000000000 +0200
-+# @@ -386,3 +386,3 @@
-+# my ( $type, $site, $home ) ;
-+# - if ( $url =~ m!^(ftp|http)://([^/:]+)(:\d+)?/! )
-+# + if ( $url =~ m!^(ftp|https?|rsync)://([^/:]+)(:\d+)?/! )
-+# { $type = $1 ; $site = $2 ; $home = $& ; }
-+
-+exit (&main ());
-+
-+sub main
-+{
-+ my ($timeout,$url) = @ARGV;
-+ my $ret;
-+
-+ if ($url =~ m,^rsync://,) {
-+ $ret = &handle_rsync ($timeout, $url);
-+ } else {
-+ $ret = system qq(wget -q -O - -t 1 -T $timeout $url);
-+ }
-+ return $ret;
-+}
-+
-+
-+sub handle_rsync
-+{
-+ my ($timeout,$url) = @_;
-+
-+ my $tmpdir = "rsync-tmp";
-+ -d $tmpdir || mkdir ($tmpdir, 0700);
-+
-+ (my $file = $url) =~ s/\W/_/g; # translate all non-letters to _
-+ my $local = "$tmpdir/$file";
-+ my $ret = system
-+ qq(/usr/local/bin/rsync --no-motd --timeout $timeout $url $local);
-+
-+ @ARGV = ($local); # don't care about our args any more.
-+ print <>; # let perl autoprint
-+
-+ return $ret;
-+}
---
-1.6.4.4
-
diff --git a/www-apps/mirmon/mirmon-1.38-r4.ebuild b/www-apps/mirmon/mirmon-1.38-r4.ebuild
deleted file mode 100644
index ede9c4ac7ee2..000000000000
--- a/www-apps/mirmon/mirmon-1.38-r4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-inherit webapp eutils
-WEBAPP_MANUAL_SLOT="yes"
-
-DESCRIPTION="Simple webapp to monitor the status of mirrors"
-HOMEPAGE="http://people.cs.uu.nl/henkp/mirmon/"
-SRC_URI="http://people.cs.uu.nl/henkp/mirmon/src/$PN/src/$P.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND=">=dev-lang/perl-5.8.5-r2"
-RDEPEND="${DEPEND}
- dev-perl/File-Tempdir
- dev-perl/Socket6"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/0001-Add-rsync-monitoring-support-to-mirmon.patch" \
- "${FILESDIR}/0002-Add-ipv6-monitor-support-to-mirmon.patch"
- # set the proper interpreter
- sed -i -e 's:/sw/bin/perl:/usr/bin/perl:' mirmon || die
-}
-
-src_install() {
- # Don't install empty dirs
- MY_CGIBINDIR=""
- MY_ICONSDIR=""
- MY_ERRORSDIR=""
-
- webapp_src_preinst
-
- for file in mirmon.html mirmon.txt; do
- dodoc ${file}
- rm -f ${file}
- done
- cp -R icons "${D}"/${MY_HTDOCSDIR}
- rm -rf icons
- cp -R . "${D}"/${MY_HOSTROOTDIR}
-
- webapp_src_install
-}