summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-01-14 10:27:47 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2019-01-14 14:41:07 +0100
commit8655337139d42a24dc5cfbdef244d19f0ac746b9 (patch)
tree3e763cb79e98d0b87f7f59211ef8c8b5d93fd1ae /www-apps/nextcloud/nextcloud-14.0.6.ebuild
parentprofiles: mask www-apps/nextcloud[imagemagick] on arm (diff)
downloadgentoo-8655337139d42a24dc5cfbdef244d19f0ac746b9.tar.gz
gentoo-8655337139d42a24dc5cfbdef244d19f0ac746b9.tar.bz2
gentoo-8655337139d42a24dc5cfbdef244d19f0ac746b9.zip
www-apps/nextcloud: 15.0.2, 14.0.6, 13.0.10 bumps
Also add enabled by default dependency on pecl-imagick in 15 Closes: https://bugs.gentoo.org/673362 Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/nextcloud/nextcloud-14.0.6.ebuild')
-rw-r--r--www-apps/nextcloud/nextcloud-14.0.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-apps/nextcloud/nextcloud-14.0.6.ebuild b/www-apps/nextcloud/nextcloud-14.0.6.ebuild
new file mode 100644
index 000000000000..e4392ac62888
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-14.0.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="http://nextcloud.com"
+SRC_URI="http://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+curl mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="dev-lang/php[curl?,filter,gd,hash,intl,json,mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_src_install
+}