summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-03-23 21:15:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-03-23 21:15:50 -0500
commit1ab18c9d10f4f4e2df6ec801414befb1200e9985 (patch)
tree09d142318e24835379d79fe0602272691446f418 /www-apps/novnc
parentsys-cluster/swift: clarify the kernel check (diff)
downloadgentoo-1ab18c9d10f4f4e2df6ec801414befb1200e9985.tar.gz
gentoo-1ab18c9d10f4f4e2df6ec801414befb1200e9985.tar.bz2
gentoo-1ab18c9d10f4f4e2df6ec801414befb1200e9985.zip
www-apps/novnc: bump to 1.1.0
Closes: https://bugs.gentoo.org/714116 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps/novnc')
-rw-r--r--www-apps/novnc/Manifest1
-rw-r--r--www-apps/novnc/novnc-1.1.0.ebuild45
-rw-r--r--www-apps/novnc/novnc-9999.ebuild8
3 files changed, 50 insertions, 4 deletions
diff --git a/www-apps/novnc/Manifest b/www-apps/novnc/Manifest
index a72a4ad314ee..5f0a899a2ff7 100644
--- a/www-apps/novnc/Manifest
+++ b/www-apps/novnc/Manifest
@@ -1,2 +1,3 @@
DIST novnc-0.6.2.tar.gz 600675 BLAKE2B f9779a9f03ba653f77090639112cd0c967ff5925d2f9897da6508fd077fb79a2f543467e32210572935a642e06fbbcac4a44c34b4342474f54ef7ec7a9bdbf4f SHA512 245d205f8935c82722a55d6cfcd2cea1825176c0cd695fd0eec34aa19cdc3b766fed62e741ff41b0a8c4a3b3cbabc5a39dfa6ad8ffa6169f5b88420a4a845a7c
DIST novnc-1.0.0.tar.gz 1551574 BLAKE2B 58bd63eb0480b3f20ed16907725e0abcf8c699671614dc195f46a363d6ab9cdb5b0b033ba0ba16bbe39b16437fb94f64a741acd69d1c3c3957a0e60353d78a89 SHA512 97a86be5f10f382e2ed641360f5f6c3b22998f68f980c78138aca900ef6a011c1f6aa9cbdd8cd07afd4884e8c65af30d65487e87bb34e524c10f16cf4cd116a3
+DIST novnc-1.1.0.tar.gz 1034997 BLAKE2B 0cb920cac99c3567cbf1c6a58e12649d4bca211d552a472a73ac1089d7c8a18d9478dcfeb558b6302c0c74d321b62575c35a492b02717dc4721b6a9b42f54415 SHA512 9c736912f5a3051027efe779fc64b182f523b9378ff412d78202e52665772678846d97fe3cc5ac18f5c29dd83d5ff2a2dd915e5eadf9af3573fe871db2e7821e
diff --git a/www-apps/novnc/novnc-1.1.0.ebuild b/www-apps/novnc/novnc-1.1.0.ebuild
new file mode 100644
index 000000000000..130e5d594698
--- /dev/null
+++ b/www-apps/novnc/novnc-1.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
+HOMEPAGE="https://kanaka.github.com/noVNC/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
+else
+ SRC_URI="https://github.com/kanaka/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/websockify[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+
+python_compile() {
+ :
+}
+
+src_install() {
+ exeinto /usr/share/novnc/utils
+ for f in utils/*; do
+ [[ ! f = utils/README.md ]] && doexe $f
+ done
+
+ dodoc README.md LICENSE.txt
+
+ insinto /usr/share/novnc
+ doins -r vnc.html vnc_lite.html app/ core/ vendor/
+ dosym vnc_lite.html /usr/share/novnc/vnc_auto.html # for compat
+}
diff --git a/www-apps/novnc/novnc-9999.ebuild b/www-apps/novnc/novnc-9999.ebuild
index cf6e775ac58d..130e5d594698 100644
--- a/www-apps/novnc/novnc-9999.ebuild
+++ b/www-apps/novnc/novnc-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_6 python3_7 )
inherit distutils-r1
@@ -28,7 +28,7 @@ RDEPEND="${DEPEND}
dev-python/numpy[${PYTHON_USEDEP}]"
python_compile() {
- echo
+ :
}
src_install() {
@@ -41,5 +41,5 @@ src_install() {
insinto /usr/share/novnc
doins -r vnc.html vnc_lite.html app/ core/ vendor/
- dosym /usr/share/novnc/vnc_lite.html /usr/share/novnc/vnc_auto.html # for compat
+ dosym vnc_lite.html /usr/share/novnc/vnc_auto.html # for compat
}