summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-12-04 07:16:56 -0500
committerVirgil Dupras <vdupras@gentoo.org>2018-12-04 07:18:06 -0500
commit06243ab947dbf0693ddeee53cef81d5fc53b396e (patch)
tree5e96e6097b5e7f8f9cda3698f472541d73a86d57 /www-apps
parentmedia-gfx/dcraw: amd64 stable wrt bug #662898 (diff)
downloadgentoo-06243ab947dbf0693ddeee53cef81d5fc53b396e.tar.gz
gentoo-06243ab947dbf0693ddeee53cef81d5fc53b396e.tar.bz2
gentoo-06243ab947dbf0693ddeee53cef81d5fc53b396e.zip
www-apps/moinmoin: remove last-rited package
Closes: https://bugs.gentoo.org/550188 Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/moinmoin/Manifest1
-rw-r--r--www-apps/moinmoin/files/postinstall-en-1.9.4.txt16
-rw-r--r--www-apps/moinmoin/files/reconfig-1.9.417
-rw-r--r--www-apps/moinmoin/metadata.xml8
-rw-r--r--www-apps/moinmoin/moinmoin-1.9.7-r1.ebuild105
5 files changed, 0 insertions, 147 deletions
diff --git a/www-apps/moinmoin/Manifest b/www-apps/moinmoin/Manifest
deleted file mode 100644
index 01f07495c49..00000000000
--- a/www-apps/moinmoin/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST moin-1.9.7.tar.gz 36911772 BLAKE2B 26e0896a68692054c7a40da3e4ccb85a947e5335fde1387f47d6cc39f4c43e1e7421a4143ded9a1659596a2137cd68091967acd8a95630fe8263904e98d0d275 SHA512 5cb6c205fb0c18b83fe7cee83bf88098bfbbc357c89004f8b7cf484bd7efd35af4ace78d0e80df71b01f70861e8bbb63aeefdd831768989d5b7f511ca24fb60c
diff --git a/www-apps/moinmoin/files/postinstall-en-1.9.4.txt b/www-apps/moinmoin/files/postinstall-en-1.9.4.txt
deleted file mode 100644
index 6a6baf764ea..00000000000
--- a/www-apps/moinmoin/files/postinstall-en-1.9.4.txt
+++ /dev/null
@@ -1,16 +0,0 @@
-Now please read the installation manual at
-/usr/share/doc/${PF}/html
-
-MoinMoin can work with a variety of webservers. Simple Apache instructions
-are given below:
-
-1. ExecCGI needs to be enabled in your Moinmoin directory by doing:
-# echo "Options ExecCGI" > ${MY_INSTALLDIR}/.htaccess
-# echo "AddHandler cgi-script .cgi" >> ${MY_INSTALLDIR}/.htaccess
-
-2. Add the following lines to your Apache configs:
-ScriptAlias /mywiki "${MY_INSTALLDIR}/moin.cgi"
-
-3. Restart Apache
-
-4. Go to http://${VHOST_HOSTNAME}/mywiki/ and follow the instructions there.
diff --git a/www-apps/moinmoin/files/reconfig-1.9.4 b/www-apps/moinmoin/files/reconfig-1.9.4
deleted file mode 100644
index 698da419fdb..00000000000
--- a/www-apps/moinmoin/files/reconfig-1.9.4
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/bash
-
-die() {
- echo "#####"
- echo $1
- echo "#####"
- exit 1
-}
-
-if [ $1 = "install" ]; then
- sed -e "s|^#\(.*\)/path/to/wikiconfigdir|\1${VHOST_ROOT}/${PN}-${PVR}|g" -i ${MY_INSTALLDIR}/moin.cgi || die "sed failed"
- sed -e "s|#url_prefix_static|url_prefix_static|" -i ${VHOST_ROOT}/${PN}-${PVR}/wikiconfig.py || die "sed failed"
- sed -e "s|//|/|" -i ${VHOST_ROOT}/${PN}-${PVR}/wikiconfig.py || die "sed failed"
-
-elif [ $1 = "clean" ]; then
- echo $1
-fi
diff --git a/www-apps/moinmoin/metadata.xml b/www-apps/moinmoin/metadata.xml
deleted file mode 100644
index f2f2ba9e282..00000000000
--- a/www-apps/moinmoin/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>web-apps@gentoo.org</email>
- <name>Gentoo Webapps</name>
-</maintainer>
-</pkgmetadata>
diff --git a/www-apps/moinmoin/moinmoin-1.9.7-r1.ebuild b/www-apps/moinmoin/moinmoin-1.9.7-r1.ebuild
deleted file mode 100644
index 27ad731eec9..00000000000
--- a/www-apps/moinmoin/moinmoin-1.9.7-r1.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="xml"
-DISTUTILS_SINGLE_IMPL=1
-
-inherit eutils distutils-r1 webapp
-
-MY_PN="moin"
-
-DESCRIPTION="Python WikiClone"
-HOMEPAGE="http://moinmo.in/"
-SRC_URI="http://static.moinmo.in/files/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc x86"
-
-RDEPEND=">=dev-python/docutils-0.4[${PYTHON_USEDEP}]
- >=dev-python/flup-1.0.2[${PYTHON_USEDEP}]
- >=dev-python/pygments-1.1.1[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.7.0[${PYTHON_USEDEP}]"
-
-need_httpd_cgi
-
-S=${WORKDIR}/${MY_PN}-${PV}
-
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- if has_version "<www-apps/moinmoin-1.9" ; then
- ewarn
- ewarn "You already have a version of moinmoin prior to 1.9 installed."
- ewarn "moinmoin-1.9 has a very different configuration than 1.8 (among"
- ewarn "other changes, static content is no longer installed under the"
- ewarn "htdocs directory)."
- ewarn
- ewarn "Please read http://moinmo.in/MoinMoinRelease1.9 and"
- ewarn "README.migration in /usr/share/doc/${PF}"
- ewarn
- fi
-
- webapp_pkg_setup
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # remove bundled -- parsedatetime and xappy not packaged yet
- rm -r MoinMoin/support/{pygments,werkzeug,flup} || die
- sed -i "/\(flup\|pygments\|werkzeug\)/d" setup.py || die
-
- # needed for python_fix_shebang
- edos2unix MoinMoin/web/static/htdocs/applets/FCKeditor/editor/filemanager/connectors/py/*.py
-
- distutils-r1_src_prepare
-}
-
-src_install() {
- webapp_src_preinst
- distutils-r1_src_install
-
- dodoc README docs/CHANGES* docs/README.migration
- dohtml docs/INSTALL.html
- rm -rf README docs/
-
- cd "${D}"/usr/share/moin
-
- insinto "${MY_HTDOCSDIR}"
- doins -r server/moin.cgi
- fperms +x "${MY_HTDOCSDIR}/moin.cgi"
-
- insinto "${MY_HOSTROOTDIR}"/${PF}
- doins -r data underlay config/wikiconfig.py
-
- insinto "${MY_HOSTROOTDIR}"/${PF}/altconfigs
- doins -r config
-
- insinto "${MY_HOSTROOTDIR}"/${PF}/altserver
- doins -r server
-
- # data needs to be server owned per moin devs
- cd "${D}/${MY_HOSTROOTDIR}"/${PF}
- for file in $(find data underlay); do
- webapp_serverowned "${MY_HOSTROOTDIR}/${PF}/${file}"
- done
-
- webapp_configfile "${MY_HOSTROOTDIR}"/${PF}/wikiconfig.py
- webapp_hook_script "${FILESDIR}"/reconfig-1.9.4
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en-1.9.4.txt
-
- webapp_src_install
-
- # bug 466390
- python_fix_shebang "${D}"
-}
-
-pkg_postinst() {
- ewarn
- ewarn "If you are upgrading from an older version, please read"
- ewarn "README.migration in /usr/share/doc/${PF}"
- ewarn
- webapp_pkg_postinst
-}