summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-05-12 22:57:09 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-05-12 22:57:09 +0100
commit15e998d86f5915ca56cb5b8c935b2a1786255d9e (patch)
treef8bf67e6157a5edd9dd830ae79257b7d82443c22 /www-apps
parentvirtual/dist-kernel: Stabilize 5.15.37 arm64, #842897 (diff)
downloadgentoo-15e998d86f5915ca56cb5b8c935b2a1786255d9e.tar.gz
gentoo-15e998d86f5915ca56cb5b8c935b2a1786255d9e.tar.bz2
gentoo-15e998d86f5915ca56cb5b8c935b2a1786255d9e.zip
www-apps/xpra-html5: Version bump to 5.0
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/xpra-html5/Manifest1
-rw-r--r--www-apps/xpra-html5/xpra-html5-5.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/www-apps/xpra-html5/Manifest b/www-apps/xpra-html5/Manifest
index 872df3d1d30d..98ddc7760a0b 100644
--- a/www-apps/xpra-html5/Manifest
+++ b/www-apps/xpra-html5/Manifest
@@ -1 +1,2 @@
DIST xpra-html5-4.5.2.tar.gz 1492651 BLAKE2B 1e0fb2f554f4e2c4bb4bbf3b937b33408dc56b7a2aaba1a0459e28bea4c87b5f96195abbd2de0e8461964e43dace5f40badfdb9dfe3a4db5f7c3c9eddc6eaa68 SHA512 a1f73889ad3797ca25d232d3d11e1753dc10944cb8f07c1d6dbacfbf5273b22a0d3696af4e88cd5b75ed4a0970533e340a41253842c3766ab6fe650dc5fb0d0b
+DIST xpra-html5-5.0.tar.gz 1570694 BLAKE2B aef7b818aa618c143701993627e629884b5e696c7334e6b75701a20028f18aced5e3249505ac031d6cd0a08d79ca2b9728afdb2e90712fcbe45d43d02598f608 SHA512 8318c6dd8f8f53d0a132272c2bb8c69e8ba928f2f267679aee48cec4598faa828788a219dfa342162e1fcf8159bf46b44d50db57180f1aa972edd67fa43e9cd5
diff --git a/www-apps/xpra-html5/xpra-html5-5.0.ebuild b/www-apps/xpra-html5/xpra-html5-5.0.ebuild
new file mode 100644
index 000000000000..5c2270895f63
--- /dev/null
+++ b/www-apps/xpra-html5/xpra-html5-5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit python-any-r1
+
+DESCRIPTION="HTML5 client to connect to any xpra server"
+HOMEPAGE="https://xpra.org/"
+SRC_URI="https://github.com/Xpra-org/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="brotli +gzip minify"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ brotli? ( app-arch/brotli )
+ minify? ( dev-util/uglifyjs )
+"
+
+src_configure() {
+ cat <<EOF > vcs-info || die
+BRANCH=gentoo
+REVISION=${PR#r}
+LOCAL_MODIFICATIONS=0
+EOF
+}
+
+src_install() {
+ "${PYTHON}" <<EOF || die
+import setup
+setup.set_version("${PV}")
+setup.install_html5(
+ root="${D}",
+ install_dir="${EPREFIX}/usr/share/xpra/www/",
+ config_dir="${EPREFIX}/etc/xpra/html5-client",
+ minifier="$(usex minify uglifyjs copy)",
+ gzip=$(usex gzip True False),
+ brotli=$(usex brotli True False),
+)
+EOF
+}