summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-12-16 09:06:55 -0500
committerMike Gilbert <floppym@gentoo.org>2017-12-16 09:07:11 -0500
commitc44287847c83dc1d9f163b141ff1656fd736ba50 (patch)
treec223bfa571d2fd92955f9a709b36109f1c527512 /www-client/chromium
parentx11-themes/gtk-chtheme-0.3.1-r3: amd64 stable (diff)
downloadgentoo-c44287847c83dc1d9f163b141ff1656fd736ba50.tar.gz
gentoo-c44287847c83dc1d9f163b141ff1656fd736ba50.tar.bz2
gentoo-c44287847c83dc1d9f163b141ff1656fd736ba50.zip
www-client/chromium: fix build with cups disabled
Closes: https://bugs.gentoo.org/640642 Package-Manager: Portage-2.3.19_p1, Repoman-2.3.6_p35
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/chromium-64.0.3282.24.ebuild1
-rw-r--r--www-client/chromium/files/chromium-cups-r0.patch45
2 files changed, 46 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-64.0.3282.24.ebuild b/www-client/chromium/chromium-64.0.3282.24.ebuild
index c0f32ba37a41..bf7155220b07 100644
--- a/www-client/chromium/chromium-64.0.3282.24.ebuild
+++ b/www-client/chromium/chromium-64.0.3282.24.ebuild
@@ -146,6 +146,7 @@ PATCHES=(
"${FILESDIR}/chromium-FORTIFY_SOURCE-r2.patch"
"${FILESDIR}/chromium-webrtc-r0.patch"
"${FILESDIR}/chromium-memcpy-r0.patch"
+ "${FILESDIR}/chromium-cups-r0.patch"
)
pre_build_checks() {
diff --git a/www-client/chromium/files/chromium-cups-r0.patch b/www-client/chromium/files/chromium-cups-r0.patch
new file mode 100644
index 000000000000..88ea78a81ebf
--- /dev/null
+++ b/www-client/chromium/files/chromium-cups-r0.patch
@@ -0,0 +1,45 @@
+From 3cf91d8d674a496d533aa106723a632b68ab26ba Mon Sep 17 00:00:00 2001
+From: Tom Anderson <thomasanderson@chromium.org>
+Date: Tue, 12 Dec 2017 23:31:56 +0000
+Subject: [PATCH] Fix use_cups=false build
+
+BUG=793801
+R=thestig@chromium.org
+
+Change-Id: I60ee6ec48d2686d0b42ca25311a9b76009ce9768
+Reviewed-on: https://chromium-review.googlesource.com/823245
+Reviewed-by: Lei Zhang <thestig@chromium.org>
+Commit-Queue: Thomas Anderson <thomasanderson@chromium.org>
+Cr-Commit-Position: refs/heads/master@{#523602}
+---
+ chrome/service/cloud_print/print_system.cc | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/chrome/service/cloud_print/print_system.cc b/chrome/service/cloud_print/print_system.cc
+index ac94c804f9..4ceba96919 100644
+--- a/chrome/service/cloud_print/print_system.cc
++++ b/chrome/service/cloud_print/print_system.cc
+@@ -5,6 +5,7 @@
+ #include "chrome/service/cloud_print/print_system.h"
+
+ #include "base/guid.h"
++#include "build/build_config.h"
+
+ namespace cloud_print {
+
+@@ -35,5 +36,11 @@ std::string PrintSystem::GenerateProxyId() {
+ return base::GenerateGUID();
+ }
+
+-} // namespace cloud_print
++#if defined(OS_LINUX) && !defined(USE_CUPS)
++scoped_refptr<PrintSystem> PrintSystem::CreateInstance(
++ const base::DictionaryValue*) {
++ return nullptr;
++}
++#endif
+
++} // namespace cloud_print
+--
+2.15.1
+