summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-09 09:37:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-09 09:51:02 +0200
commit6fae0f84de7fb17e84f5f91b17162146d66a4d18 (patch)
tree0ab0675eba9e638b2e20bb422173dc75b0f52ff6 /www-client/falkon
parentmedia-libs/xine-lib: Removed old. (diff)
downloadgentoo-6fae0f84de7fb17e84f5f91b17162146d66a4d18.tar.gz
gentoo-6fae0f84de7fb17e84f5f91b17162146d66a4d18.tar.bz2
gentoo-6fae0f84de7fb17e84f5f91b17162146d66a4d18.zip
www-client/falkon: 3.0.1 version bump
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'www-client/falkon')
-rw-r--r--www-client/falkon/Manifest1
-rw-r--r--www-client/falkon/falkon-3.0.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/www-client/falkon/Manifest b/www-client/falkon/Manifest
index bbd80e7362d2..dc725eb70d38 100644
--- a/www-client/falkon/Manifest
+++ b/www-client/falkon/Manifest
@@ -1 +1,2 @@
DIST falkon-3.0.0.tar.xz 1985800 BLAKE2B 8505e2c91600d265c28f70c37bf9e8f669ecd907dd9263371a4a4c10b854d32415ec1a3fd6ac163b297d0a9f42c542d4691a6cd417ed81864585f0c66b769e34 SHA512 1d99ecd47022986570dd6bb9b57484abe30838bf52daf669c977e1d2a9381efdd60912fd72b97e0b43b6102159f4343c4d1589d4f6442d0ed62c24f1482a8d97
+DIST falkon-3.0.1.tar.xz 2219444 BLAKE2B 013d29925f9a1c7e77d5f194eb4a1371dadda05de01a0c103902acfbb16941c6fa9c7256a98ef1965c622222ccfcee8b44c48076cb00bd892378157502f73916 SHA512 e2384cb49d4e1ec52ff7804cf798688be2d80fa5957c72accb09376aa0c41ee491c45234fd53c79871bc474a8d0677e40ddb48241a70d77102c67406b0719191
diff --git a/www-client/falkon/falkon-3.0.1.ebuild b/www-client/falkon/falkon-3.0.1.ebuild
new file mode 100644
index 000000000000..8db691656aae
--- /dev/null
+++ b/www-client/falkon/falkon-3.0.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+QT_MINIMAL="5.9.2"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Cross-platform web browser using QtWebEngine"
+HOMEPAGE="https://www.falkon.org/"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus gnome-keyring kwallet libressl +X"
+
+COMMON_DEPEND="
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork 'ssl')
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsql 'sqlite')
+ $(add_qt_dep qtwebchannel)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ dbus? ( $(add_qt_dep qtdbus) )
+ gnome-keyring? ( gnome-base/gnome-keyring )
+ kwallet? ( $(add_frameworks_dep kwallet) )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:0= )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb:=
+ x11-libs/xcb-util
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep linguist-tools)
+ $(add_qt_dep qtconcurrent)
+ gnome-keyring? ( virtual/pkgconfig )
+"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ DEPEND+=" $(add_frameworks_dep ki18n)"
+fi
+RDEPEND="${COMMON_DEPEND}
+ !www-client/qupzilla
+ $(add_qt_dep qtsvg)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_DBUS=$(usex !dbus)
+ -DBUILD_KEYRING=$(usex gnome-keyring)
+ $(cmake-utils_use_find_package kwallet KF5Wallet)
+ -DNO_X11=$(usex !X)
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "If you were previously using QupZilla, you can manually migrate your profiles"
+ elog "by moving the config directory from ~/.config/qupzilla to ~/.config/falkon"
+}