summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-11-18 02:00:24 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-11-18 02:18:00 +0100
commit97ada37a910c02d335dbb8ebce6fc0f3dfbcbefe (patch)
tree2afd016150c2803b75bd7109ca474e9a71983d55 /www-client/opera-beta
parentwww-client/opera: bump to v56.0.3051.104 (diff)
downloadgentoo-97ada37a910c02d335dbb8ebce6fc0f3dfbcbefe.tar.gz
gentoo-97ada37a910c02d335dbb8ebce6fc0f3dfbcbefe.tar.bz2
gentoo-97ada37a910c02d335dbb8ebce6fc0f3dfbcbefe.zip
www-client/opera-beta: bump to v57.0.3098.53
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client/opera-beta')
-rw-r--r--www-client/opera-beta/Manifest1
-rw-r--r--www-client/opera-beta/opera-beta-57.0.3098.53.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/www-client/opera-beta/Manifest b/www-client/opera-beta/Manifest
index 2c4eb43a9fa8..c536707ca855 100644
--- a/www-client/opera-beta/Manifest
+++ b/www-client/opera-beta/Manifest
@@ -1,2 +1,3 @@
DIST opera-beta_57.0.3098.20_amd64.deb 70403908 BLAKE2B a990a7949ea81a5d019cb0c1ca7c4ddfde184f7a9ff4aab14b7b407f96e4b371981c1106ad0681c03d4b8792cda191032947a779e712027d4bf156c56db281d2 SHA512 ef2ca1963b94d3920ccdcb3bfcb98fce08774a52f57ed5f21675f50d68600117348d652c431a70e14d335fb1a5e32e053ef5e7782d6a604d0492fd2e5b10738f
DIST opera-beta_57.0.3098.27_amd64.deb 70410538 BLAKE2B 6dbe2a73ce51b3c7a118919cbdf711bbd3b66973ba4d19622d9eca684ab87aa989ad14fba47ea79560522fbf200548f073c71f82d96a7b245ddd95d48b3bf505 SHA512 0459f8f5c8e9076e4092eab25e48bc15edf78426613cb53cdebdcf59f34a7eb387d85ca99569b4b5005a2a3d5ab7c832febb249168691ce909d63ba82993f155
+DIST opera-beta_57.0.3098.53_amd64.deb 70612748 BLAKE2B 077663b246f3c188af6114f34e41529997e35ed8e454e6577068fab31d741284a2738c95ae973705569c1a2c04986f9d1acb8371df8487e201aebb76754d7f1a SHA512 96b40bedabbd01d12734ece9a7f23d0ce12fc43ea396a6ecda5637b677260756bb9f51285d20da2e711f738fc8d36decd46aef7446cfdb8ac9e7783bd8ebde57
diff --git a/www-client/opera-beta/opera-beta-57.0.3098.53.ebuild b/www-client/opera-beta/opera-beta-57.0.3098.53.ebuild
new file mode 100644
index 000000000000..c09ad3685d1c
--- /dev/null
+++ b/www-client/opera-beta/opera-beta-57.0.3098.53.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CHROMIUM_LANGS="
+ be bg bn ca cs da de el en-GB es es-419 fi fil fr fr-CA hi hr hu id it
+ ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
+ zh-CN zh-TW
+"
+inherit chromium-2 gnome2-utils multilib unpacker xdg-utils
+
+DESCRIPTION="A fast and secure web browser"
+HOMEPAGE="https://www.opera.com/"
+LICENSE="OPERA-2014"
+SLOT="0"
+SRC_URI_BASE="
+ https://download1.operacdn.com/pub/
+ https://download2.operacdn.com/pub/
+ https://download3.operacdn.com/pub/
+ https://download4.operacdn.com/pub/
+"
+SRC_URI="amd64? ("
+for uri in ${SRC_URI_BASE}; do
+SRC_URI+="
+ "${uri}${PN}/${PV}/linux/${PN}_${PV}_amd64.deb"
+"
+done
+SRC_URI+=")"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gconf:2
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libnotify
+ x11-libs/pango[X]
+"
+
+QA_PREBUILT="*"
+S=${WORKDIR}
+OPERA_HOME="usr/$(get_libdir)/${PN}"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_prepare() {
+ epatch_user
+
+ case ${ARCH} in
+ amd64)
+ mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
+ rm -r usr/lib || die
+ ;;
+ x86)
+ mv usr/lib/i386-linux-gnu/${PN} usr/$(get_libdir)/ || die
+ ;;
+ esac
+
+ mv usr/share/doc/${PN} usr/share/doc/${PF} || die
+ gunzip usr/share/doc/${PF}/changelog.gz || die
+
+ rm usr/bin/${PN} || die
+
+ pushd "${OPERA_HOME}/localization" > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+
+ sed -i \
+ -e 's|^TargetEnvironment|X-&|g' \
+ usr/share/applications/${PN}.desktop || die
+}
+
+src_install() {
+ mv * "${D}" || die
+ dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
+ fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}