summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-23 08:23:43 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-23 08:27:39 +0100
commite517fd9a13fe15edcf44b8a240f1cf2776e31fc1 (patch)
treee213d2636dd2da56f4ba927141e71d80a2a8d6db /www-client/opera
parentsys-apps/portage: Bump to version 2.3.85 (diff)
downloadgentoo-e517fd9a13fe15edcf44b8a240f1cf2776e31fc1.tar.gz
gentoo-e517fd9a13fe15edcf44b8a240f1cf2776e31fc1.tar.bz2
gentoo-e517fd9a13fe15edcf44b8a240f1cf2776e31fc1.zip
www-client/opera: Version 66.0.3515.44
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'www-client/opera')
-rw-r--r--www-client/opera/Manifest1
-rw-r--r--www-client/opera/opera-66.0.3515.44.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/www-client/opera/Manifest b/www-client/opera/Manifest
index fa57ec285c0e..08a723724e58 100644
--- a/www-client/opera/Manifest
+++ b/www-client/opera/Manifest
@@ -1 +1,2 @@
DIST opera-stable_66.0.3515.36_amd64.deb 66040280 BLAKE2B 42aa65a1ebae30bab32c16abaf81edf942418919a50f48348b02001e088b3cd7aaac223baf2cf8e6f59e60dc9c7bce7b26811fdd583c78459e3382b1120123d7 SHA512 fd600bacd367b1ffecb4b9425c7f7a61433df661dabbb34bed1b3c7e489c4ffe8bac7f74c160a61feb19b5ada6006baf58a67e6bbf156880e05cf6fe5e274ed8
+DIST opera-stable_66.0.3515.44_amd64.deb 66057808 BLAKE2B 47ce7c02798b7d50558be1a7223696c62cf133a9446f1ccbe7f6fb382693be2755f2cb62a15eba49fe48140060c87937b91a7bbffd5a7ccca8a79f932bc6c945 SHA512 f4d1555f61a3ae461d12075375c4c98259f91b5c906b385cc521b43a27e8cd96895abb27d4a46cc1a679fd0295f07ba925804ffcf6718af28f5749f7091edf23
diff --git a/www-client/opera/opera-66.0.3515.44.ebuild b/www-client/opera/opera-66.0.3515.44.ebuild
new file mode 100644
index 000000000000..a1d448874c75
--- /dev/null
+++ b/www-client/opera/opera-66.0.3515.44.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CHROMIUM_LANGS="
+ be bg bn ca cs da de el en-GB en-US es-419 es fil fi fr-CA fr hi hr hu id
+ it ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
+ zh-CN zh-TW
+
+"
+inherit chromium-2 multilib unpacker xdg-utils
+
+DESCRIPTION="A fast and secure web browser"
+HOMEPAGE="https://www.opera.com/"
+LICENSE="OPERA-2014"
+SLOT="0"
+SRC_URI_BASE="
+ https://download1.operacdn.com/pub/
+ https://download2.operacdn.com/pub/
+ https://download3.operacdn.com/pub/
+ https://download4.operacdn.com/pub/
+"
+for uri in ${SRC_URI_BASE}; do
+SRC_URI+="
+ "${uri}${PN}/desktop/${PV}/linux/${PN}-stable_${PV}_amd64.deb"
+"
+done
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gconf:2
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libnotify
+ x11-libs/pango[X]
+"
+
+QA_PREBUILT="*"
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_prepare() {
+ default
+
+ OPERA_HOME="usr/$(get_libdir)/${PN}"
+
+ case ${ARCH} in
+ amd64)
+ mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
+ rm -r usr/lib || die
+ ;;
+ esac
+
+ rm usr/bin/${PN} || die
+
+ rm usr/share/doc/${PN}-stable/copyright || die
+ mv usr/share/doc/${PN}-stable usr/share/doc/${PF} || die
+ gunzip usr/share/doc/${PF}/changelog.gz || die
+
+ pushd "${OPERA_HOME}"/localization > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+
+ sed -i \
+ -e 's|^TargetEnvironment|X-&|g' \
+ usr/share/applications/${PN}.desktop || die
+}
+
+src_install() {
+ rm "${OPERA_HOME}"/${PN}_autoupdate || die
+ mv * "${D}" || die
+ dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
+ fperms 4711 /"${OPERA_HOME}"/opera_sandbox
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}