summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-04-28 11:53:23 -0400
committerMike Gilbert <floppym@gentoo.org>2020-04-28 11:53:23 -0400
commitbe99566c82e5b09d553da61e3f7cb5494b110341 (patch)
tree6a09ee110f531f98e1a259a09101f5a9674cc93b /www-plugins/chrome-binary-plugins/chrome-binary-plugins-84.0.4122.7_alpha.ebuild
parentwww-client/google-chrome-unstable: automated update (84.0.4122.7) (diff)
downloadgentoo-be99566c82e5b09d553da61e3f7cb5494b110341.tar.gz
gentoo-be99566c82e5b09d553da61e3f7cb5494b110341.tar.bz2
gentoo-be99566c82e5b09d553da61e3f7cb5494b110341.zip
www-plugins/chrome-binary-plugins: automated update
Package-Manager: Portage-2.3.99_p2, Repoman-2.3.22_p31 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-84.0.4122.7_alpha.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-84.0.4122.7_alpha.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-84.0.4122.7_alpha.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-84.0.4122.7_alpha.ebuild
new file mode 100644
index 000000000000..50f2de431d29
--- /dev/null
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-84.0.4122.7_alpha.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2012-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib unpacker
+
+DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
+HOMEPAGE="https://www.google.com/chrome"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_alpha}-1
+ ;;
+ *_beta*)
+ SLOT="beta"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_beta}-1
+ ;;
+ *)
+ SLOT="stable"
+ CHROMEDIR="opt/google/chrome"
+ MY_PV=${PV}-1
+ ;;
+esac
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
+KEYWORDS="-* ~amd64"
+
+LICENSE="google-chrome"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ !<www-client/chromium-57[widevine(-)]
+"
+
+for x in 0 beta stable unstable; do
+ if [[ ${SLOT} != ${x} ]]; then
+ RDEPEND+=" !${CATEGORY}/${PN}:${x}"
+ fi
+done
+
+S="${WORKDIR}/${CHROMEDIR}"
+QA_PREBUILT="*"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/chromium-browser"
+ doins -r WidevineCdm
+}