summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-07-30 13:49:06 -0400
committerMike Gilbert <floppym@gentoo.org>2020-07-30 13:49:06 -0400
commite66351c24dddb0823ba6fd5ed3c042355fac5d9e (patch)
treead1f2cd0aedf315bdbbd96b20da2141f9c1464e0 /www-plugins/chrome-binary-plugins/chrome-binary-plugins-85.0.4183.49_beta.ebuild
parentwww-client/google-chrome-unstable: automated update (86.0.4214.2) (diff)
downloadgentoo-e66351c24dddb0823ba6fd5ed3c042355fac5d9e.tar.gz
gentoo-e66351c24dddb0823ba6fd5ed3c042355fac5d9e.tar.bz2
gentoo-e66351c24dddb0823ba6fd5ed3c042355fac5d9e.zip
www-plugins/chrome-binary-plugins: automated update
Package-Manager: Portage-3.0.1, Repoman-2.3.23_p49 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-85.0.4183.49_beta.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-85.0.4183.49_beta.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-85.0.4183.49_beta.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-85.0.4183.49_beta.ebuild
new file mode 100644
index 000000000000..5ab3a0cae742
--- /dev/null
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-85.0.4183.49_beta.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2012-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib unpacker
+
+DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
+HOMEPAGE="https://www.google.com/chrome"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_alpha}-1
+ ;;
+ *_beta*)
+ SLOT="beta"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_beta}-1
+ ;;
+ *)
+ SLOT="stable"
+ CHROMEDIR="opt/google/chrome"
+ MY_PV=${PV}-1
+ ;;
+esac
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
+KEYWORDS="-* ~amd64"
+
+LICENSE="google-chrome"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+"
+
+for x in 0 beta stable unstable; do
+ if [[ ${SLOT} != ${x} ]]; then
+ RDEPEND+=" !${CATEGORY}/${PN}:${x}"
+ fi
+done
+
+S="${WORKDIR}/${CHROMEDIR}"
+QA_PREBUILT="*"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/chromium-browser"
+ doins -r WidevineCdm
+}