summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-05 20:16:35 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-05 20:51:06 +0200
commit7602f895c9669f6d7fa94dd5764b0ee4924c0c79 (patch)
tree9ab5497250e9656f37b32699daf772fd40b888dc /www-plugins/lightspark
parentwww-plugins/lightspark: GTK+2 dep removed in -9999 (diff)
downloadgentoo-7602f895c9669f6d7fa94dd5764b0ee4924c0c79.tar.gz
gentoo-7602f895c9669f6d7fa94dd5764b0ee4924c0c79.tar.bz2
gentoo-7602f895c9669f6d7fa94dd5764b0ee4924c0c79.zip
www-plugins/lightspark: Remove test for ancient GCC in -9999
Diffstat (limited to 'www-plugins/lightspark')
-rw-r--r--www-plugins/lightspark/lightspark-9999.ebuild10
1 files changed, 0 insertions, 10 deletions
diff --git a/www-plugins/lightspark/lightspark-9999.ebuild b/www-plugins/lightspark/lightspark-9999.ebuild
index bfec3b32acd..09a12ccd261 100644
--- a/www-plugins/lightspark/lightspark-9999.ebuild
+++ b/www-plugins/lightspark/lightspark-9999.ebuild
@@ -24,7 +24,6 @@ RDEPEND="app-arch/xz-utils:0=
media-libs/libpng:0=
media-libs/libsdl2:0=
media-libs/sdl2-mixer:0=
- >=sys-devel/gcc-4.6.0:*[cxx]
>=sys-devel/llvm-3.4:=
sys-libs/zlib:0=
x11-libs/cairo:0=
@@ -49,15 +48,6 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P/_rc*/}
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if tc-is-gcc && [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 6 || $(gcc-major-version) -lt 4 ]] ; then
- eerror "You need at least sys-devel/gcc-4.6.0"
- die "You need at least sys-devel/gcc-4.6.0"
- fi
- fi
-}
-
src_configure() {
local mycmakeargs=(
-DENABLE_CURL=$(usex curl)