summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-04-09 22:26:02 +0200
committerDavid Seifert <soap@gentoo.org>2016-04-09 22:26:02 +0200
commit5317471fd578c7501126c6f7481f02f7ff02f248 (patch)
tree668bb93a5f4693ac386b39e58d6b3881a08140f5 /www-plugins
parentRemove unnecessary src_compile() phase. (diff)
downloadgentoo-5317471fd578c7501126c6f7481f02f7ff02f248.tar.gz
gentoo-5317471fd578c7501126c6f7481f02f7ff02f248.tar.bz2
gentoo-5317471fd578c7501126c6f7481f02f7ff02f248.zip
www-plugins/gnash: Add patch for dev-libs/boost-1.60
Gentoo-Bug: 579142 Package-Manager: portage-2.2.28
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/gnash/files/gnash-0.8.10_p20150316-boost-1.60.patch24
-rw-r--r--www-plugins/gnash/gnash-0.8.10_p20150316.ebuild4
2 files changed, 28 insertions, 0 deletions
diff --git a/www-plugins/gnash/files/gnash-0.8.10_p20150316-boost-1.60.patch b/www-plugins/gnash/files/gnash-0.8.10_p20150316-boost-1.60.patch
new file mode 100644
index 000000000000..6671d361e325
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.10_p20150316-boost-1.60.patch
@@ -0,0 +1,24 @@
+diff --git i/libbase/accumulator.h w/libbase/accumulator.h
+index 694cbd2..876c669 100644
+--- i/libbase/accumulator.h
++++ w/libbase/accumulator.h
+@@ -22,6 +22,7 @@
+
+ #include <boost/program_options/value_semantic.hpp>
+ #include <boost/any.hpp>
++#include <boost/version.hpp>
+ #include <functional>
+ #include <vector>
+ #include <string>
+@@ -61,6 +62,11 @@ public:
+ virtual unsigned min_tokens() const { return 0; }
+ virtual unsigned max_tokens() const { return 0; }
+
++#if BOOST_VERSION >= 105900
++ /// There are no tokens, so this is indifferent.
++ virtual bool adjacent_tokens_only() const { return false; }
++#endif
++
+ /// Accumulating from different sources is silly.
+ virtual bool is_composing() const { return false; }
+
diff --git a/www-plugins/gnash/gnash-0.8.10_p20150316.ebuild b/www-plugins/gnash/gnash-0.8.10_p20150316.ebuild
index a1747f939b9c..441d7ba28132 100644
--- a/www-plugins/gnash/gnash-0.8.10_p20150316.ebuild
+++ b/www-plugins/gnash/gnash-0.8.10_p20150316.ebuild
@@ -143,6 +143,10 @@ src_prepare() {
# Fix libamf includes
epatch "${FILESDIR}"/${PN}-0.8.10-amf-include.patch
+ # Fix new adjacent_tokens_only() in >=boost-1.59 (bug 579142)
+ # See https://savannah.gnu.org/bugs/?46148
+ epatch "${FILESDIR}"/${P}-boost-1.60.patch
+
eautoreconf
}
src_configure() {