summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2016-03-01 23:33:01 +0100
committerRafael Martins <rafaelmartins@gentoo.org>2016-03-01 23:33:01 +0100
commit414aab53101a863624a86e6a4f2571888d0f9edf (patch)
tree85737284e28b9a515d6c196c81474078a2bf179a /www-servers/blogc-runserver/blogc-runserver-0.1.1.ebuild
parentdev-libs/openssl: Revbump to add subslot that reflects lack of SSLv2 (#575548). (diff)
downloadgentoo-414aab53101a863624a86e6a4f2571888d0f9edf.tar.gz
gentoo-414aab53101a863624a86e6a4f2571888d0f9edf.tar.bz2
gentoo-414aab53101a863624a86e6a4f2571888d0f9edf.zip
www-servers/blogc-runserver: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'www-servers/blogc-runserver/blogc-runserver-0.1.1.ebuild')
-rw-r--r--www-servers/blogc-runserver/blogc-runserver-0.1.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/www-servers/blogc-runserver/blogc-runserver-0.1.1.ebuild b/www-servers/blogc-runserver/blogc-runserver-0.1.1.ebuild
new file mode 100644
index 000000000000..649d7522651b
--- /dev/null
+++ b/www-servers/blogc-runserver/blogc-runserver-0.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/blogc/blogc-runserver.git
+ https://github.com/blogc/blogc-runserver.git"
+ inherit git-r3 autotools
+fi
+
+DESCRIPTION="A simple HTTP server to test blogc websites"
+HOMEPAGE="https://github.com/blogc/blogc-runserver"
+
+SRC_URI="https://github.com/blogc/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+ DEPEND="=dev-libs/squareball-9999"
+else
+ DEPEND=">=dev-libs/squareball-0.1"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${DEPEND}
+ dev-libs/libevent
+ sys-apps/file"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ --with-squareball=system
+}