summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-12-07 15:18:33 +0100
committerSebastian Pipping <sping@gentoo.org>2020-12-07 15:18:33 +0100
commit6bbbdac109fefb19b38123742c98ce8eee3411fe (patch)
tree89f8a74c536b0bf49645885a9e159bc51f98ddf9 /www-servers/gatling
parentapp-arch/rar: v6.0.0 from 2020-12-01 (diff)
downloadgentoo-6bbbdac109fefb19b38123742c98ce8eee3411fe.tar.gz
gentoo-6bbbdac109fefb19b38123742c98ce8eee3411fe.tar.bz2
gentoo-6bbbdac109fefb19b38123742c98ce8eee3411fe.zip
www-servers/gatling: Drop old versions causing DeprecatedEclass
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
Diffstat (limited to 'www-servers/gatling')
-rw-r--r--www-servers/gatling/Manifest1
-rw-r--r--www-servers/gatling/files/gatling-0.15-gcc10.patch38
-rw-r--r--www-servers/gatling/gatling-0.15.ebuild67
-rw-r--r--www-servers/gatling/gatling-0.16.ebuild66
4 files changed, 0 insertions, 172 deletions
diff --git a/www-servers/gatling/Manifest b/www-servers/gatling/Manifest
index 59942cd426c0..f422906b7320 100644
--- a/www-servers/gatling/Manifest
+++ b/www-servers/gatling/Manifest
@@ -1,2 +1 @@
-DIST gatling-0.15.tar.xz 121804 BLAKE2B 7df5f6d4fc823e8a1252bacca2b57d0848dd3a920216d1d3185d5f471f786eee1eb36396114b367660ead816bd4ee6c734099bbb9bdb5ffbd5b70a59e0fb0667 SHA512 b76d220a0644f1e6e7ea966a4eff409964c564fc4a31c4efdb764e5f7b5857bc58c26bc31e860fe35df932cbd60fb2b0f4f21c75cb5aa56427e8a2a453684716
DIST gatling-0.16.tar.xz 126844 BLAKE2B 33dd2e93833b216ffadae4dbd5650af87b23ed5d62caf181d8005acb4dce889b86d1afb711676377ba2b7c4fe08b8f2350a32965cf6292a268281b28c4310c27 SHA512 9446ea0ae862509b1a892e5bdef14d3a2320c3c3e846362b4679c0834aa906ab5b16ef54e4a7c8e7ee839d30317436dd411e891e3105035a9ee31b0facc0b8c1
diff --git a/www-servers/gatling/files/gatling-0.15-gcc10.patch b/www-servers/gatling/files/gatling-0.15-gcc10.patch
deleted file mode 100644
index 446ea5cffdec..000000000000
--- a/www-servers/gatling/files/gatling-0.15-gcc10.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From b815fc02179e8f25a6bea2bc1ee7306ffea37258 Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Thu, 26 Nov 2020 16:05:26 +0100
-Subject: [PATCH] Fix build with -fno-common or GCC 10
-
----
- dirfd.c | 1 +
- dirfd.h | 2 +-
- 2 files changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/dirfd.c b/dirfd.c
-index 6a0217e..792bd29 100644
---- a/dirfd.c
-+++ b/dirfd.c
-@@ -34,6 +34,7 @@ struct hashtable dc;
-
- #ifdef __linux__
- int rootwd;
-+int ifd;
- #endif
-
- /* initialize a hashtable as empty */
-diff --git a/dirfd.h b/dirfd.h
-index cdfc4a3..a76c5d8 100644
---- a/dirfd.h
-+++ b/dirfd.h
-@@ -21,7 +21,7 @@
- * given dir, and it will return the fd or -1 on error. */
-
- #ifdef __linux__
--int ifd; /* inotify fd */
-+extern int ifd; /* inotify fd */
- #endif
-
- struct dircacheentry {
---
-2.27.0
-
diff --git a/www-servers/gatling/gatling-0.15.ebuild b/www-servers/gatling/gatling-0.15.ebuild
deleted file mode 100644
index c18fb7fe8684..000000000000
--- a/www-servers/gatling/gatling-0.15.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit eutils toolchain-funcs user
-
-DESCRIPTION="High performance web server"
-HOMEPAGE="https://www.fefe.de/gatling/"
-SRC_URI="https://www.fefe.de/gatling/${P}.tar.xz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="libressl ssl diet"
-REQUIRED_USE="ssl? ( !diet )"
-
-DEPEND=">=dev-libs/libowfat-0.32-r2[diet=]
- diet? ( dev-libs/dietlibc )
- ssl? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.13-compile.patch"
- "${FILESDIR}/${P}-ar.patch"
- "${FILESDIR}/${P}-gcc10.patch"
-)
-
-src_prepare() {
- default
- rm Makefile # leaves us with GNUmakefile
-}
-
-src_compile() {
- local DIET=
- use diet && DIET='/usr/bin/diet'
-
- local targets='gatling'
- use ssl && targets+=' tlsgatling'
-
- emake DIET="${DIET}" CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} -I${ROOT}usr/include/libowfat" \
- LDFLAGS="${LDFLAGS}" prefix=/usr ${targets}
-}
-
-src_install() {
- doman gatling.1
-
- newconfd "${FILESDIR}/gatling.confd" gatling
- newinitd "${FILESDIR}/gatling.initd-3" gatling
- dodoc README.{ftp,http}
-
- dobin gatling
- use ssl && {
- dodoc README.tls
- dobin tlsgatling
- }
-}
-
-pkg_setup() {
- ebegin "Creating gatling user and group"
- enewgroup gatling
- enewuser ${PN} -1 -1 /var/www/localhost ${PN}
-}
diff --git a/www-servers/gatling/gatling-0.16.ebuild b/www-servers/gatling/gatling-0.16.ebuild
deleted file mode 100644
index c1b0e8bf0abe..000000000000
--- a/www-servers/gatling/gatling-0.16.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit eutils toolchain-funcs user
-
-DESCRIPTION="High performance web server"
-HOMEPAGE="https://www.fefe.de/gatling/"
-SRC_URI="https://www.fefe.de/gatling/${P}.tar.xz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="libressl ssl diet"
-REQUIRED_USE="ssl? ( !diet )"
-
-DEPEND=">=dev-libs/libowfat-0.32-r2[diet=]
- diet? ( dev-libs/dietlibc )
- ssl? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.13-compile.patch"
- "${FILESDIR}/${PN}-0.15-ar.patch"
-)
-
-src_prepare() {
- default
- rm Makefile # leaves us with GNUmakefile
-}
-
-src_compile() {
- local DIET=
- use diet && DIET='/usr/bin/diet'
-
- local targets='gatling'
- use ssl && targets+=' tlsgatling'
-
- emake DIET="${DIET}" CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} -I${ROOT}/usr/include/libowfat" \
- LDFLAGS="${LDFLAGS}" prefix=/usr ${targets}
-}
-
-src_install() {
- doman gatling.1
-
- newconfd "${FILESDIR}/gatling.confd" gatling
- newinitd "${FILESDIR}/gatling.initd-3" gatling
- dodoc README.{ftp,http}
-
- dobin gatling
- use ssl && {
- dodoc README.tls
- dobin tlsgatling
- }
-}
-
-pkg_setup() {
- ebegin "Creating gatling user and group"
- enewgroup gatling
- enewuser ${PN} -1 -1 /var/www/localhost ${PN}
-}