summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafaelmartins@gentoo.org>2018-05-15 00:46:51 +0200
committerRafael G. Martins <rafaelmartins@gentoo.org>2018-05-15 00:46:51 +0200
commit1388b133852e3ba06bf9e70e06d1c899f1cf3839 (patch)
tree758a266a3d56bece8d97183cb38d6e1314b907e3 /www-servers/gunicorn/gunicorn-19.8.1.ebuild
parentapp-shells/hstr: version bump. (diff)
downloadgentoo-1388b133852e3ba06bf9e70e06d1c899f1cf3839.tar.gz
gentoo-1388b133852e3ba06bf9e70e06d1c899f1cf3839.tar.bz2
gentoo-1388b133852e3ba06bf9e70e06d1c899f1cf3839.zip
www-servers/gunicorn: version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'www-servers/gunicorn/gunicorn-19.8.1.ebuild')
-rw-r--r--www-servers/gunicorn/gunicorn-19.8.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/www-servers/gunicorn/gunicorn-19.8.1.ebuild b/www-servers/gunicorn/gunicorn-19.8.1.ebuild
new file mode 100644
index 000000000000..8aef7da541fa
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-19.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="http://gunicorn.org https://pypi.org/project/gunicorn https://github.com/benoitc/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT PSF-2 doc? ( BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+DOCS="README.rst"
+
+python_prepare_all() {
+ sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}