summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-14 10:44:07 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-14 12:18:05 +0200
commite8aa87af5d9e6c0b533e42f0924c13ac0cd2d412 (patch)
tree24224c084c34a05022be26bc0e6c9aef1826b3cc /www-servers/spawn-fcgi
parentwww-servers/spawn-fcgi: Several fixes to init.d script (diff)
downloadgentoo-e8aa87af5d9e6c0b533e42f0924c13ac0cd2d412.tar.gz
gentoo-e8aa87af5d9e6c0b533e42f0924c13ac0cd2d412.tar.bz2
gentoo-e8aa87af5d9e6c0b533e42f0924c13ac0cd2d412.zip
www-servers/spawn-fcgi: Drop old
Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'www-servers/spawn-fcgi')
-rw-r--r--www-servers/spawn-fcgi/files/spawn-fcgi.initd-r2116
-rw-r--r--www-servers/spawn-fcgi/spawn-fcgi-1.6.3-r2.ebuild32
-rw-r--r--www-servers/spawn-fcgi/spawn-fcgi-1.6.4.ebuild32
3 files changed, 0 insertions, 180 deletions
diff --git a/www-servers/spawn-fcgi/files/spawn-fcgi.initd-r2 b/www-servers/spawn-fcgi/files/spawn-fcgi.initd-r2
deleted file mode 100644
index e7941a125a58..000000000000
--- a/www-servers/spawn-fcgi/files/spawn-fcgi.initd-r2
+++ /dev/null
@@ -1,116 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-PROGNAME=${SVCNAME#*.}
-SPAWNFCGI=/usr/bin/spawn-fcgi
-PIDPATH=/run/spawn-fcgi
-PIDFILE=${PIDPATH}/${PROGNAME}
-
-depend() {
- need net
-}
-
-start() {
- local X E OPTIONS i RETVAL FCGI_PROGRAM_EXEC
- FCGI_PROGRAM_EXEC=$(echo ${FCGI_PROGRAM} | awk "{print \$1}")
-
- if [ "${SVCNAME}" = "spawn-fcgi" ]; then
- eerror "You are not supposed to run this script directly. Create a symlink"
- eerror "for the FastCGI application you want to run as well as a copy of the"
- eerror "configuration file and modify it appropriately like so..."
- eerror
- eerror " ln -s spawn-fcgi /etc/init.d/spawn-fcgi.trac"
- eerror " cp /etc/conf.d/spawn-fcgi /etc/conf.d/spawn-fcgi.trac"
- eerror " `basename "${EDITOR}"` /etc/conf.d/spawn-fcgi.trac"
- eerror
- return 1
- fi
-
- if [ ! -z "${FCGI_SOCKET}" ] && [ ! -z "${FCGI_PORT}" ]; then
- eerror "Only one of the two may be defined:"
- eerror " FCGI_SOCKET=${FCGI_SOCKET}"
- eerror " FCGI_PORT=${FCGI_PORT}"
- return 1
- fi
-
- if [ -z "${FCGI_PROGRAM}" ]; then
- eerror "You need to specify which \$FCGI_PROGRAM"
- eerror "you want to start."
- eerror "Please adjust /etc/conf.d/spawn-fcgi.${PROGNAME}"
- return 1
- fi
-
- if [ ! -x "${FCGI_PROGRAM_EXEC}" ]; then
- eerror "The file specified as \$FCGI_PROGRAM"
- eerror "does not exist or is not executable."
- eerror "Please adjust /etc/conf.d/spawn-fcgi.${PROGNAME}"
- return 1
- fi
-
- if [ -z "${FCGI_ADDRESS}" ]; then
- FCGI_ADDRESS=127.0.0.1
- fi
-
- if [ -z "${FCGI_CHILDREN}" ]; then
- FCGI_CHILDREN=1
- fi
-
- if [ -n "${FCGI_CHROOT}" ]; then
- OPTIONS="${OPTIONS} -c ${FCGI_CHROOT}"
- fi
-
- if [ -n "${FCGI_DIR}" ]; then
- OPTIONS="${OPTIONS} -d ${FCGI_DIR}"
- fi
-
- if [ -n "${FCGI_USER}" ] && [ "${FCGI_USER}" != "root" ]; then
- OPTIONS="${OPTIONS} -u ${FCGI_USER}"
- fi
-
- if [ -n "${FCGI_GROUP}" ] && [ "${FCGI_GROUP}" != "root" ]; then
- OPTIONS="${OPTIONS} -g ${FCGI_GROUP}"
- fi
-
- if [ -n "${FCGI_EXTRA_OPTIONS}" ]; then
- OPTIONS="${OPTIONS} ${FCGI_EXTRA_OPTIONS}"
- fi
-
- unset E
- for i in ${ALLOWED_ENV}; do
- local j
- eval j=$(echo \$"$i")
- [ -n "${j}" ] && E="${E} ${i}=${j}"
- done
-
- ebegin "Starting FastCGI application ${PROGNAME}"
- checkpath -q -d -m 700 /run/spawn-fcgi
- X=0
- while [ $X -lt ${FCGI_CHILDREN} ]; do
- X=$(($X+1))
- local P SOCKET_OPTION INET_OPTION
- P=${PIDFILE}-${X}.pid
- [ -n "${FCGI_SOCKET}" ] && SOCKET_OPTION="-s ${FCGI_SOCKET}-${X}"
- [ -n "${FCGI_PORT}" ] && INET_OPTION="-a ${FCGI_ADDRESS} -p $((${FCGI_PORT} + ${X} - 1))"
-
- env -i ${E} /sbin/start-stop-daemon --start --pidfile ${P} --exec ${SPAWNFCGI} \
- --name ${FCGI_PROGRAM_EXEC} -- ${SOCKET_OPTION} ${INET_OPTION} \
- -P ${P} ${OPTIONS} -- ${FCGI_PROGRAM}
- RETVAL=$?
-
- # Stop on error. Don't want to spawn a mess!
- [ "${RETVAL}" != "0" ] && break
- done
- eend ${RETVAL}
-}
-
-stop() {
- local X RETVAL=0
-
- ebegin "Stopping FastCGI application ${PROGNAME}"
- for X in ${PIDFILE}-[0-9]*.pid ; do
- start-stop-daemon --stop --pidfile ${X} || \
- { RETVAL=$? && break ; }
- done
- eend ${RETVAL}
-}
diff --git a/www-servers/spawn-fcgi/spawn-fcgi-1.6.3-r2.ebuild b/www-servers/spawn-fcgi/spawn-fcgi-1.6.3-r2.ebuild
deleted file mode 100644
index a19ec429e424..000000000000
--- a/www-servers/spawn-fcgi/spawn-fcgi-1.6.3-r2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DESCRIPTION="A FCGI spawner for lighttpd and cherokee and other webservers"
-HOMEPAGE="http://redmine.lighttpd.net/projects/spawn-fcgi"
-SRC_URI="http://www.lighttpd.net/download/${P}.tar.bz2"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="ipv6"
-
-DEPEND=""
-RDEPEND="
- !<=www-servers/lighttpd-1.4.20
- !<=www-servers/cherokee-0.98.1"
-
-src_configure() {
- econf $(use_enable ipv6)
-}
-
-src_install() {
- default
-
- newconfd "${FILESDIR}"/spawn-fcgi.confd spawn-fcgi
- newinitd "${FILESDIR}"/spawn-fcgi.initd-r2 spawn-fcgi
-
- docinto examples
- dodoc doc/run-generic doc/run-php doc/run-rails
-}
diff --git a/www-servers/spawn-fcgi/spawn-fcgi-1.6.4.ebuild b/www-servers/spawn-fcgi/spawn-fcgi-1.6.4.ebuild
deleted file mode 100644
index 4068e674e390..000000000000
--- a/www-servers/spawn-fcgi/spawn-fcgi-1.6.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DESCRIPTION="A FCGI spawner for lighttpd and cherokee and other webservers"
-HOMEPAGE="http://redmine.lighttpd.net/projects/spawn-fcgi"
-SRC_URI="http://www.lighttpd.net/download/${P}.tar.xz"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="ipv6"
-
-DEPEND=""
-RDEPEND="
- !<=www-servers/lighttpd-1.4.20
- !<=www-servers/cherokee-0.98.1"
-
-src_configure() {
- econf $(use_enable ipv6)
-}
-
-src_install() {
- default
-
- newconfd "${FILESDIR}"/spawn-fcgi.confd spawn-fcgi
- newinitd "${FILESDIR}"/spawn-fcgi.initd-r2 spawn-fcgi
-
- docinto examples
- dodoc doc/run-generic doc/run-php doc/run-rails
-}