summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-21 21:17:57 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-21 21:20:02 +0200
commite6eb690ffb5a238cdc950ba94dfd574278fc461c (patch)
tree7ff84854780b57876e9867c4eca8cd44d0d1a838 /www-servers
parentnet-misc/openntpd: create chroot (bug #619118) (diff)
downloadgentoo-e6eb690ffb5a238cdc950ba94dfd574278fc461c.tar.gz
gentoo-e6eb690ffb5a238cdc950ba94dfd574278fc461c.tar.bz2
gentoo-e6eb690ffb5a238cdc950ba94dfd574278fc461c.zip
www-servers/pshs: Bump to 0.3.2 (getopt bugfix)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pshs/Manifest1
-rw-r--r--www-servers/pshs/pshs-0.3.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/www-servers/pshs/Manifest b/www-servers/pshs/Manifest
index 6705107a1b08..b2f144f993ae 100644
--- a/www-servers/pshs/Manifest
+++ b/www-servers/pshs/Manifest
@@ -1,2 +1,3 @@
DIST pshs-0.3.1.tar.bz2 80022 SHA256 842a60bd0451c5ad86566d5d42a83eeccd9c5d91118d62f7483f6be4c483bfa8 SHA512 a82c2a3e6fa64e521d77fafc48d1d9a6799d62c16cef3f01b3c11ba17e4e98cedafd200abaa97a45563f6d78efcfc6dbef4c5fa84ba39e9857fdc9ea2b1dc2c2 WHIRLPOOL ac4dd540182687a7be1b711a7b5895fadc6cb650d6b5c540442e33569c5fd6ea7ddc921f8b5e1e7be3b9d0544183c31f58400970bfac7d4690986304fa9df2e4
+DIST pshs-0.3.2.tar.bz2 80103 SHA256 a46ff74422c27eb50e4885d519275b0c410c5e38707bc15e6bea84e5594ac32d SHA512 82eb0e0ff76ad6d5651b789ca59b654558562501f9f4b89a562773f5c60e80c6d43a86fca35a41a313952d8134b83fe6a11d1085c8c35cb9bbffd6d2a243964a WHIRLPOOL 4acb5d2538e47b57d29aa1b7c43c228da532354d7dac9278c0db09b0c0004fc747134cf4b2e0388b27cd2f814f5d802cd068ab26e467c489b21a66686d4aa0a0
DIST pshs-0.3.tar.bz2 81622 SHA256 c3c4d2abc7f3ee9ef80eff2dd4811d542ab5b4b229e3a0615c50ae2a530d7e63 SHA512 17dd21603ea36ecbe69923a2c476f6f41fea026b654a9d4819132047bad67f60a797cd0008afc85ab27ed3538681cfe8d79f9f33fc60823fd425337138723d45 WHIRLPOOL 515e551f41aee68729594f00bad4a9b48974103897d3e9a31e9ac77fe5dec62284cedac78759513b198d3638c3529842e517a903ee09b1aabb265dce6eeb92d2
diff --git a/www-servers/pshs/pshs-0.3.2.ebuild b/www-servers/pshs/pshs-0.3.2.ebuild
new file mode 100644
index 000000000000..fc0cb0facdc0
--- /dev/null
+++ b/www-servers/pshs/pshs-0.3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Pretty small HTTP server -- a command-line tool to share files"
+HOMEPAGE="https://github.com/mgorny/pshs/"
+SRC_URI="https://github.com/mgorny/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl +magic +netlink qrcode ssl upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ ssl? ( >=dev-libs/libevent-2.1:0=[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}
+ netlink? ( sys-apps/iproute2
+ >=sys-kernel/linux-headers-2.6.27 )"
+# libnetlink is static only ATM
+
+src_configure() {
+ local myconf=(
+ $(use_enable magic libmagic)
+ $(use_enable netlink)
+ $(use_enable qrcode qrencode)
+ $(use_enable ssl)
+ $(use_enable upnp)
+ )
+
+ econf "${myconf[@]}"
+}