summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2018-09-25 11:56:40 +0300
committerMaxim Koltsov <maksbotan@gentoo.org>2019-01-02 18:48:30 +0300
commit89df135b62ba273ffbaa8c91391aa27f366b27fa (patch)
treebe1e39a666070ccc94d036975ca0751e9feb1d0e /x11-apps/copyq
parentapp-text/dvipng: Remove old. (diff)
downloadgentoo-89df135b62ba273ffbaa8c91391aa27f366b27fa.tar.gz
gentoo-89df135b62ba273ffbaa8c91391aa27f366b27fa.tar.bz2
gentoo-89df135b62ba273ffbaa8c91391aa27f366b27fa.zip
x11-apps/copyq: bump to 3.7.2
- add missing qtx11extras dependency - update icon cache Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Maxim Koltsov <maksbotan@gentoo.org>
Diffstat (limited to 'x11-apps/copyq')
-rw-r--r--x11-apps/copyq/Manifest2
-rw-r--r--x11-apps/copyq/copyq-3.7.2.ebuild (renamed from x11-apps/copyq/copyq-3.5.0.ebuild)15
2 files changed, 14 insertions, 3 deletions
diff --git a/x11-apps/copyq/Manifest b/x11-apps/copyq/Manifest
index bcf3fb2265bd..a9dfd0e3a5a8 100644
--- a/x11-apps/copyq/Manifest
+++ b/x11-apps/copyq/Manifest
@@ -1,2 +1,2 @@
-DIST CopyQ-3.5.0.tar.gz 3004460 BLAKE2B 30b2d732e87dd5ffea4d07adec14a377feddf2b7e89caf235e0a6bde5781419ec186bf40c687f14d658603ed3aebe43e5010a062560748a8dc00311f0f52a821 SHA512 9e662c8f80a59d58fbc8c51990682bfe61582ebdeba240e49996aab618b0a118422b0f2023952ef8cdf8e00f50ec4d7c67bd874abacf564226fb096dcc6d944d
+DIST CopyQ-3.7.2.tar.gz 2882944 BLAKE2B 3fd90b719b931ad9d92cca97f3ad284dc454ea5644907fa61b51b70eef5c42f41d52323346c0d24611c99cd2004a0528111125726d5cefe64f2cc9ead22d1f94 SHA512 dff6530375ea674502b754866c0011f3436796fc0535dc9cd317640b8cab4620e821b440df62d229a3d1dba371a7ae0c4a03e5d3366dd845218ab1516196d730
DIST copyq-2.8.1.tar.gz 1573991 BLAKE2B 464c7fb462638ae717ee70dffcf5fb6eaf628dd4640c9db9d757769ac07479424fc953d81c92ed0e11015802432a9e556171994e8e2da7d0ce11868dcdf57cb6 SHA512 77602d39b0cb5fd0c8bd8d6c1ba5079e95ad72dc846c3e273556ffe029732e65bfd0951954de856c894bd7b6ebae816dfe7048040d77f7f3cd07faa922260b57
diff --git a/x11-apps/copyq/copyq-3.5.0.ebuild b/x11-apps/copyq/copyq-3.7.2.ebuild
index 1607b43b0199..0c5b8ccd84f5 100644
--- a/x11-apps/copyq/copyq-3.5.0.ebuild
+++ b/x11-apps/copyq/copyq-3.7.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils
+inherit cmake-utils gnome2-utils
MY_P=CopyQ-${PV}
@@ -25,6 +25,7 @@ RDEPEND="
dev-qt/qtscript:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
x11-libs/libX11
x11-libs/libXfixes
x11-libs/libXtst
@@ -37,11 +38,21 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/$MY_P
src_configure() {
+ # CMakeLists.txt concatenates INSTALL_PREFIX with INSTALL_MANDIR leading to /usr/usr
local mycmakeargs=(
-DPLUGIN_INSTALL_PREFIX="/usr/$(get_libdir)/${PN}/plugins"
-DWITH_QT5=ON
-DWITH_TESTS=$(usex test)
-DWITH_WEBKIT=$(usex webkit)
+ -DCMAKE_INSTALL_MANDIR="share/man"
)
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}