summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMohanram Meenakshisundaram <mohanram.meenakshisundaram@gmail.com>2020-04-17 19:30:31 +0530
committerMatt Turner <mattst88@gentoo.org>2020-05-04 13:46:53 -0700
commit4e726aa879fbaf237cc3a4dcad72afd89b7f387d (patch)
treecb2cc24f883a07b6fa16251a8143136ee0503f08 /x11-apps
parentprofiles: removal of keyboard and mouse INPUT_DEVICES defaults. (diff)
downloadgentoo-4e726aa879fbaf237cc3a4dcad72afd89b7f387d.tar.gz
gentoo-4e726aa879fbaf237cc3a4dcad72afd89b7f387d.tar.bz2
gentoo-4e726aa879fbaf237cc3a4dcad72afd89b7f387d.zip
x11-apps/igt-gpu-tools: Version bump to 1.25
New igt-gpu-tools 1.25 release contains new hardware supports, improvements and bug fixes check the release notes here https://cgit.freedesktop.org/xorg/app/intel-gpu-tools/commit/?h=igt-gpu-tools-1.25&id=f49ebeee9f54d6f23c60a842f75f65561d452ab0 Closes:https://bugs.gentoo.org/718582 Closes:https://github.com/gentoo/gentoo/pull/15385 Signed-off-by: Mohanram Meenakshisundaram <mohanram.meenakshisundaram@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/igt-gpu-tools/Manifest1
-rw-r--r--x11-apps/igt-gpu-tools/igt-gpu-tools-1.25.ebuild103
-rw-r--r--x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild22
3 files changed, 115 insertions, 11 deletions
diff --git a/x11-apps/igt-gpu-tools/Manifest b/x11-apps/igt-gpu-tools/Manifest
index da385bc220c9..63f3124187c1 100644
--- a/x11-apps/igt-gpu-tools/Manifest
+++ b/x11-apps/igt-gpu-tools/Manifest
@@ -1 +1,2 @@
DIST igt-gpu-tools-1.24.tar.xz 1207436 BLAKE2B 0b04033be0195a4fee5611aeae2f47334ce1de5df65c652ebc0b36d1185286268bb426f472e3c1311ff576e8184e7a4efb95ef3181006ed8c448ea76452940d7 SHA512 22c25e27ead64f561fe8f46b132d6c7562a90d7bff09dc2618a532b16d7b8fdf54ed94d986a45655657b54219d350ce1b1e6c89da2b6073024e9bbe0973fa190
+DIST igt-gpu-tools-1.25.tar.xz 1425652 BLAKE2B 1dd17e8542c126d356478acd07344d8732013a24fd180064d6f2277be76170924e7031fd2529b2aa054b40d5093d9cd95271e156bc6b97a75158c84de142f1ba SHA512 a24ee46092241da26fc2dac2b9b54c9f16f7a408c8740c9c7209e876929e2908a36261ba258ca4a4a4e4a21c1e9c919457bf98d514f81d8b7dbfcf5f89a74daf
diff --git a/x11-apps/igt-gpu-tools/igt-gpu-tools-1.25.ebuild b/x11-apps/igt-gpu-tools/igt-gpu-tools-1.25.ebuild
new file mode 100644
index 000000000000..e87a5ccf4a7a
--- /dev/null
+++ b/x11-apps/igt-gpu-tools/igt-gpu-tools-1.25.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGIT_REPO_URI="https://gitlab.freedesktop.org/drm/${PN}.git"
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson
+
+DESCRIPTION="Intel GPU userland tools"
+
+HOMEPAGE="https://01.org/linuxgraphics https://gitlab.freedesktop.org/drm/igt-gpu-tools"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://www.x.org/releases/individual/app/${P}.tar.xz"
+fi
+LICENSE="MIT"
+SLOT="0"
+IUSE="chamelium doc man overlay runner unwind valgrind video_cards_amdgpu video_cards_intel video_cards_nouveau X xv"
+REQUIRED_USE="
+ || ( video_cards_amdgpu video_cards_intel video_cards_nouveau )
+ overlay? (
+ video_cards_intel
+ || ( X xv )
+ )
+"
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/elfutils
+ dev-libs/glib:2
+ sys-apps/kmod:=
+ sys-libs/libunwind:=
+ sys-libs/zlib:=
+ sys-process/procps:=
+ virtual/libudev:=
+ >=x11-libs/cairo-1.12.0[X?]
+ >=x11-libs/libdrm-2.4.82[video_cards_amdgpu?,video_cards_intel?,video_cards_nouveau?]
+ >=x11-libs/libpciaccess-0.10
+ x11-libs/pixman
+ chamelium? (
+ dev-libs/xmlrpc-c[curl]
+ sci-libs/gsl
+ media-libs/alsa-lib:=
+ )
+ overlay? (
+ >=x11-libs/libXrandr-1.3
+ xv? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXv
+ )
+ )
+ runner? ( dev-libs/json-c:= )
+ unwind? ( sys-libs/libunwind )
+ valgrind? ( dev-util/valgrind )
+ "
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.25-r1 )
+ man? ( dev-python/docutils )
+ overlay? (
+ >=dev-util/peg-0.1.18
+ x11-base/xorg-proto
+ )
+ video_cards_intel? (
+ sys-devel/bison
+ sys-devel/flex
+ )
+"
+
+src_prepare() {
+ sed -e "s/find_program('rst2man-3'/find_program('rst2man.py', 'rst2man-3'/" -i man/meson.build
+ default_src_prepare
+}
+
+src_configure() {
+ local gpus=""
+ use video_cards_amdgpu && gpus+="amdgpu,"
+ use video_cards_intel && gpus+="intel,"
+ use video_cards_nouveau && gpus+="nouveau,"
+
+ local overlay_backends=""
+ use overlay && use xv && overlay_backends+="xv,"
+ use overlay && use X && overlay_backends+="x,"
+
+ local emesonargs=(
+ $(meson_feature chamelium)
+ $(meson_feature doc docs)
+ $(meson_feature man)
+ $(meson_feature overlay)
+ $(meson_feature runner)
+ $(meson_feature doc tests) # Test build is required for docs
+ $(meson_feature valgrind)
+ $(meson_feature unwind libunwind)
+ -Doverlay_backends=${overlay_backends%?}
+ -Dlibdrm_drivers=${gpus%?}
+ )
+ meson_src_configure
+}
diff --git a/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild b/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
index 8662c0102ba5..e87a5ccf4a7a 100644
--- a/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
+++ b/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
EGIT_REPO_URI="https://gitlab.freedesktop.org/drm/${PN}.git"
if [[ ${PV} = *9999* ]]; then
GIT_ECLASS="git-r3"
@@ -88,16 +88,16 @@ src_configure() {
use overlay && use X && overlay_backends+="x,"
local emesonargs=(
- $(meson_feature chamelium build_chamelium)
- $(meson_feature doc build_docs)
- $(meson_feature man build_man)
- $(meson_feature overlay build_overlay)
- $(meson_feature runner build_runner)
- $(meson_feature doc build_tests) # Test build is required for docs
- $(meson_feature valgrind with_valgrind)
- $(meson_feature unwind with_libunwind)
+ $(meson_feature chamelium)
+ $(meson_feature doc docs)
+ $(meson_feature man)
+ $(meson_feature overlay)
+ $(meson_feature runner)
+ $(meson_feature doc tests) # Test build is required for docs
+ $(meson_feature valgrind)
+ $(meson_feature unwind libunwind)
-Doverlay_backends=${overlay_backends%?}
- -Dwith_libdrm=${gpus%?}
+ -Dlibdrm_drivers=${gpus%?}
)
meson_src_configure
}