summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGino McCarty <onigino@protonmail.com>2020-04-19 15:38:05 -0700
committerJoonas Niilola <juippis@gentoo.org>2020-04-28 10:44:06 +0300
commitd2bc2a37258fca2e0f4eab52cecfc809509f07c0 (patch)
tree75cee5e3151f5858c6115ecf4ff5d783444a9d18 /x11-apps
parentapp-crypt/trousers: Fix -fno-common/gcc10 compile error (diff)
downloadgentoo-d2bc2a37258fca2e0f4eab52cecfc809509f07c0.tar.gz
gentoo-d2bc2a37258fca2e0f4eab52cecfc809509f07c0.tar.bz2
gentoo-d2bc2a37258fca2e0f4eab52cecfc809509f07c0.zip
x11-apps/copyq: Version bump to 3.10.0
Closes: https://bugs.gentoo.org/show_bug.cgi?id=696406 Signed-off-by: Gino McCarty <onigino@protonmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/copyq/Manifest1
-rw-r--r--x11-apps/copyq/copyq-3.10.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-apps/copyq/Manifest b/x11-apps/copyq/Manifest
index cd543f535d17..bf21a31cf9ac 100644
--- a/x11-apps/copyq/Manifest
+++ b/x11-apps/copyq/Manifest
@@ -1,2 +1,3 @@
+DIST CopyQ-3.10.0.tar.gz 2832904 BLAKE2B 78866a3ecbd1ed4d1ab06db552ef517234c1354609ef2bc18f8c4d8fa22342c7479a5bde79b9333f896dee4fe18543e47657c780b821f45121e0413c597b45aa SHA512 6cae338a144d7f92850ce88c991ed99222613c57540ced49dab719e43af884bbd9d15e6e8f074c6af94b0ac2ecd1b355eff8b83ec99f688c0f93fa19f253d653
DIST CopyQ-3.7.2.tar.gz 2882944 BLAKE2B 3fd90b719b931ad9d92cca97f3ad284dc454ea5644907fa61b51b70eef5c42f41d52323346c0d24611c99cd2004a0528111125726d5cefe64f2cc9ead22d1f94 SHA512 dff6530375ea674502b754866c0011f3436796fc0535dc9cd317640b8cab4620e821b440df62d229a3d1dba371a7ae0c4a03e5d3366dd845218ab1516196d730
DIST CopyQ-3.8.0.tar.gz 2909764 BLAKE2B 73b5f1b088bdea6db7a1141d8b029329210c18f980caf8ff52746894d672885c0940b7eeea2e66ed4d7957ea83649780860fd97e93f8eb02aad4cb8d3e687472 SHA512 ae22e5e00a2624b5fb551790ccda82f4a10a026cfd16d6526b370a0a210a939f2a11d0729f2b735e201085083514ff9eff8cda69ee2d360766fbfb7ea49b6c5e
diff --git a/x11-apps/copyq/copyq-3.10.0.ebuild b/x11-apps/copyq/copyq-3.10.0.ebuild
new file mode 100644
index 000000000000..4bcda78587f5
--- /dev/null
+++ b/x11-apps/copyq/copyq-3.10.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+MY_P=CopyQ-${PV}
+
+DESCRIPTION="Clipboard manager with advanced features"
+HOMEPAGE="https://github.com/hluk/CopyQ"
+SRC_URI="https://github.com/hluk/CopyQ/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test webkit"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtscript:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXtst
+ webkit? ( dev-qt/qtwebkit:5 )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ test? ( dev-qt/qttest:5 )
+"
+S=${WORKDIR}/$MY_P
+
+src_configure() {
+ # CMakeLists.txt concatenates INSTALL_PREFIX with INSTALL_MANDIR leading to /usr/usr
+ local mycmakeargs=(
+ -DPLUGIN_INSTALL_PREFIX="/usr/$(get_libdir)/${PN}/plugins"
+ -DWITH_QT5=ON
+ -DWITH_TESTS=$(usex test)
+ -DWITH_WEBKIT=$(usex webkit)
+ -DCMAKE_INSTALL_MANDIR="share/man"
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}