summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-08 18:50:51 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-08 19:05:42 -0700
commitdb0db442ab5220efe9ab11ea8f931ff9b83d460a (patch)
tree78e153fc1600bbeef7bf1ea37edc3114be3ff411 /x11-apps
parentdev-libs/libinput: Inform users about dev-python/python-libevdev (diff)
downloadgentoo-db0db442ab5220efe9ab11ea8f931ff9b83d460a.tar.gz
gentoo-db0db442ab5220efe9ab11ea8f931ff9b83d460a.tar.bz2
gentoo-db0db442ab5220efe9ab11ea8f931ff9b83d460a.zip
x11-apps/xinit: Fix postinstall message
Closes: https://bugs.gentoo.org/710294 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/xinit-1.4.1.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/x11-apps/xinit/xinit-1.4.1.ebuild b/x11-apps/xinit/xinit-1.4.1.ebuild
index 70f4ab1c68ae..cd467fa426af 100644
--- a/x11-apps/xinit/xinit-1.4.1.ebuild
+++ b/x11-apps/xinit/xinit-1.4.1.ebuild
@@ -53,7 +53,7 @@ src_install() {
}
pkg_postinst() {
- if ! has_version 'x11-apps/xinit'; then
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
ewarn "any executable. When you run startx, it will run this as the login session."
@@ -64,11 +64,13 @@ pkg_postinst() {
ewarn " env-update && source /etc/profile"
fi
- if has_version "<${CATEGORY}/${PN}-1.4.1"; then
- ewarn "Starting with ${CATEGORY}/${PN}-1.4.1 serverauth files are no longer kept in the"
- ewarn "home directory but rather are created in \$TMPDIR (typically /tmp). The change"
- ewarn "is transparent for most of users, however those that use runtime temporary"
- ewarn "directories cleaning tools, like app-admin/tmpreaper, may need to adjust them"
- ewarn "not to remove the 'serverauth.*' files."
- fi
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "$v" "-lt" "1.4.1"; then
+ ewarn "Starting with ${CATEGORY}/${PN}-1.4.1 serverauth files are no longer kept in the"
+ ewarn "home directory but rather are created in \$TMPDIR (typically /tmp). The change"
+ ewarn "is transparent for most of users, however those that use runtime temporary"
+ ewarn "directories cleaning tools, like app-admin/tmpreaper, may need to adjust them"
+ ewarn "not to remove the 'serverauth.*' files."
+ fi
+ done
}