summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-06-24 13:36:07 -0700
committerMatt Turner <mattst88@gentoo.org>2020-06-24 13:38:57 -0700
commitf6ad7d8754c7f4cf9d871d78a191d3ba6f198b64 (patch)
treeee2ba7eac856e37d0bbddca28e29bea652b79e14 /x11-apps
parentx11-apps/xinput_calibrator: Drop stable keywords (diff)
downloadgentoo-f6ad7d8754c7f4cf9d871d78a191d3ba6f198b64.tar.gz
gentoo-f6ad7d8754c7f4cf9d871d78a191d3ba6f198b64.tar.bz2
gentoo-f6ad7d8754c7f4cf9d871d78a191d3ba6f198b64.zip
x11-apps/xinput_calibrator: Port to EAPI 7
And drop IUSE=gtk since it depends on gtkmm:2.4. Closes: https://bugs.gentoo.org/421363 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild (renamed from x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r1.ebuild)15
1 files changed, 7 insertions, 8 deletions
diff --git a/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r1.ebuild b/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild
index 79564888e2c6..7a3d3101534e 100644
--- a/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r1.ebuild
+++ b/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools-utils flag-o-matic
+EAPI=7
+inherit flag-o-matic
DESCRIPTION="A generic touchscreen calibration program for X.Org"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/xinput_calibrator"
@@ -11,21 +11,20 @@ SRC_URI="https://github.com/downloads/tias/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="gtk"
+IUSE=""
RDEPEND="x11-libs/libX11
x11-libs/libXext
x11-libs/libXi
- x11-libs/libXrandr
- gtk? ( dev-cpp/gtkmm:2.4 )"
+ x11-libs/libXrandr"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
src_configure() {
append-cxxflags -std=c++11 #566594
- local myeconfargs=(
- --with-gui=$(use gtk && echo "gtkmm" || echo "x11")
+ local myconf=(
+ --with-gui=x11
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
}