summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-02-27 20:36:38 -0800
committerMatt Turner <mattst88@gentoo.org>2019-02-27 21:44:46 -0800
commitf4d9d7a5278621e1af50506533344577a8e66626 (patch)
tree7cc687045aa4efbda9c78a7571713958a106c226 /x11-base/xorg-server
parentxorg-3.eclass: Copy from xorg-2.eclass and add EAPI 7 support (diff)
downloadgentoo-f4d9d7a5278621e1af50506533344577a8e66626.tar.gz
gentoo-f4d9d7a5278621e1af50506533344577a8e66626.tar.bz2
gentoo-f4d9d7a5278621e1af50506533344577a8e66626.zip
x11-base/xorg-server: Port to EAPI 7
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base/xorg-server')
-rw-r--r--x11-base/xorg-server/xorg-server-9999.ebuild27
1 files changed, 8 insertions, 19 deletions
diff --git a/x11-base/xorg-server/xorg-server-9999.ebuild b/x11-base/xorg-server/xorg-server-9999.ebuild
index d1cbe013ded9..f9f7d5827997 100644
--- a/x11-base/xorg-server/xorg-server-9999.ebuild
+++ b/x11-base/xorg-server/xorg-server-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
XORG_DOC=doc
-inherit xorg-2 multilib versionator flag-o-matic
+inherit xorg-3 multilib flag-o-matic
EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/xserver.git"
DESCRIPTION="X.Org X servers"
@@ -101,7 +101,7 @@ RDEPEND="${CDEPEND}
"
PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
+ xorg? ( >=x11-base/xorg-drivers-$(ver_cut 1-2) )"
REQUIRED_USE="!minimal? (
|| ( ${IUSE_SERVERS} )
@@ -109,9 +109,8 @@ REQUIRED_USE="!minimal? (
minimal? ( !glamor !wayland )
xephyr? ( kdrive )"
-#UPSTREAMED_PATCHES=(
-# "${WORKDIR}/patches/"
-#)
+UPSTREAMED_PATCHES=(
+)
PATCHES=(
"${UPSTREAMED_PATCHES[@]}"
@@ -120,20 +119,12 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.18-support-multiple-Files-sections.patch
)
-pkg_pretend() {
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" && $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
-}
-
pkg_setup() {
if use wayland && ! use glamor; then
ewarn "glamor is necessary for acceleration under Xwayland."
ewarn "Performance may be unacceptable without it."
fi
-}
-src_configure() {
# localstatedir is used for the log location; we need to override the default
# from ebuild.sh
# sysconfdir is used for the xorg.conf location; same applies
@@ -176,18 +167,16 @@ src_configure() {
--without-fop
--with-sha1=libcrypto
)
-
- xorg-2_src_configure
}
src_install() {
- xorg-2_src_install
+ default
server_based_install
if ! use minimal && use xorg; then
# Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
+ dodoc "${S}"/hw/xfree86/xorg.conf.example
fi
newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup