summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-10-29 14:43:35 +0100
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-10-29 14:43:35 +0100
commita68fb875cdc5d83bfe3e28686ca39b86032e3a94 (patch)
tree66265c5868e22054cdbbe484e1d7365df6e1a999 /x11-base
parentnet-misc/yandex-disk: version bump, install locales and man page (diff)
downloadgentoo-a68fb875cdc5d83bfe3e28686ca39b86032e3a94.tar.gz
gentoo-a68fb875cdc5d83bfe3e28686ca39b86032e3a94.tar.bz2
gentoo-a68fb875cdc5d83bfe3e28686ca39b86032e3a94.zip
x11-base/xorg-server: remove versions that crash with xproto-7.0.28
Bug: https://bugs.gentoo.org/show_bug.cgi?id=555776 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-server/Manifest2
-rw-r--r--x11-base/xorg-server/xorg-server-1.12.4-r6.ebuild226
-rw-r--r--x11-base/xorg-server/xorg-server-1.15.2-r3.ebuild235
-rw-r--r--x11-base/xorg-server/xorg-server-1.16.4-r1.ebuild231
-rw-r--r--x11-base/xorg-server/xorg-server-1.16.4-r2.ebuild233
-rw-r--r--x11-base/xorg-server/xorg-server-1.16.4-r3.ebuild261
-rw-r--r--x11-base/xorg-server/xorg-server-1.16.4-r4.ebuild236
-rw-r--r--x11-base/xorg-server/xorg-server-1.17.1-r1.ebuild244
-rw-r--r--x11-base/xorg-server/xorg-server-1.17.1.ebuild242
-rw-r--r--x11-base/xorg-server/xorg-server-1.17.2-r1.ebuild245
-rw-r--r--x11-base/xorg-server/xorg-server-1.17.2-r2.ebuild246
-rw-r--r--x11-base/xorg-server/xorg-server-1.17.2.ebuild244
12 files changed, 0 insertions, 2645 deletions
diff --git a/x11-base/xorg-server/Manifest b/x11-base/xorg-server/Manifest
index 2363cbf1873..f26dfacaf8c 100644
--- a/x11-base/xorg-server/Manifest
+++ b/x11-base/xorg-server/Manifest
@@ -3,6 +3,4 @@ DIST xorg-server-1.12.4.tar.bz2 5444761 SHA256 8ac07c35306ba3fb3c0972722dd4e9193
DIST xorg-server-1.15.2.tar.bz2 5551426 SHA256 3c0585607c654ded836da43a45a75492fc13454ff4149704fb08dac39f051163 SHA512 5fcbf0012af309f80e1db206e05d7861796146d765cd17f3963fde6da7f43f0e57d63dbbdbf2c554612a557aa4dee623ef62f7ca7d007834aafd7a46ca7bb1d6 WHIRLPOOL 22cdbad68462f9bac32b13be958df496411ca72fe47435ec7e3ebb470b121ba4b4a0e023913f31a92113c5a56bc4be660dfec5086bc1fb72a617d2cdeaa8adf1
DIST xorg-server-1.16-cve-2014-8091..8103.patches.tar.xz 27892 SHA256 47d8c9bb79c829389e7599aef1110d43afbc5bf744dbcf73d8f3cf01796d287a SHA512 f8b55c009166883b3e6ec2c8c7a2ff4ed61df6970afcc4f0efb9efa36741af194456a368d4b1c7ba9345ef973fb139a48eb50cb5a7ebc144b43749b9ffdb1f7b WHIRLPOOL 2f8b26c018f4ad4cf780ed7dcb0b844de64e7a612adc30c622d1956dfcee710086ffcc837ff0a64cdcc14d47720d82d8797374488bf0b52d77ca63adf6806885
DIST xorg-server-1.16.4.tar.bz2 5817330 SHA256 abb6e1cc9213a9915a121f48576ff6739a0b8cdb3d32796f9a7743c9a6efc871 SHA512 f756fca65535aa921a85d8d8eb36ea2ba5b7af90a46d640b0ca76259a9abd9d323885087e11156528d95240937c70373045001ae20266a1b9e89909f007e9e74 WHIRLPOOL 63980a3e2b57d2860998344f21a6524598b3dc135c277e5a868e34b57ab5060681ae7137358b3ba8b9ca5fd622a91aeb06bd0ac9e3e5ce1f4dc55df2b2dc0e33
-DIST xorg-server-1.17.1.tar.bz2 5852385 SHA256 2bf8e9f6f0a710dec1d2472467bff1f4e247cb6dcd76eb469aafdc8a2d7db2ab SHA512 195a0e0a6bd9c7655e62dd40dfbd7dea77d10f1143d4fd6154e8bdbb463d3729f81ecd1e379d66f68e828d4f4583782c15ce260de24444802076844aec552c4f WHIRLPOOL a8a78b0bfa6137941e3434f083319a827f0332fd9c190922bb0a33381e86173868d236c96a89ee3049400f37521fe052838416f009713f004227f05b8717d776
-DIST xorg-server-1.17.2.tar.bz2 5767983 SHA256 f61120612728f2c5034671d0ca3e2273438c60aba93b3dda4a8aa40e6a257993 SHA512 7e7b7620890cc8db696695758fa22fa879f9d3c33946663611ec0b37f02116e9c6f08779f9eece59907b430d3df93f0c0548939683ea156b3c4cbe02571b7551 WHIRLPOOL bfa04d9a6fba776138ec239183bd9f7badd73da520f1c4c62f7bf00bc264431959cd73ba145b5698429a6d5f3ae71d8dc07ab3f9442f365fae94ba2a98d69b96
DIST xorg-server-1.17.4.tar.bz2 5791384 SHA256 0c4b45c116a812a996eb432d8508cf26c2ec8c3916ff2a50781796882f8d6457 SHA512 4b8377b86ca88f27dcf59db2996b2ee620ce6f181a37dc47600365db588d48f2f3ca66a3149e7c856e686e5783b1cccb2ba0827aa7413299163dfca869f4d376 WHIRLPOOL c5baa1b01e57eac9e18bd1890c0a7e2246836524645057d5e05a1a19225d863645616aafaadbf9d083ffb672d47ea1934ad8323d813533e9519f0d92f9a1c6ab
diff --git a/x11-base/xorg-server/xorg-server-1.12.4-r6.ebuild b/x11-base/xorg-server/xorg-server-1.12.4-r6.ebuild
deleted file mode 100644
index 1f04d68a5e8..00000000000
--- a/x11-base/xorg-server/xorg-server-1.12.4-r6.ebuild
+++ /dev/null
@@ -1,226 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-XORG_DOC=doc
-inherit xorg-2 multilib versionator flag-o-matic
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-
-SRC_URI="${SRC_URI} mirror://gentoo/${PN}-1.12-cve-2014-8091..8103.patches.tar.xz"
-
-IUSE_SERVERS="dmx kdrive xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} ipv6 minimal nptl selinux tslib +udev"
-
-RDEPEND=">=app-eselect/eselect-opengl-1.3.0
- dev-libs/openssl
- media-libs/freetype
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont-1.4.2
- <x11-libs/libXfont-1.5.0
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/pixman-0.21.8
- >=x11-libs/xtrans-1.2.2
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- dmx? (
- x11-libs/libXt
- >=x11-libs/libdmx-1.0.99.1
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXaw-1.0.4
- >=x11-libs/libXext-1.0.99.4
- >=x11-libs/libXfixes-5.0
- >=x11-libs/libXi-1.2.99.1
- >=x11-libs/libXmu-1.0.3
- x11-libs/libXrender
- >=x11-libs/libXres-1.0.3
- >=x11-libs/libXtst-1.0.99.2
- )
- kdrive? (
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-10.3.7-r2[nptl=]
- )
- tslib? ( >=x11-libs/tslib-1.0 )
- udev? ( >=virtual/udev-150 )
- >=x11-apps/xinit-1.3
- selinux? ( sec-policy/selinux-xserver )"
-
-DEPEND="${RDEPEND}
- sys-devel/flex
- >=x11-proto/bigreqsproto-1.1.0
- >=x11-proto/compositeproto-0.4
- >=x11-proto/damageproto-1.1
- >=x11-proto/fixesproto-5.0
- >=x11-proto/fontsproto-2.0.2
- <x11-proto/fontsproto-2.1.3
- >=x11-proto/glproto-1.4.17-r1
- >=x11-proto/inputproto-2.1.99.3
- >=x11-proto/kbproto-1.0.3
- >=x11-proto/randrproto-1.2.99.3
- >=x11-proto/recordproto-1.13.99.1
- >=x11-proto/renderproto-0.11
- >=x11-proto/resourceproto-1.0.2
- >=x11-proto/scrnsaverproto-1.1
- >=x11-proto/trapproto-3.4.3
- >=x11-proto/videoproto-2.2.2
- >=x11-proto/xcmiscproto-1.2.0
- >=x11-proto/xextproto-7.1.99
- >=x11-proto/xf86dgaproto-2.0.99.1
- >=x11-proto/xf86rushproto-1.1.2
- >=x11-proto/xf86vidmodeproto-2.2.99.1
- >=x11-proto/xineramaproto-1.1.3
- >=x11-proto/xproto-7.0.22
- dmx? (
- >=x11-proto/dmxproto-2.2.99.1
- doc? (
- || (
- www-client/links
- www-client/lynx
- www-client/w3m
- )
- )
- )
- !minimal? (
- >=x11-proto/xf86driproto-2.1.0
- >=x11-proto/dri2proto-2.6
- >=x11-libs/libdrm-2.4.20
- )"
-
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )"
-
-# Security patches taken from Debian from their 1.12 package
-UPSTREAMED_PATCHES=(
- "${WORKDIR}"/patches/${PN}-1.12-cve-2014-8091..8103.patch
-)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.12-disable-acpi.patch
- "${FILESDIR}"/${PN}-1.12-cve-2013-1940.patch
- "${FILESDIR}"/${PN}-1.12-cve-2013-4396.patch
- "${FILESDIR}"/${PN}-1.17-cve-2015-0255-0.patch
- "${FILESDIR}"/${PN}-1.17-cve-2015-0255-1.patch
- "${FILESDIR}"/${PN}-1.12-cve-2015-3418.patch
-)
-
-pkg_pretend() {
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" && $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 wont work for xorg-server."
-}
-
-src_configure() {
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
- # --enable-install-setuid needed because sparcs default off
- # NOTE: fop is used for doc generating ; and i have no idea if gentoo
- # package it somewhere
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- $(use_enable dmx)
- $(use_enable kdrive)
- $(use_enable kdrive kdrive-kbd)
- $(use_enable kdrive kdrive-mouse)
- $(use_enable kdrive kdrive-evdev)
- $(use_enable tslib)
- $(use_enable !minimal record)
- $(use_enable !minimal xfree86-utils)
- $(use_enable !minimal install-libxf86config)
- $(use_enable !minimal dri)
- $(use_enable !minimal dri2)
- $(use_enable !minimal glx)
- $(use_enable xnest)
- $(use_enable xorg)
- $(use_enable xvfb)
- $(use_enable nptl glx-tls)
- $(use_enable udev config-udev)
- $(use_with doc doxygen)
- $(use_with doc xmlto)
- --sysconfdir=/etc/X11
- --localstatedir=/var
- --enable-install-setuid
- --with-fontrootdir=/usr/share/fonts
- --with-xkb-output=/var/lib/xkb
- --disable-config-hal
- --without-dtrace
- --without-fop
- --with-os-vendor=Gentoo
- )
-
- xorg-2_src_configure
-}
-
-src_install() {
- xorg-2_src_install
-
- server_based_install
-
- if ! use minimal && use xorg; then
- # Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
- fi
-
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-9 xdm
- newconfd "${FILESDIR}"/xdm.confd-4 xdm
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postinst() {
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- eselect opengl set xorg-x11 --use-old
-
- if [[ ${PV} != 9999 && $(get_version_component_range 2 ${REPLACING_VERSIONS}) != $(get_version_component_range 2 ${PV}) ]]; then
- ewarn "You must rebuild all drivers if upgrading from <xorg-server-$(get_version_component_range 1-2)"
- ewarn "because the ABI changed. If you cannot start X because"
- ewarn "of module version mismatch errors, this is your problem."
-
- echo
- ewarn "You can generate a list of all installed packages in the x11-drivers"
- ewarn "category using this command:"
- ewarn " emerge portage-utils; qlist -I -C x11-drivers/"
- ewarn "or using sets from portage-2.2:"
- ewarn " emerge @x11-module-rebuild"
- fi
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${ROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${ROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}
-
-server_based_install() {
- if ! use xorg; then
- rm "${D}"/usr/share/man/man1/Xserver.1x \
- "${D}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${D}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${D}"/usr/share/man/man1/Xserver.1x
- fi
-}
diff --git a/x11-base/xorg-server/xorg-server-1.15.2-r3.ebuild b/x11-base/xorg-server/xorg-server-1.15.2-r3.ebuild
deleted file mode 100644
index 0d51022230f..00000000000
--- a/x11-base/xorg-server/xorg-server-1.15.2-r3.ebuild
+++ /dev/null
@@ -1,235 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-XORG_EAUTORECONF=yes
-XORG_DOC=doc
-inherit xorg-2 multilib versionator flag-o-matic
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-
-SRC_URI="${SRC_URI} mirror://gentoo/${PN}-1.16-cve-2014-8091..8103.patches.tar.xz"
-
-IUSE_SERVERS="dmx kdrive xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} ipv6 minimal nptl selinux +suid tslib +udev unwind"
-
-CDEPEND=">=app-eselect/eselect-opengl-1.3.0
- dev-libs/openssl
- media-libs/freetype
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.20
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont-1.4.2
- <x11-libs/libXfont-1.5.0
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/libxshmfence-1.1
- >=x11-libs/pixman-0.27.2
- >=x11-libs/xtrans-1.3.2
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- dmx? (
- x11-libs/libXt
- >=x11-libs/libdmx-1.0.99.1
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXaw-1.0.4
- >=x11-libs/libXext-1.0.99.4
- >=x11-libs/libXfixes-5.0
- >=x11-libs/libXi-1.2.99.1
- >=x11-libs/libXmu-1.0.3
- x11-libs/libXrender
- >=x11-libs/libXres-1.0.3
- >=x11-libs/libXtst-1.0.99.2
- )
- kdrive? (
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-10.3.7-r2[nptl=]
- )
- tslib? ( >=x11-libs/tslib-1.0 )
- udev? ( >=virtual/udev-150 )
- unwind? ( sys-libs/libunwind )
- >=x11-apps/xinit-1.3"
-
-DEPEND="${CDEPEND}
- sys-devel/flex
- >=x11-proto/bigreqsproto-1.1.0
- >=x11-proto/compositeproto-0.4
- >=x11-proto/damageproto-1.1
- >=x11-proto/fixesproto-5.0
- >=x11-proto/fontsproto-2.0.2
- <x11-proto/fontsproto-2.1.3
- >=x11-proto/glproto-1.4.17-r1
- >=x11-proto/inputproto-2.2.99.1
- >=x11-proto/kbproto-1.0.3
- >=x11-proto/randrproto-1.4.0
- >=x11-proto/recordproto-1.13.99.1
- >=x11-proto/renderproto-0.11
- >=x11-proto/resourceproto-1.2.0
- >=x11-proto/scrnsaverproto-1.1
- >=x11-proto/trapproto-3.4.3
- >=x11-proto/videoproto-2.2.2
- >=x11-proto/xcmiscproto-1.2.0
- >=x11-proto/xextproto-7.2.99.901
- >=x11-proto/xf86dgaproto-2.0.99.1
- >=x11-proto/xf86rushproto-1.1.2
- >=x11-proto/xf86vidmodeproto-2.2.99.1
- >=x11-proto/xineramaproto-1.1.3
- >=x11-proto/xproto-7.0.22
- >=x11-proto/presentproto-1.0
- >=x11-proto/dri3proto-1.0
- dmx? (
- >=x11-proto/dmxproto-2.2.99.1
- doc? (
- || (
- www-client/links
- www-client/lynx
- www-client/w3m
- )
- )
- )
- !minimal? (
- >=x11-proto/xf86driproto-2.1.0
- >=x11-proto/dri2proto-2.8
- )"
-
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-xserver )
-"
-
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )"
-
-pkg_pretend() {
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" && $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
-}
-
-src_prepare() {
- UPSTREAMED_PATCHES=(
- "${WORKDIR}"/patches/*.patch
- )
- PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.12-ia64-fix_inx_outx.patch
- "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
- "${FILESDIR}"/${PN}-1.17-cve-2015-0255-0.patch
- "${FILESDIR}"/${PN}-1.17-cve-2015-0255-1.patch
-
- )
- xorg-2_src_prepare
-}
-
-src_configure() {
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
- # NOTE: fop is used for doc generating ; and i have no idea if gentoo
- # package it somewhere
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- $(use_enable dmx)
- $(use_enable kdrive)
- $(use_enable kdrive kdrive-kbd)
- $(use_enable kdrive kdrive-mouse)
- $(use_enable kdrive kdrive-evdev)
- $(use_enable suid install-setuid)
- $(use_enable tslib)
- $(use_enable unwind libunwind)
- $(use_enable !minimal record)
- $(use_enable !minimal xfree86-utils)
- $(use_enable !minimal install-libxf86config)
- $(use_enable !minimal dri)
- $(use_enable !minimal dri2)
- $(use_enable !minimal glx)
- $(use_enable xnest)
- $(use_enable xorg)
- $(use_enable xvfb)
- $(use_enable nptl glx-tls)
- $(use_enable udev config-udev)
- $(use_with doc doxygen)
- $(use_with doc xmlto)
- --enable-libdrm
- --sysconfdir="${EPREFIX}"/etc/X11
- --localstatedir="${EPREFIX}"/var
- --with-fontrootdir="${EPREFIX}"/usr/share/fonts
- --with-xkb-output="${EPREFIX}"/var/lib/xkb
- --disable-config-hal
- --disable-linux-acpi
- --without-dtrace
- --without-fop
- --with-os-vendor=Gentoo
- --with-sha1=libcrypto
- )
-
- xorg-2_src_configure
-}
-
-src_install() {
- xorg-2_src_install
-
- server_based_install
-
- if ! use minimal && use xorg; then
- # Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
- fi
-
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-11 xdm
- newconfd "${FILESDIR}"/xdm.confd-4 xdm
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postinst() {
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- eselect opengl set xorg-x11 --use-old
-
- if [[ ${PV} != 9999 && $(get_version_component_range 2 ${REPLACING_VERSIONS}) != $(get_version_component_range 2 ${PV}) ]]; then
- ewarn "You must rebuild all drivers if upgrading from <xorg-server-$(get_version_component_range 1-2)"
- ewarn "because the ABI changed. If you cannot start X because"
- ewarn "of module version mismatch errors, this is your problem."
-
- echo
- ewarn "You can rebuild all installed packages in the x11-drivers"
- ewarn "category using this command:"
- ewarn " emerge @x11-module-rebuild"
- fi
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}
-
-server_based_install() {
- if ! use xorg; then
- rm "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x
- fi
-}
diff --git a/x11-base/xorg-server/xorg-server-1.16.4-r1.ebuild b/x11-base/xorg-server/xorg-server-1.16.4-r1.ebuild
deleted file mode 100644
index f05a7321201..00000000000
--- a/x11-base/xorg-server/xorg-server-1.16.4-r1.ebuild
+++ /dev/null
@@ -1,231 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-XORG_DOC=doc
-inherit xorg-2 multilib versionator flag-o-matic
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/1.16.1"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-
-IUSE_SERVERS="dmx kdrive xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} glamor ipv6 minimal nptl selinux +suid systemd tslib +udev unwind wayland"
-
-CDEPEND=">=app-eselect/eselect-opengl-1.3.0
- dev-libs/openssl
- media-libs/freetype
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.20
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont-1.4.2
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/libxshmfence-1.1
- >=x11-libs/pixman-0.27.2
- >=x11-libs/xtrans-1.3.3
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- dmx? (
- x11-libs/libXt
- >=x11-libs/libdmx-1.0.99.1
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXaw-1.0.4
- >=x11-libs/libXext-1.0.99.4
- >=x11-libs/libXfixes-5.0
- >=x11-libs/libXi-1.2.99.1
- >=x11-libs/libXmu-1.0.3
- x11-libs/libXrender
- >=x11-libs/libXres-1.0.3
- >=x11-libs/libXtst-1.0.99.2
- )
- glamor? (
- media-libs/libepoxy
- >=media-libs/mesa-10.3.4-r1[egl,gbm]
- !x11-libs/glamor
- )
- kdrive? (
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-10.3.4-r1[nptl=]
- )
- tslib? ( >=x11-libs/tslib-1.0 )
- udev? ( >=virtual/udev-150 )
- unwind? ( sys-libs/libunwind )
- wayland? (
- >=dev-libs/wayland-1.3.0
- media-libs/libepoxy
- )
- >=x11-apps/xinit-1.3
- systemd? (
- sys-apps/dbus
- sys-apps/systemd
- )"
-
-DEPEND="${CDEPEND}
- sys-devel/flex
- >=x11-proto/bigreqsproto-1.1.0
- >=x11-proto/compositeproto-0.4
- >=x11-proto/damageproto-1.1
- >=x11-proto/fixesproto-5.0
- >=x11-proto/fontsproto-2.1.3
- >=x11-proto/glproto-1.4.17-r1
- >=x11-proto/inputproto-2.2.99.1
- >=x11-proto/kbproto-1.0.3
- >=x11-proto/randrproto-1.4.0
- >=x11-proto/recordproto-1.13.99.1
- >=x11-proto/renderproto-0.11
- >=x11-proto/resourceproto-1.2.0
- >=x11-proto/scrnsaverproto-1.1
- >=x11-proto/trapproto-3.4.3
- >=x11-proto/videoproto-2.2.2
- >=x11-proto/xcmiscproto-1.2.0
- >=x11-proto/xextproto-7.2.99.901
- >=x11-proto/xf86dgaproto-2.0.99.1
- >=x11-proto/xf86rushproto-1.1.2
- >=x11-proto/xf86vidmodeproto-2.2.99.1
- >=x11-proto/xineramaproto-1.1.3
- >=x11-proto/xproto-7.0.26
- >=x11-proto/presentproto-1.0
- >=x11-proto/dri3proto-1.0
- dmx? (
- >=x11-proto/dmxproto-2.2.99.1
- doc? (
- || (
- www-client/links
- www-client/lynx
- www-client/w3m
- )
- )
- )
- !minimal? (
- >=x11-proto/xf86driproto-2.1.0
- >=x11-proto/dri2proto-2.8
- )"
-
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-xserver )
-"
-
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )"
-
-#UPSTREAMED_PATCHES=(
-# "${WORKDIR}/patches/"
-#)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.12-ia64-fix_inx_outx.patch
- "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
-)
-
-pkg_pretend() {
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" && $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
-}
-
-src_configure() {
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
- # NOTE: fop is used for doc generating ; and i have no idea if gentoo
- # package it somewhere
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- $(use_enable dmx)
- $(use_enable glamor)
- $(use_enable kdrive)
- $(use_enable kdrive kdrive-kbd)
- $(use_enable kdrive kdrive-mouse)
- $(use_enable kdrive kdrive-evdev)
- $(use_enable suid install-setuid)
- $(use_enable tslib)
- $(use_enable unwind libunwind)
- $(use_enable wayland xwayland)
- $(use_enable !minimal record)
- $(use_enable !minimal xfree86-utils)
- $(use_enable !minimal install-libxf86config)
- $(use_enable !minimal dri)
- $(use_enable !minimal dri2)
- $(use_enable !minimal glx)
- $(use_enable xnest)
- $(use_enable xorg)
- $(use_enable xvfb)
- $(use_enable nptl glx-tls)
- $(use_enable udev config-udev)
- $(use_with doc doxygen)
- $(use_with doc xmlto)
- $(use_with systemd systemd-daemon)
- $(use_enable systemd systemd-logind)
- --enable-libdrm
- --sysconfdir="${EPREFIX}"/etc/X11
- --localstatedir="${EPREFIX}"/var
- --with-fontrootdir="${EPREFIX}"/usr/share/fonts
- --with-xkb-output="${EPREFIX}"/var/lib/xkb
- --disable-config-hal
- --disable-linux-acpi
- --without-dtrace
- --without-fop
- --with-os-vendor=Gentoo
- --with-sha1=libcrypto
- )
-
- xorg-2_src_configure
-}
-
-src_install() {
- xorg-2_src_install
-
- server_based_install
-
- if ! use minimal && use xorg; then
- # Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
- fi
-
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-11 xdm
- newconfd "${FILESDIR}"/xdm.confd-4 xdm
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postinst() {
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- eselect opengl set xorg-x11 --use-old
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}
-
-server_based_install() {
- if ! use xorg; then
- rm "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x
- fi
-}
diff --git a/x11-base/xorg-server/xorg-server-1.16.4-r2.ebuild b/x11-base/xorg-server/xorg-server-1.16.4-r2.ebuild
deleted file mode 100644
index 166c3ff5eda..00000000000
--- a/x11-base/xorg-server/xorg-server-1.16.4-r2.ebuild
+++ /dev/null
@@ -1,233 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-XORG_DOC=doc
-inherit xorg-2 multilib versionator flag-o-matic
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/1.16.1"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-
-IUSE_SERVERS="dmx kdrive xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} glamor ipv6 minimal nptl selinux +suid systemd tslib +udev unwind wayland"
-
-CDEPEND=">=app-eselect/eselect-opengl-1.3.0
- dev-libs/openssl
- media-libs/freetype
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.20
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont-1.4.2
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/libxshmfence-1.1
- >=x11-libs/pixman-0.27.2
- >=x11-libs/xtrans-1.3.3
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- dmx? (
- x11-libs/libXt
- >=x11-libs/libdmx-1.0.99.1
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXaw-1.0.4
- >=x11-libs/libXext-1.0.99.4
- >=x11-libs/libXfixes-5.0
- >=x11-libs/libXi-1.2.99.1
- >=x11-libs/libXmu-1.0.3
- x11-libs/libXrender
- >=x11-libs/libXres-1.0.3
- >=x11-libs/libXtst-1.0.99.2
- )
- glamor? (
- media-libs/libepoxy
- >=media-libs/mesa-10.3.4-r1[egl,gbm]
- !x11-libs/glamor
- )
- kdrive? (
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-10.3.4-r1[nptl=]
- )
- tslib? ( >=x11-libs/tslib-1.0 )
- udev? ( >=virtual/udev-150 )
- unwind? ( sys-libs/libunwind )
- wayland? (
- >=dev-libs/wayland-1.3.0
- media-libs/libepoxy
- )
- >=x11-apps/xinit-1.3
- systemd? (
- sys-apps/dbus
- sys-apps/systemd
- )"
-
-DEPEND="${CDEPEND}
- sys-devel/flex
- >=x11-proto/bigreqsproto-1.1.0
- >=x11-proto/compositeproto-0.4
- >=x11-proto/damageproto-1.1
- >=x11-proto/fixesproto-5.0
- >=x11-proto/fontsproto-2.1.3
- >=x11-proto/glproto-1.4.17-r1
- >=x11-proto/inputproto-2.2.99.1
- >=x11-proto/kbproto-1.0.3
- >=x11-proto/randrproto-1.4.0
- >=x11-proto/recordproto-1.13.99.1
- >=x11-proto/renderproto-0.11
- >=x11-proto/resourceproto-1.2.0
- >=x11-proto/scrnsaverproto-1.1
- >=x11-proto/trapproto-3.4.3
- >=x11-proto/videoproto-2.2.2
- >=x11-proto/xcmiscproto-1.2.0
- >=x11-proto/xextproto-7.2.99.901
- >=x11-proto/xf86dgaproto-2.0.99.1
- >=x11-proto/xf86rushproto-1.1.2
- >=x11-proto/xf86vidmodeproto-2.2.99.1
- >=x11-proto/xineramaproto-1.1.3
- >=x11-proto/xproto-7.0.26
- >=x11-proto/presentproto-1.0
- >=x11-proto/dri3proto-1.0
- dmx? (
- >=x11-proto/dmxproto-2.2.99.1
- doc? (
- || (
- www-client/links
- www-client/lynx
- www-client/w3m
- )
- )
- )
- !minimal? (
- >=x11-proto/xf86driproto-2.1.0
- >=x11-proto/dri2proto-2.8
- )"
-
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-xserver )
-"
-
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )"
-
-#UPSTREAMED_PATCHES=(
-# "${WORKDIR}/patches/"
-#)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.12-ia64-fix_inx_outx.patch
- "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
- # needed for new eselect-opengl, bug #541232
- "${FILESDIR}"/${PN}-1.17-support-multiple-Files-sections.patch
-)
-
-pkg_pretend() {
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" && $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
-}
-
-src_configure() {
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
- # NOTE: fop is used for doc generating ; and i have no idea if gentoo
- # package it somewhere
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- $(use_enable dmx)
- $(use_enable glamor)
- $(use_enable kdrive)
- $(use_enable kdrive kdrive-kbd)
- $(use_enable kdrive kdrive-mouse)
- $(use_enable kdrive kdrive-evdev)
- $(use_enable suid install-setuid)
- $(use_enable tslib)
- $(use_enable unwind libunwind)
- $(use_enable wayland xwayland)
- $(use_enable !minimal record)
- $(use_enable !minimal xfree86-utils)
- $(use_enable !minimal install-libxf86config)
- $(use_enable !minimal dri)
- $(use_enable !minimal dri2)
- $(use_enable !minimal glx)
- $(use_enable xnest)
- $(use_enable xorg)
- $(use_enable xvfb)
- $(use_enable nptl glx-tls)
- $(use_enable udev config-udev)
- $(use_with doc doxygen)
- $(use_with doc xmlto)
- $(use_with systemd systemd-daemon)
- $(use_enable systemd systemd-logind)
- --enable-libdrm
- --sysconfdir="${EPREFIX}"/etc/X11
- --localstatedir="${EPREFIX}"/var
- --with-fontrootdir="${EPREFIX}"/usr/share/fonts
- --with-xkb-output="${EPREFIX}"/var/lib/xkb
- --disable-config-hal
- --disable-linux-acpi
- --without-dtrace
- --without-fop
- --with-os-vendor=Gentoo
- --with-sha1=libcrypto
- )
-
- xorg-2_src_configure
-}
-
-src_install() {
- xorg-2_src_install
-
- server_based_install
-
- if ! use minimal && use xorg; then
- # Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
- fi
-
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-11 xdm
- newconfd "${FILESDIR}"/xdm.confd-4 xdm
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postinst() {
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- eselect opengl set xorg-x11 --use-old
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}
-
-server_based_install() {
- if ! use xorg; then
- rm "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x
- fi
-}
diff --git a/x11-base/xorg-server/xorg-server-1.16.4-r3.ebuild b/x11-base/xorg-server/xorg-server-1.16.4-r3.ebuild
deleted file mode 100644
index 58c70e0256e..00000000000
--- a/x11-base/xorg-server/xorg-server-1.16.4-r3.ebuild
+++ /dev/null
@@ -1,261 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-XORG_DOC=doc
-inherit xorg-2 multilib versionator flag-o-matic
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/1.16.1"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-
-IUSE_SERVERS="dmx kdrive xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} glamor ipv6 minimal nptl selinux +suid systemd tslib +udev unwind wayland"
-
-CDEPEND=">=app-eselect/eselect-opengl-1.0.8
- !>=app-eselect/eselect-opengl-1.3.0
- dev-libs/openssl
- media-libs/freetype
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.20
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont-1.4.2
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/libxshmfence-1.1
- >=x11-libs/pixman-0.27.2
- >=x11-libs/xtrans-1.3.3
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- dmx? (
- x11-libs/libXt
- >=x11-libs/libdmx-1.0.99.1
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXaw-1.0.4
- >=x11-libs/libXext-1.0.99.4
- >=x11-libs/libXfixes-5.0
- >=x11-libs/libXi-1.2.99.1
- >=x11-libs/libXmu-1.0.3
- x11-libs/libXrender
- >=x11-libs/libXres-1.0.3
- >=x11-libs/libXtst-1.0.99.2
- )
- glamor? (
- media-libs/libepoxy
- media-libs/mesa[egl,gbm]
- !x11-libs/glamor
- )
- kdrive? (
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-9.2.0[nptl=]
- )
- tslib? ( >=x11-libs/tslib-1.0 )
- udev? ( >=virtual/udev-150 )
- unwind? ( sys-libs/libunwind )
- wayland? (
- >=dev-libs/wayland-1.3.0
- media-libs/libepoxy
- )
- >=x11-apps/xinit-1.3
- systemd? (
- sys-apps/dbus
- sys-apps/systemd
- )"
-
-DEPEND="${CDEPEND}
- sys-devel/flex
- >=x11-proto/bigreqsproto-1.1.0
- >=x11-proto/compositeproto-0.4
- >=x11-proto/damageproto-1.1
- >=x11-proto/fixesproto-5.0
- >=x11-proto/fontsproto-2.1.3
- >=x11-proto/glproto-1.4.17
- >=x11-proto/inputproto-2.2.99.1
- >=x11-proto/kbproto-1.0.3
- >=x11-proto/randrproto-1.4.0
- >=x11-proto/recordproto-1.13.99.1
- >=x11-proto/renderproto-0.11
- >=x11-proto/resourceproto-1.2.0
- >=x11-proto/scrnsaverproto-1.1
- >=x11-proto/trapproto-3.4.3
- >=x11-proto/videoproto-2.2.2
- >=x11-proto/xcmiscproto-1.2.0
- >=x11-proto/xextproto-7.2.99.901
- >=x11-proto/xf86dgaproto-2.0.99.1
- >=x11-proto/xf86rushproto-1.1.2
- >=x11-proto/xf86vidmodeproto-2.2.99.1
- >=x11-proto/xineramaproto-1.1.3
- >=x11-proto/xproto-7.0.26
- >=x11-proto/presentproto-1.0
- >=x11-proto/dri3proto-1.0
- dmx? (
- >=x11-proto/dmxproto-2.2.99.1
- doc? (
- || (
- www-client/links
- www-client/lynx
- www-client/w3m
- )
- )
- )
- !minimal? (
- >=x11-proto/xf86driproto-2.1.0
- >=x11-proto/dri2proto-2.8
- )"
-
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-xserver )
-"
-
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )"
-
-#UPSTREAMED_PATCHES=(
-# "${WORKDIR}/patches/"
-#)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.12-ia64-fix_inx_outx.patch
- "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
- "${FILESDIR}"/${PN}-1.17-cve-2015-3164-1.patch
- "${FILESDIR}"/${PN}-1.17-cve-2015-3164-2.patch
- "${FILESDIR}"/${PN}-1.17-cve-2015-3164-3.patch
-)
-
-pkg_pretend() {
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" && $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
-}
-
-src_configure() {
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
- # NOTE: fop is used for doc generating ; and i have no idea if gentoo
- # package it somewhere
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- $(use_enable dmx)
- $(use_enable glamor)
- $(use_enable kdrive)
- $(use_enable kdrive kdrive-kbd)
- $(use_enable kdrive kdrive-mouse)
- $(use_enable kdrive kdrive-evdev)
- $(use_enable suid install-setuid)
- $(use_enable tslib)
- $(use_enable unwind libunwind)
- $(use_enable wayland xwayland)
- $(use_enable !minimal record)
- $(use_enable !minimal xfree86-utils)
- $(use_enable !minimal install-libxf86config)
- $(use_enable !minimal dri)
- $(use_enable !minimal dri2)
- $(use_enable !minimal glx)
- $(use_enable xnest)
- $(use_enable xorg)
- $(use_enable xvfb)
- $(use_enable nptl glx-tls)
- $(use_enable udev config-udev)
- $(use_with doc doxygen)
- $(use_with doc xmlto)
- $(use_with systemd systemd-daemon)
- $(use_enable systemd systemd-logind)
- --enable-libdrm
- --sysconfdir="${EPREFIX}"/etc/X11
- --localstatedir="${EPREFIX}"/var
- --with-fontrootdir="${EPREFIX}"/usr/share/fonts
- --with-xkb-output="${EPREFIX}"/var/lib/xkb
- --disable-config-hal
- --disable-linux-acpi
- --without-dtrace
- --without-fop
- --with-os-vendor=Gentoo
- --with-sha1=libcrypto
- )
-
- # Xorg-server requires includes from OS mesa which are not visible for
- # users of binary drivers.
- mkdir -p "${T}/mesa-symlinks/GL"
- for i in gl glx glxmd glxproto glxtokens; do
- ln -s "${EROOT}usr/$(get_libdir)/opengl/xorg-x11/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
- done
- for i in glext glxext; do
- ln -s "${EROOT}usr/$(get_libdir)/opengl/global/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
- done
- append-cppflags "-I${T}/mesa-symlinks"
-
- xorg-2_src_configure
-}
-
-src_install() {
- xorg-2_src_install
-
- dynamic_libgl_install
-
- server_based_install
-
- if ! use minimal && use xorg; then
- # Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
- fi
-
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-11 xdm
- newconfd "${FILESDIR}"/xdm.confd-4 xdm
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postinst() {
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- eselect opengl set xorg-x11 --use-old
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}
-
-dynamic_libgl_install() {
- # next section is to setup the dynamic libGL stuff
- ebegin "Moving GL files for dynamic switching"
- dodir /usr/$(get_libdir)/opengl/xorg-x11/extensions
- local x=""
- for x in "${ED}"/usr/$(get_libdir)/xorg/modules/extensions/lib{glx,dri,dri2}*; do
- if [ -f ${x} -o -L ${x} ]; then
- mv -f ${x} "${ED}"/usr/$(get_libdir)/opengl/xorg-x11/extensions
- fi
- done
- eend 0
-}
-
-server_based_install() {
- if ! use xorg; then
- rm "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x
- fi
-}
diff --git a/x11-base/xorg-server/xorg-server-1.16.4-r4.ebuild b/x11-base/xorg-server/xorg-server-1.16.4-r4.ebuild
deleted file mode 100644
index 1ec0222efd2..00000000000
--- a/x11-base/xorg-server/xorg-server-1.16.4-r4.ebuild
+++ /dev/null
@@ -1,236 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-XORG_DOC=doc
-inherit xorg-2 multilib versionator flag-o-matic
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/1.16.1"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-
-IUSE_SERVERS="dmx kdrive xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} glamor ipv6 minimal nptl selinux +suid systemd tslib +udev unwind wayland"
-
-CDEPEND=">=app-eselect/eselect-opengl-1.3.0
- dev-libs/openssl
- media-libs/freetype
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.20
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont-1.4.2
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/libxshmfence-1.1
- >=x11-libs/pixman-0.27.2
- >=x11-libs/xtrans-1.3.3
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- dmx? (
- x11-libs/libXt
- >=x11-libs/libdmx-1.0.99.1
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXaw-1.0.4
- >=x11-libs/libXext-1.0.99.4
- >=x11-libs/libXfixes-5.0
- >=x11-libs/libXi-1.2.99.1
- >=x11-libs/libXmu-1.0.3
- x11-libs/libXrender
- >=x11-libs/libXres-1.0.3
- >=x11-libs/libXtst-1.0.99.2
- )
- glamor? (
- media-libs/libepoxy
- >=media-libs/mesa-10.3.4-r1[egl,gbm]
- !x11-libs/glamor
- )
- kdrive? (
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-10.3.4-r1[nptl=]
- )
- tslib? ( >=x11-libs/tslib-1.0 )
- udev? ( >=virtual/udev-150 )
- unwind? ( sys-libs/libunwind )
- wayland? (
- >=dev-libs/wayland-1.3.0
- media-libs/libepoxy
- )
- >=x11-apps/xinit-1.3
- systemd? (
- sys-apps/dbus
- sys-apps/systemd
- )"
-
-DEPEND="${CDEPEND}
- sys-devel/flex
- >=x11-proto/bigreqsproto-1.1.0
- >=x11-proto/compositeproto-0.4
- >=x11-proto/damageproto-1.1
- >=x11-proto/fixesproto-5.0
- >=x11-proto/fontsproto-2.1.3
- >=x11-proto/glproto-1.4.17-r1
- >=x11-proto/inputproto-2.2.99.1
- >=x11-proto/kbproto-1.0.3
- >=x11-proto/randrproto-1.4.0
- >=x11-proto/recordproto-1.13.99.1
- >=x11-proto/renderproto-0.11
- >=x11-proto/resourceproto-1.2.0
- >=x11-proto/scrnsaverproto-1.1
- >=x11-proto/trapproto-3.4.3
- >=x11-proto/videoproto-2.2.2
- >=x11-proto/xcmiscproto-1.2.0
- >=x11-proto/xextproto-7.2.99.901
- >=x11-proto/xf86dgaproto-2.0.99.1
- >=x11-proto/xf86rushproto-1.1.2
- >=x11-proto/xf86vidmodeproto-2.2.99.1
- >=x11-proto/xineramaproto-1.1.3
- >=x11-proto/xproto-7.0.26
- >=x11-proto/presentproto-1.0
- >=x11-proto/dri3proto-1.0
- dmx? (
- >=x11-proto/dmxproto-2.2.99.1
- doc? (
- || (
- www-client/links
- www-client/lynx
- www-client/w3m
- )
- )
- )
- !minimal? (
- >=x11-proto/xf86driproto-2.1.0
- >=x11-proto/dri2proto-2.8
- )"
-
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-xserver )
-"
-
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )"
-
-#UPSTREAMED_PATCHES=(
-# "${WORKDIR}/patches/"
-#)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.12-ia64-fix_inx_outx.patch
- "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
- # needed for new eselect-opengl, bug #541232
- "${FILESDIR}"/${PN}-1.17-support-multiple-Files-sections.patch
- "${FILESDIR}"/${PN}-1.17-cve-2015-3164-1.patch
- "${FILESDIR}"/${PN}-1.17-cve-2015-3164-2.patch
- "${FILESDIR}"/${PN}-1.17-cve-2015-3164-3.patch
-)
-
-pkg_pretend() {
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" && $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
-}
-
-src_configure() {
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
- # NOTE: fop is used for doc generating ; and i have no idea if gentoo
- # package it somewhere
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- $(use_enable dmx)
- $(use_enable glamor)
- $(use_enable kdrive)
- $(use_enable kdrive kdrive-kbd)
- $(use_enable kdrive kdrive-mouse)
- $(use_enable kdrive kdrive-evdev)
- $(use_enable suid install-setuid)
- $(use_enable tslib)
- $(use_enable unwind libunwind)
- $(use_enable wayland xwayland)
- $(use_enable !minimal record)
- $(use_enable !minimal xfree86-utils)
- $(use_enable !minimal install-libxf86config)
- $(use_enable !minimal dri)
- $(use_enable !minimal dri2)
- $(use_enable !minimal glx)
- $(use_enable xnest)
- $(use_enable xorg)
- $(use_enable xvfb)
- $(use_enable nptl glx-tls)
- $(use_enable udev config-udev)
- $(use_with doc doxygen)
- $(use_with doc xmlto)
- $(use_with systemd systemd-daemon)
- $(use_enable systemd systemd-logind)
- --enable-libdrm
- --sysconfdir="${EPREFIX}"/etc/X11
- --localstatedir="${EPREFIX}"/var
- --with-fontrootdir="${EPREFIX}"/usr/share/fonts
- --with-xkb-output="${EPREFIX}"/var/lib/xkb
- --disable-config-hal
- --disable-linux-acpi
- --without-dtrace
- --without-fop
- --with-os-vendor=Gentoo
- --with-sha1=libcrypto
- )
-
- xorg-2_src_configure
-}
-
-src_install() {
- xorg-2_src_install
-
- server_based_install
-
- if ! use minimal && use xorg; then
- # Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
- fi
-
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-11 xdm
- newconfd "${FILESDIR}"/xdm.confd-4 xdm
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postinst() {
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- eselect opengl set xorg-x11 --use-old
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}
-
-server_based_install() {
- if ! use xorg; then
- rm "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x
- fi
-}
diff --git a/x11-base/xorg-server/xorg-server-1.17.1-r1.ebuild b/x11-base/xorg-server/xorg-server-1.17.1-r1.ebuild
deleted file mode 100644
index 8f4c90e6799..00000000000
--- a/x11-base/xorg-server/xorg-server-1.17.1-r1.ebuild
+++ /dev/null
@@ -1,244 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-XORG_DOC=doc
-inherit xorg-2 multilib versionator flag-o-matic
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-
-IUSE_SERVERS="dmx kdrive xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} glamor ipv6 minimal nptl selinux +suid systemd tslib +udev unwind wayland"
-
-CDEPEND=">=app-eselect/eselect-opengl-1.3.0
- dev-libs/openssl
- media-libs/freetype
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.46
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont-1.4.2
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/libxshmfence-1.1
- >=x11-libs/pixman-0.27.2
- >=x11-libs/xtrans-1.3.5
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- dmx? (
- x11-libs/libXt
- >=x11-libs/libdmx-1.0.99.1
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXaw-1.0.4
- >=x11-libs/libXext-1.0.99.4
- >=x11-libs/libXfixes-5.0
- >=x11-libs/libXi-1.2.99.1
- >=x11-libs/libXmu-1.0.3
- x11-libs/libXrender
- >=x11-libs/libXres-1.0.3
- >=x11-libs/libXtst-1.0.99.2
- )
- glamor? (
- media-libs/libepoxy
- >=media-libs/mesa-10.3.4-r1[egl,gbm]
- !x11-libs/glamor
- )
- kdrive? (
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- )
- xephyr? (
- x11-libs/libxcb
- x11-libs/xcb-util
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-10.3.4-r1[nptl=]
- )
- tslib? ( >=x11-libs/tslib-1.0 )
- udev? ( >=virtual/udev-150 )
- unwind? ( sys-libs/libunwind )
- wayland? (
- >=dev-libs/wayland-1.3.0
- media-libs/libepoxy
- )
- >=x11-apps/xinit-1.3.3-r1
- systemd? (
- sys-apps/dbus
- sys-apps/systemd
- )"
-
-DEPEND="${CDEPEND}
- sys-devel/flex
- >=x11-proto/bigreqsproto-1.1.0
- >=x11-proto/compositeproto-0.4
- >=x11-proto/damageproto-1.1
- >=x11-proto/fixesproto-5.0
- >=x11-proto/fontsproto-2.1.3
- >=x11-proto/glproto-1.4.17-r1
- >=x11-proto/inputproto-2.2.99.1
- >=x11-proto/kbproto-1.0.3
- >=x11-proto/randrproto-1.4.0
- >=x11-proto/recordproto-1.13.99.1
- >=x11-proto/renderproto-0.11
- >=x11-proto/resourceproto-1.2.0
- >=x11-proto/scrnsaverproto-1.1
- >=x11-proto/trapproto-3.4.3
- >=x11-proto/videoproto-2.2.2
- >=x11-proto/xcmiscproto-1.2.0
- >=x11-proto/xextproto-7.2.99.901
- >=x11-proto/xf86dgaproto-2.0.99.1
- >=x11-proto/xf86rushproto-1.1.2
- >=x11-proto/xf86vidmodeproto-2.2.99.1
- >=x11-proto/xineramaproto-1.1.3
- >=x11-proto/xproto-7.0.26
- >=x11-proto/presentproto-1.0
- >=x11-proto/dri3proto-1.0
- dmx? (
- >=x11-proto/dmxproto-2.2.99.1
- doc? (
- || (
- www-client/links
- www-client/lynx
- www-client/w3m
- )
- )
- )
- !minimal? (
- >=x11-proto/xf86driproto-2.1.0
- >=x11-proto/dri2proto-2.8
- )"
-
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-xserver )
- !x11-drivers/xf86-video-modesetting
-"
-
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )
- xephyr? ( kdrive )"
-
-#UPSTREAMED_PATCHES=(
-# "${WORKDIR}/patches/"
-#)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.17-ia64-fix_inx_outx.patch
- "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
- # needed for new eselect-opengl, bug #541232
- "${FILESDIR}"/${PN}-1.17-support-multiple-Files-sections.patch
-)
-
-pkg_pretend() {
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" && $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
-}
-
-src_configure() {
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
- # NOTE: fop is used for doc generating ; and i have no idea if gentoo
- # package it somewhere
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- $(use_enable dmx)
- $(use_enable glamor)
- $(use_enable kdrive)
- $(use_enable kdrive kdrive-kbd)
- $(use_enable kdrive kdrive-mouse)
- $(use_enable kdrive kdrive-evdev)
- $(use_enable suid install-setuid)
- $(use_enable tslib)
- $(use_enable unwind libunwind)
- $(use_enable wayland xwayland)
- $(use_enable !minimal record)
- $(use_enable !minimal xfree86-utils)
- $(use_enable !minimal install-libxf86config)
- $(use_enable !minimal dri)
- $(use_enable !minimal dri2)
- $(use_enable !minimal glx)
- $(use_enable xephyr)
- $(use_enable xnest)
- $(use_enable xorg)
- $(use_enable xvfb)
- $(use_enable nptl glx-tls)
- $(use_enable udev config-udev)
- $(use_with doc doxygen)
- $(use_with doc xmlto)
- $(use_with systemd systemd-daemon)
- $(use_enable systemd systemd-logind)
- --enable-libdrm
- --sysconfdir="${EPREFIX}"/etc/X11
- --localstatedir="${EPREFIX}"/var
- --with-fontrootdir="${EPREFIX}"/usr/share/fonts
- --with-xkb-output="${EPREFIX}"/var/lib/xkb
- --disable-config-hal
- --disable-linux-acpi
- --without-dtrace
- --without-fop
- --with-os-vendor=Gentoo
- --with-sha1=libcrypto
- )
-
- xorg-2_src_configure
-}
-
-src_install() {
- xorg-2_src_install
-
- server_based_install
-
- if ! use minimal && use xorg; then
- # Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
- fi
-
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-11 xdm
- newconfd "${FILESDIR}"/xdm.confd-4 xdm
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postinst() {
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- eselect opengl set xorg-x11 --use-old
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}
-
-server_based_install() {
- if ! use xorg; then
- rm "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x
- fi
-}
diff --git a/x11-base/xorg-server/xorg-server-1.17.1.ebuild b/x11-base/xorg-server/xorg-server-1.17.1.ebuild
deleted file mode 100644
index 84398cd22b3..00000000000
--- a/x11-base/xorg-server/xorg-server-1.17.1.ebuild
+++ /dev/null
@@ -1,242 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-XORG_DOC=doc
-inherit xorg-2 multilib versionator flag-o-matic
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-
-IUSE_SERVERS="dmx kdrive xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} glamor ipv6 minimal nptl selinux +suid systemd tslib +udev unwind wayland"
-
-CDEPEND=">=app-eselect/eselect-opengl-1.3.0
- dev-libs/openssl
- media-libs/freetype
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.46
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont-1.4.2
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/libxshmfence-1.1
- >=x11-libs/pixman-0.27.2
- >=x11-libs/xtrans-1.3.5
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- dmx? (
- x11-libs/libXt
- >=x11-libs/libdmx-1.0.99.1
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXaw-1.0.4
- >=x11-libs/libXext-1.0.99.4
- >=x11-libs/libXfixes-5.0
- >=x11-libs/libXi-1.2.99.1
- >=x11-libs/libXmu-1.0.3
- x11-libs/libXrender
- >=x11-libs/libXres-1.0.3
- >=x11-libs/libXtst-1.0.99.2
- )
- glamor? (
- media-libs/libepoxy
- >=media-libs/mesa-10.3.4-r1[egl,gbm]
- !x11-libs/glamor
- )
- kdrive? (
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- )
- xephyr? (
- x11-libs/libxcb
- x11-libs/xcb-util
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-10.3.4-r1[nptl=]
- )
- tslib? ( >=x11-libs/tslib-1.0 )
- udev? ( >=virtual/udev-150 )
- unwind? ( sys-libs/libunwind )
- wayland? (
- >=dev-libs/wayland-1.3.0
- media-libs/libepoxy
- )
- >=x11-apps/xinit-1.3.3-r1
- systemd? (
- sys-apps/dbus
- sys-apps/systemd
- )"
-
-DEPEND="${CDEPEND}
- sys-devel/flex
- >=x11-proto/bigreqsproto-1.1.0
- >=x11-proto/compositeproto-0.4
- >=x11-proto/damageproto-1.1
- >=x11-proto/fixesproto-5.0
- >=x11-proto/fontsproto-2.1.3
- >=x11-proto/glproto-1.4.17-r1
- >=x11-proto/inputproto-2.2.99.1
- >=x11-proto/kbproto-1.0.3
- >=x11-proto/randrproto-1.4.0
- >=x11-proto/recordproto-1.13.99.1
- >=x11-proto/renderproto-0.11
- >=x11-proto/resourceproto-1.2.0
- >=x11-proto/scrnsaverproto-1.1
- >=x11-proto/trapproto-3.4.3
- >=x11-proto/videoproto-2.2.2
- >=x11-proto/xcmiscproto-1.2.0
- >=x11-proto/xextproto-7.2.99.901
- >=x11-proto/xf86dgaproto-2.0.99.1
- >=x11-proto/xf86rushproto-1.1.2
- >=x11-proto/xf86vidmodeproto-2.2.99.1
- >=x11-proto/xineramaproto-1.1.3
- >=x11-proto/xproto-7.0.26
- >=x11-proto/presentproto-1.0
- >=x11-proto/dri3proto-1.0
- dmx? (
- >=x11-proto/dmxproto-2.2.99.1
- doc? (
- || (
- www-client/links
- www-client/lynx
- www-client/w3m
- )
- )
- )
- !minimal? (
- >=x11-proto/xf86driproto-2.1.0
- >=x11-proto/dri2proto-2.8
- )"
-
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-xserver )
- !x11-drivers/xf86-video-modesetting
-"
-
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )
- xephyr? ( kdrive )"
-
-#UPSTREAMED_PATCHES=(
-# "${WORKDIR}/patches/"
-#)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.17-ia64-fix_inx_outx.patch
- "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
-)
-
-pkg_pretend() {
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" && $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
-}
-
-src_configure() {
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
- # NOTE: fop is used for doc generating ; and i have no idea if gentoo
- # package it somewhere
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- $(use_enable dmx)
- $(use_enable glamor)
- $(use_enable kdrive)
- $(use_enable kdrive kdrive-kbd)
- $(use_enable kdrive kdrive-mouse)
- $(use_enable kdrive kdrive-evdev)
- $(use_enable suid install-setuid)
- $(use_enable tslib)
- $(use_enable unwind libunwind)
- $(use_enable wayland xwayland)
- $(use_enable !minimal record)
- $(use_enable !minimal xfree86-utils)
- $(use_enable !minimal install-libxf86config)
- $(use_enable !minimal dri)
- $(use_enable !minimal dri2)
- $(use_enable !minimal glx)
- $(use_enable xephyr)
- $(use_enable xnest)
- $(use_enable xorg)
- $(use_enable xvfb)
- $(use_enable nptl glx-tls)
- $(use_enable udev config-udev)
- $(use_with doc doxygen)
- $(use_with doc xmlto)
- $(use_with systemd systemd-daemon)
- $(use_enable systemd systemd-logind)
- --enable-libdrm
- --sysconfdir="${EPREFIX}"/etc/X11
- --localstatedir="${EPREFIX}"/var
- --with-fontrootdir="${EPREFIX}"/usr/share/fonts
- --with-xkb-output="${EPREFIX}"/var/lib/xkb
- --disable-config-hal
- --disable-linux-acpi
- --without-dtrace
- --without-fop
- --with-os-vendor=Gentoo
- --with-sha1=libcrypto
- )
-
- xorg-2_src_configure
-}
-
-src_install() {
- xorg-2_src_install
-
- server_based_install
-
- if ! use minimal && use xorg; then
- # Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
- fi
-
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-11 xdm
- newconfd "${FILESDIR}"/xdm.confd-4 xdm
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postinst() {
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- eselect opengl set xorg-x11 --use-old
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}
-
-server_based_install() {
- if ! use xorg; then
- rm "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x
- fi
-}
diff --git a/x11-base/xorg-server/xorg-server-1.17.2-r1.ebuild b/x11-base/xorg-server/xorg-server-1.17.2-r1.ebuild
deleted file mode 100644
index 8181fa562e9..00000000000
--- a/x11-base/xorg-server/xorg-server-1.17.2-r1.ebuild
+++ /dev/null
@@ -1,245 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-XORG_DOC=doc
-inherit xorg-2 multilib versionator flag-o-matic
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-
-IUSE_SERVERS="dmx kdrive xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} glamor ipv6 minimal nptl selinux +suid systemd tslib +udev unwind wayland"
-
-CDEPEND=">=app-eselect/eselect-opengl-1.3.0
- dev-libs/openssl
- media-libs/freetype
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.46
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont-1.4.2
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/libxshmfence-1.1
- >=x11-libs/pixman-0.27.2
- >=x11-libs/xtrans-1.3.5
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- dmx? (
- x11-libs/libXt
- >=x11-libs/libdmx-1.0.99.1
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXaw-1.0.4
- >=x11-libs/libXext-1.0.99.4
- >=x11-libs/libXfixes-5.0
- >=x11-libs/libXi-1.2.99.1
- >=x11-libs/libXmu-1.0.3
- x11-libs/libXrender
- >=x11-libs/libXres-1.0.3
- >=x11-libs/libXtst-1.0.99.2
- )
- glamor? (
- media-libs/libepoxy
- >=media-libs/mesa-10.3.4-r1[egl,gbm]
- !x11-libs/glamor
- )
- kdrive? (
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- )
- xephyr? (
- x11-libs/libxcb
- x11-libs/xcb-util
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-10.3.4-r1[nptl=]
- )
- tslib? ( >=x11-libs/tslib-1.0 )
- udev? ( >=virtual/udev-150 )
- unwind? ( sys-libs/libunwind )
- wayland? (
- >=dev-libs/wayland-1.3.0
- media-libs/libepoxy
- )
- >=x11-apps/xinit-1.3.3-r1
- systemd? (
- sys-apps/dbus
- sys-apps/systemd
- )"
-
-DEPEND="${CDEPEND}
- sys-devel/flex
- >=x11-proto/bigreqsproto-1.1.0
- >=x11-proto/compositeproto-0.4
- >=x11-proto/damageproto-1.1
- >=x11-proto/fixesproto-5.0
- >=x11-proto/fontsproto-2.1.3
- >=x11-proto/glproto-1.4.17-r1
- >=x11-proto/inputproto-2.2.99.1
- >=x11-proto/kbproto-1.0.3
- >=x11-proto/randrproto-1.4.0
- >=x11-proto/recordproto-1.13.99.1
- >=x11-proto/renderproto-0.11
- >=x11-proto/resourceproto-1.2.0
- >=x11-proto/scrnsaverproto-1.1
- >=x11-proto/trapproto-3.4.3
- >=x11-proto/videoproto-2.2.2
- >=x11-proto/xcmiscproto-1.2.0
- >=x11-proto/xextproto-7.2.99.901
- >=x11-proto/xf86dgaproto-2.0.99.1
- >=x11-proto/xf86rushproto-1.1.2
- >=x11-proto/xf86vidmodeproto-2.2.99.1
- >=x11-proto/xineramaproto-1.1.3
- >=x11-proto/xproto-7.0.26
- >=x11-proto/presentproto-1.0
- >=x11-proto/dri3proto-1.0
- dmx? (
- >=x11-proto/dmxproto-2.2.99.1
- doc? (
- || (
- www-client/links
- www-client/lynx
- www-client/w3m
- )
- )
- )
- !minimal? (
- >=x11-proto/xf86driproto-2.1.0
- >=x11-proto/dri2proto-2.8
- )"
-
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-xserver )
- !x11-drivers/xf86-video-modesetting
-"
-
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )
- xephyr? ( kdrive )"
-
-#UPSTREAMED_PATCHES=(
-# "${WORKDIR}/patches/"
-#)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.17-ia64-fix_inx_outx.patch
- "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
- # needed for new eselect-opengl, bug #541232
- "${FILESDIR}"/${PN}-1.17-support-multiple-Files-sections.patch
- "${FILESDIR}"/${PN}-1.17.2-uninit-clientsWritable.patch
-)
-
-pkg_pretend() {
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" && $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
-}
-
-src_configure() {
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
- # NOTE: fop is used for doc generating ; and i have no idea if gentoo
- # package it somewhere
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- $(use_enable dmx)
- $(use_enable glamor)
- $(use_enable kdrive)
- $(use_enable kdrive kdrive-kbd)
- $(use_enable kdrive kdrive-mouse)
- $(use_enable kdrive kdrive-evdev)
- $(use_enable suid install-setuid)
- $(use_enable tslib)
- $(use_enable unwind libunwind)
- $(use_enable wayland xwayland)
- $(use_enable !minimal record)
- $(use_enable !minimal xfree86-utils)
- $(use_enable !minimal install-libxf86config)
- $(use_enable !minimal dri)
- $(use_enable !minimal dri2)
- $(use_enable !minimal glx)
- $(use_enable xephyr)
- $(use_enable xnest)
- $(use_enable xorg)
- $(use_enable xvfb)
- $(use_enable nptl glx-tls)
- $(use_enable udev config-udev)
- $(use_with doc doxygen)
- $(use_with doc xmlto)
- $(use_with systemd systemd-daemon)
- $(use_enable systemd systemd-logind)
- --enable-libdrm
- --sysconfdir="${EPREFIX}"/etc/X11
- --localstatedir="${EPREFIX}"/var
- --with-fontrootdir="${EPREFIX}"/usr/share/fonts
- --with-xkb-output="${EPREFIX}"/var/lib/xkb
- --disable-config-hal
- --disable-linux-acpi
- --without-dtrace
- --without-fop
- --with-os-vendor=Gentoo
- --with-sha1=libcrypto
- )
-
- xorg-2_src_configure
-}
-
-src_install() {
- xorg-2_src_install
-
- server_based_install
-
- if ! use minimal && use xorg; then
- # Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
- fi
-
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-11 xdm
- newconfd "${FILESDIR}"/xdm.confd-4 xdm
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postinst() {
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- eselect opengl set xorg-x11 --use-old
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}
-
-server_based_install() {
- if ! use xorg; then
- rm "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x
- fi
-}
diff --git a/x11-base/xorg-server/xorg-server-1.17.2-r2.ebuild b/x11-base/xorg-server/xorg-server-1.17.2-r2.ebuild
deleted file mode 100644
index 3001951b1ef..00000000000
--- a/x11-base/xorg-server/xorg-server-1.17.2-r2.ebuild
+++ /dev/null
@@ -1,246 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-XORG_DOC=doc
-inherit xorg-2 multilib versionator flag-o-matic
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-
-IUSE_SERVERS="dmx kdrive xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} glamor ipv6 libressl minimal nptl selinux +suid systemd tslib +udev unwind wayland"
-
-CDEPEND=">=app-eselect/eselect-opengl-1.3.0
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- media-libs/freetype
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.46
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont-1.4.2
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/libxshmfence-1.1
- >=x11-libs/pixman-0.27.2
- >=x11-libs/xtrans-1.3.5
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- dmx? (
- x11-libs/libXt
- >=x11-libs/libdmx-1.0.99.1
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXaw-1.0.4
- >=x11-libs/libXext-1.0.99.4
- >=x11-libs/libXfixes-5.0
- >=x11-libs/libXi-1.2.99.1
- >=x11-libs/libXmu-1.0.3
- x11-libs/libXrender
- >=x11-libs/libXres-1.0.3
- >=x11-libs/libXtst-1.0.99.2
- )
- glamor? (
- media-libs/libepoxy
- >=media-libs/mesa-10.3.4-r1[egl,gbm]
- !x11-libs/glamor
- )
- kdrive? (
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- )
- xephyr? (
- x11-libs/libxcb
- x11-libs/xcb-util
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-10.3.4-r1[nptl=]
- )
- tslib? ( >=x11-libs/tslib-1.0 )
- udev? ( >=virtual/udev-150 )
- unwind? ( sys-libs/libunwind )
- wayland? (
- >=dev-libs/wayland-1.3.0
- media-libs/libepoxy
- )
- >=x11-apps/xinit-1.3.3-r1
- systemd? (
- sys-apps/dbus
- sys-apps/systemd
- )"
-
-DEPEND="${CDEPEND}
- sys-devel/flex
- >=x11-proto/bigreqsproto-1.1.0
- >=x11-proto/compositeproto-0.4
- >=x11-proto/damageproto-1.1
- >=x11-proto/fixesproto-5.0
- >=x11-proto/fontsproto-2.1.3
- >=x11-proto/glproto-1.4.17-r1
- >=x11-proto/inputproto-2.2.99.1
- >=x11-proto/kbproto-1.0.3
- >=x11-proto/randrproto-1.4.0
- >=x11-proto/recordproto-1.13.99.1
- >=x11-proto/renderproto-0.11
- >=x11-proto/resourceproto-1.2.0
- >=x11-proto/scrnsaverproto-1.1
- >=x11-proto/trapproto-3.4.3
- >=x11-proto/videoproto-2.2.2
- >=x11-proto/xcmiscproto-1.2.0
- >=x11-proto/xextproto-7.2.99.901
- >=x11-proto/xf86dgaproto-2.0.99.1
- >=x11-proto/xf86rushproto-1.1.2
- >=x11-proto/xf86vidmodeproto-2.2.99.1
- >=x11-proto/xineramaproto-1.1.3
- >=x11-proto/xproto-7.0.26
- >=x11-proto/presentproto-1.0
- >=x11-proto/dri3proto-1.0
- dmx? (
- >=x11-proto/dmxproto-2.2.99.1
- doc? (
- || (
- www-client/links
- www-client/lynx
- www-client/w3m
- )
- )
- )
- !minimal? (
- >=x11-proto/xf86driproto-2.1.0
- >=x11-proto/dri2proto-2.8
- )"
-
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-xserver )
- !x11-drivers/xf86-video-modesetting
-"
-
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )
- xephyr? ( kdrive )"
-
-#UPSTREAMED_PATCHES=(
-# "${WORKDIR}/patches/"
-#)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.17-ia64-fix_inx_outx.patch
- "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
- # needed for new eselect-opengl, bug #541232
- "${FILESDIR}"/${PN}-1.17-support-multiple-Files-sections.patch
- "${FILESDIR}"/${PN}-1.17.2-uninit-clientsWritable.patch
-)
-
-pkg_pretend() {
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" && $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
-}
-
-src_configure() {
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
- # NOTE: fop is used for doc generating ; and i have no idea if gentoo
- # package it somewhere
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- $(use_enable dmx)
- $(use_enable glamor)
- $(use_enable kdrive)
- $(use_enable kdrive kdrive-kbd)
- $(use_enable kdrive kdrive-mouse)
- $(use_enable kdrive kdrive-evdev)
- $(use_enable suid install-setuid)
- $(use_enable tslib)
- $(use_enable unwind libunwind)
- $(use_enable wayland xwayland)
- $(use_enable !minimal record)
- $(use_enable !minimal xfree86-utils)
- $(use_enable !minimal install-libxf86config)
- $(use_enable !minimal dri)
- $(use_enable !minimal dri2)
- $(use_enable !minimal glx)
- $(use_enable xephyr)
- $(use_enable xnest)
- $(use_enable xorg)
- $(use_enable xvfb)
- $(use_enable nptl glx-tls)
- $(use_enable udev config-udev)
- $(use_with doc doxygen)
- $(use_with doc xmlto)
- $(use_with systemd systemd-daemon)
- $(use_enable systemd systemd-logind)
- --enable-libdrm
- --sysconfdir="${EPREFIX}"/etc/X11
- --localstatedir="${EPREFIX}"/var
- --with-fontrootdir="${EPREFIX}"/usr/share/fonts
- --with-xkb-output="${EPREFIX}"/var/lib/xkb
- --disable-config-hal
- --disable-linux-acpi
- --without-dtrace
- --without-fop
- --with-os-vendor=Gentoo
- --with-sha1=libcrypto
- )
-
- xorg-2_src_configure
-}
-
-src_install() {
- xorg-2_src_install
-
- server_based_install
-
- if ! use minimal && use xorg; then
- # Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
- fi
-
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-11 xdm
- newconfd "${FILESDIR}"/xdm.confd-4 xdm
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postinst() {
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- eselect opengl set xorg-x11 --use-old
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}
-
-server_based_install() {
- if ! use xorg; then
- rm "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x
- fi
-}
diff --git a/x11-base/xorg-server/xorg-server-1.17.2.ebuild b/x11-base/xorg-server/xorg-server-1.17.2.ebuild
deleted file mode 100644
index 8f4c90e6799..00000000000
--- a/x11-base/xorg-server/xorg-server-1.17.2.ebuild
+++ /dev/null
@@ -1,244 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-XORG_DOC=doc
-inherit xorg-2 multilib versionator flag-o-matic
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-
-IUSE_SERVERS="dmx kdrive xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} glamor ipv6 minimal nptl selinux +suid systemd tslib +udev unwind wayland"
-
-CDEPEND=">=app-eselect/eselect-opengl-1.3.0
- dev-libs/openssl
- media-libs/freetype
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.46
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont-1.4.2
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/libxshmfence-1.1
- >=x11-libs/pixman-0.27.2
- >=x11-libs/xtrans-1.3.5
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- dmx? (
- x11-libs/libXt
- >=x11-libs/libdmx-1.0.99.1
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXaw-1.0.4
- >=x11-libs/libXext-1.0.99.4
- >=x11-libs/libXfixes-5.0
- >=x11-libs/libXi-1.2.99.1
- >=x11-libs/libXmu-1.0.3
- x11-libs/libXrender
- >=x11-libs/libXres-1.0.3
- >=x11-libs/libXtst-1.0.99.2
- )
- glamor? (
- media-libs/libepoxy
- >=media-libs/mesa-10.3.4-r1[egl,gbm]
- !x11-libs/glamor
- )
- kdrive? (
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- )
- xephyr? (
- x11-libs/libxcb
- x11-libs/xcb-util
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-10.3.4-r1[nptl=]
- )
- tslib? ( >=x11-libs/tslib-1.0 )
- udev? ( >=virtual/udev-150 )
- unwind? ( sys-libs/libunwind )
- wayland? (
- >=dev-libs/wayland-1.3.0
- media-libs/libepoxy
- )
- >=x11-apps/xinit-1.3.3-r1
- systemd? (
- sys-apps/dbus
- sys-apps/systemd
- )"
-
-DEPEND="${CDEPEND}
- sys-devel/flex
- >=x11-proto/bigreqsproto-1.1.0
- >=x11-proto/compositeproto-0.4
- >=x11-proto/damageproto-1.1
- >=x11-proto/fixesproto-5.0
- >=x11-proto/fontsproto-2.1.3
- >=x11-proto/glproto-1.4.17-r1
- >=x11-proto/inputproto-2.2.99.1
- >=x11-proto/kbproto-1.0.3
- >=x11-proto/randrproto-1.4.0
- >=x11-proto/recordproto-1.13.99.1
- >=x11-proto/renderproto-0.11
- >=x11-proto/resourceproto-1.2.0
- >=x11-proto/scrnsaverproto-1.1
- >=x11-proto/trapproto-3.4.3
- >=x11-proto/videoproto-2.2.2
- >=x11-proto/xcmiscproto-1.2.0
- >=x11-proto/xextproto-7.2.99.901
- >=x11-proto/xf86dgaproto-2.0.99.1
- >=x11-proto/xf86rushproto-1.1.2
- >=x11-proto/xf86vidmodeproto-2.2.99.1
- >=x11-proto/xineramaproto-1.1.3
- >=x11-proto/xproto-7.0.26
- >=x11-proto/presentproto-1.0
- >=x11-proto/dri3proto-1.0
- dmx? (
- >=x11-proto/dmxproto-2.2.99.1
- doc? (
- || (
- www-client/links
- www-client/lynx
- www-client/w3m
- )
- )
- )
- !minimal? (
- >=x11-proto/xf86driproto-2.1.0
- >=x11-proto/dri2proto-2.8
- )"
-
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-xserver )
- !x11-drivers/xf86-video-modesetting
-"
-
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )
- xephyr? ( kdrive )"
-
-#UPSTREAMED_PATCHES=(
-# "${WORKDIR}/patches/"
-#)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.17-ia64-fix_inx_outx.patch
- "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
- # needed for new eselect-opengl, bug #541232
- "${FILESDIR}"/${PN}-1.17-support-multiple-Files-sections.patch
-)
-
-pkg_pretend() {
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" && $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
-}
-
-src_configure() {
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
- # NOTE: fop is used for doc generating ; and i have no idea if gentoo
- # package it somewhere
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- $(use_enable dmx)
- $(use_enable glamor)
- $(use_enable kdrive)
- $(use_enable kdrive kdrive-kbd)
- $(use_enable kdrive kdrive-mouse)
- $(use_enable kdrive kdrive-evdev)
- $(use_enable suid install-setuid)
- $(use_enable tslib)
- $(use_enable unwind libunwind)
- $(use_enable wayland xwayland)
- $(use_enable !minimal record)
- $(use_enable !minimal xfree86-utils)
- $(use_enable !minimal install-libxf86config)
- $(use_enable !minimal dri)
- $(use_enable !minimal dri2)
- $(use_enable !minimal glx)
- $(use_enable xephyr)
- $(use_enable xnest)
- $(use_enable xorg)
- $(use_enable xvfb)
- $(use_enable nptl glx-tls)
- $(use_enable udev config-udev)
- $(use_with doc doxygen)
- $(use_with doc xmlto)
- $(use_with systemd systemd-daemon)
- $(use_enable systemd systemd-logind)
- --enable-libdrm
- --sysconfdir="${EPREFIX}"/etc/X11
- --localstatedir="${EPREFIX}"/var
- --with-fontrootdir="${EPREFIX}"/usr/share/fonts
- --with-xkb-output="${EPREFIX}"/var/lib/xkb
- --disable-config-hal
- --disable-linux-acpi
- --without-dtrace
- --without-fop
- --with-os-vendor=Gentoo
- --with-sha1=libcrypto
- )
-
- xorg-2_src_configure
-}
-
-src_install() {
- xorg-2_src_install
-
- server_based_install
-
- if ! use minimal && use xorg; then
- # Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
- fi
-
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-11 xdm
- newconfd "${FILESDIR}"/xdm.confd-4 xdm
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postinst() {
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- eselect opengl set xorg-x11 --use-old
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}
-
-server_based_install() {
- if ! use xorg; then
- rm "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x
- fi
-}