summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-01-19 21:28:14 -0800
committerMatt Turner <mattst88@gentoo.org>2019-01-19 21:43:05 -0800
commite0afeb07eaa642f0508dec429c124fba008da07f (patch)
treef1247bb71ab2464036cd090ba1af0e69b061f0e8 /x11-drivers/xf86-input-wacom
parentx11-drivers/xf86-input-libinput: Drop old versions (diff)
downloadgentoo-e0afeb07eaa642f0508dec429c124fba008da07f.tar.gz
gentoo-e0afeb07eaa642f0508dec429c124fba008da07f.tar.bz2
gentoo-e0afeb07eaa642f0508dec429c124fba008da07f.zip
x11-drivers/xf86-input-wacom: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/Manifest2
-rw-r--r--x11-drivers/xf86-input-wacom/files/xf86-input-wacom-0.34.0-xorg-server-1.19-support.patch49
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild77
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.35.0.ebuild73
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0.ebuild73
5 files changed, 0 insertions, 274 deletions
diff --git a/x11-drivers/xf86-input-wacom/Manifest b/x11-drivers/xf86-input-wacom/Manifest
index ab7988b64c4..4b3259e7a1f 100644
--- a/x11-drivers/xf86-input-wacom/Manifest
+++ b/x11-drivers/xf86-input-wacom/Manifest
@@ -1,3 +1 @@
-DIST xf86-input-wacom-0.34.0.tar.bz2 598624 BLAKE2B 9b8b39f859a007c89ff1eb24711a2cc6a90b3106b8a3ceb2bc3c7064c14c5079e8ab08e248309ab08716da5c2e593046dd78b3d989167762c794af95b85ae95f SHA512 d0aae70853f73d989d168e054bb21ddbd2114ec6c012b1c5f949838bb20a7fe75711211886dd649ec0e9449d199da17b4ff156d5d672ad02c8b2e0b667cc40ad
-DIST xf86-input-wacom-0.35.0.tar.bz2 601314 BLAKE2B 59c2b03b79d141b71583ce3ea6ac4957e345322b67e78f24333a3f045316aa878dbcca6a575f7daf490e2991494215d83bf28bb9ec6b8a8c133abc57d559dc44 SHA512 9586348e8da91651bc9a9ee9e74dd77f4311060538dcb228681b98300f7624401878190322dcbc4e798bd1eeeb7d2900abc3f5e949a583b6cda44821b8821058
DIST xf86-input-wacom-0.36.0.tar.bz2 611678 BLAKE2B b3fc8310514e6e07c3c25fceeb982d66e9e10730028af769cd331578a48720666a0872b625beb15c7f68bbb291293dfe4c4e305411310c67bb2bd148e7d570d8 SHA512 48e4cf945eb0f5c7c65d46153756372bbfd6d1f101cd90f609c71cc21b36fa671d98c7be0b52d519775c7e7b875ec441d4308cf70d7897198600553e7a93ccc5
diff --git a/x11-drivers/xf86-input-wacom/files/xf86-input-wacom-0.34.0-xorg-server-1.19-support.patch b/x11-drivers/xf86-input-wacom/files/xf86-input-wacom-0.34.0-xorg-server-1.19-support.patch
deleted file mode 100644
index 3c1494d3605..00000000000
--- a/x11-drivers/xf86-input-wacom/files/xf86-input-wacom-0.34.0-xorg-server-1.19-support.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From f0dedf7a610ac97bc45738492b98ce4f1e0514ec Mon Sep 17 00:00:00 2001
-From: Jason Gerecke <killertofu@gmail.com>
-Date: Wed, 18 Jan 2017 09:00:10 -0800
-Subject: [PATCH] tests: Fix compilation under ABI 25 and greater
-
-The X server recently deprecated xf86BlockSIGIO and xf86UnblockSIGIO and
-simultaneously defined them inline within xf86.h. The new inline definition
-causes problems both because fake-symbols.c will end up redefining them,
-and because the function bodies reference a symbol that does not get included
-when building the tests. To fix these errors, update fake-symbols.c with
-updated include guards and a definition of the undefined symbols.
-
-Signed-off-by: Jason Gerecke <jason.gerecke@wacom.com>
-Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net>
----
- test/fake-symbols.c | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
-diff --git a/test/fake-symbols.c b/test/fake-symbols.c
-index 6f2c10a..e649fb9 100644
---- a/test/fake-symbols.c
-+++ b/test/fake-symbols.c
-@@ -493,6 +493,7 @@ void TimerFree(OsTimerPtr timer)
- {
- }
-
-+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) < 24
- int
- xf86BlockSIGIO (void)
- {
-@@ -503,6 +504,15 @@ void
- xf86UnblockSIGIO (int wasset)
- {
- }
-+#else
-+void input_lock (void)
-+{
-+}
-+
-+void input_unlock (void)
-+{
-+}
-+#endif
-
- /* This is not the same as the X server one, but it'll do for the tests */
- #if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 14
---
-2.10.2
-
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild
deleted file mode 100644
index cd427a34041..00000000000
--- a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit linux-info xorg-2
-
-DESCRIPTION="Driver for Wacom tablets and drawing devices"
-HOMEPAGE="http://linuxwacom.sourceforge.net/"
-LICENSE="GPL-2"
-EGIT_REPO_URI="git://git.code.sf.net/p/linuxwacom/${PN}"
-[[ ${PV} != 9999* ]] && \
- SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
-
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
-IUSE="debug"
-
-# depend on libwacom for its udev rules, bug #389633
-RDEPEND="dev-libs/libwacom
- virtual/udev
- >=x11-base/xorg-server-1.7
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXrandr
- x11-libs/libXinerama"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-
-PATCHES=(
- "${FILESDIR}/${P}-xorg-server-1.19-support.patch"
-)
-
-pkg_setup() {
- linux-info_pkg_setup
-
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable debug)
- )
-}
-
-src_install() {
- xorg-2_src_install
-
- rm -rf "${ED}"/usr/share/hal
-}
-
-pkg_pretend() {
- linux-info_pkg_setup
-
- if kernel_is lt 3 17; then
- if ! linux_config_exists \
- || ! linux_chkconfig_present TABLET_USB_WACOM \
- || ! linux_chkconfig_present INPUT_EVDEV; then
- echo
- ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
- ewarn " Device Drivers --->"
- ewarn " Input device support --->"
- ewarn " <*> Event interface"
- ewarn " [*] Tablets --->"
- ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
- echo
- fi
- else
- if ! linux_config_exists \
- || ! linux_chkconfig_present HID_WACOM; then
- echo
- ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
- ewarn " Device Drivers --->"
- ewarn " HID support --->"
- ewarn " Special HID drivers --->"
- ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
- echo
- fi
- fi
-
-}
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.35.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.35.0.ebuild
deleted file mode 100644
index 0f91507ed82..00000000000
--- a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.35.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit linux-info xorg-2
-
-DESCRIPTION="Driver for Wacom tablets and drawing devices"
-HOMEPAGE="http://linuxwacom.sourceforge.net/"
-LICENSE="GPL-2"
-EGIT_REPO_URI="git://git.code.sf.net/p/linuxwacom/${PN}"
-[[ ${PV} != 9999* ]] && \
- SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug"
-
-# depend on libwacom for its udev rules, bug #389633
-RDEPEND="dev-libs/libwacom
- virtual/udev
- >=x11-base/xorg-server-1.7
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXrandr
- x11-libs/libXinerama"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-
-pkg_setup() {
- linux-info_pkg_setup
-
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable debug)
- )
-}
-
-src_install() {
- xorg-2_src_install
-
- rm -rf "${ED}"/usr/share/hal
-}
-
-pkg_pretend() {
- linux-info_pkg_setup
-
- if kernel_is lt 3 17; then
- if ! linux_config_exists \
- || ! linux_chkconfig_present TABLET_USB_WACOM \
- || ! linux_chkconfig_present INPUT_EVDEV; then
- echo
- ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
- ewarn " Device Drivers --->"
- ewarn " Input device support --->"
- ewarn " <*> Event interface"
- ewarn " [*] Tablets --->"
- ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
- echo
- fi
- else
- if ! linux_config_exists \
- || ! linux_chkconfig_present HID_WACOM; then
- echo
- ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
- ewarn " Device Drivers --->"
- ewarn " HID support --->"
- ewarn " Special HID drivers --->"
- ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
- echo
- fi
- fi
-
-}
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0.ebuild
deleted file mode 100644
index 47a540cf7b6..00000000000
--- a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit linux-info xorg-2
-
-DESCRIPTION="Driver for Wacom tablets and drawing devices"
-HOMEPAGE="http://linuxwacom.sourceforge.net/"
-LICENSE="GPL-2"
-EGIT_REPO_URI="git://git.code.sf.net/p/linuxwacom/${PN}"
-[[ ${PV} != 9999* ]] && \
- SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
-
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
-IUSE="debug"
-
-# depend on libwacom for its udev rules, bug #389633
-RDEPEND="dev-libs/libwacom
- virtual/udev
- >=x11-base/xorg-server-1.7
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXrandr
- x11-libs/libXinerama"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-
-pkg_setup() {
- linux-info_pkg_setup
-
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable debug)
- )
-}
-
-src_install() {
- xorg-2_src_install
-
- rm -rf "${ED}"/usr/share/hal
-}
-
-pkg_pretend() {
- linux-info_pkg_setup
-
- if kernel_is lt 3 17; then
- if ! linux_config_exists \
- || ! linux_chkconfig_present TABLET_USB_WACOM \
- || ! linux_chkconfig_present INPUT_EVDEV; then
- echo
- ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
- ewarn " Device Drivers --->"
- ewarn " Input device support --->"
- ewarn " <*> Event interface"
- ewarn " [*] Tablets --->"
- ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
- echo
- fi
- else
- if ! linux_config_exists \
- || ! linux_chkconfig_present HID_WACOM; then
- echo
- ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
- ewarn " Device Drivers --->"
- ewarn " HID support --->"
- ewarn " Special HID drivers --->"
- ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
- echo
- fi
- fi
-
-}