summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-02-07 23:36:57 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-02-08 00:20:08 +0100
commit5dca30a28342b418cd7e7d1499a6cf45358a2cec (patch)
treed7c07452b9fddf68c0e1228f71eb76f3b66be06c /x11-libs/goffice
parentapp-arch/gcab: security version bump 0.7 → 0.8 (diff)
downloadgentoo-5dca30a28342b418cd7e7d1499a6cf45358a2cec.tar.gz
gentoo-5dca30a28342b418cd7e7d1499a6cf45358a2cec.tar.bz2
gentoo-5dca30a28342b418cd7e7d1499a6cf45358a2cec.zip
x11-libs/goffice: version 0.10.35 → 0.10.38
Force gtk+ to 3.20 as configure explicitely checks for a symbol introduced in this version and it is already stable. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-libs/goffice')
-rw-r--r--x11-libs/goffice/Manifest1
-rw-r--r--x11-libs/goffice/goffice-0.10.38.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
index 77b136523bc7..c700382de6dc 100644
--- a/x11-libs/goffice/Manifest
+++ b/x11-libs/goffice/Manifest
@@ -1,2 +1,3 @@
DIST goffice-0.10.35.tar.xz 2370332 BLAKE2B 44799f90f45b36241aa1a3e9371719dcf76d94ff5b180dbc0d13e633c65cea88c8fa6049a94833c01d7a96db29e768e737f458dfff2eb2211d2915be68ec8338 SHA512 68a274e73b8c237966ff300f129362d5a7a861e0281ca0dca9a0850f0ea30644f16de0eb5480ac8a399e7ff40699af5ddfcd79593c42f06d296ab3e778c368d2
+DIST goffice-0.10.38.tar.xz 2373308 BLAKE2B f270233adbbf300ad41516b1ed988db0772b95940196a6ac92c3090f6e52bc47933bb6bb4c023d7137cbca42adfab17fc41b82042c2e9c0340a6cd84942874e5 SHA512 1d72e30ee0b9f322cd4114d0a024a99e6d9ff7efcaeb9ca40b5fffe94180c232f03935743c15b1c6170f8bfc04fea5bdcc4d12760643c66cffafefbaa562fd62
DIST goffice-0.8.17.tar.xz 1814488 BLAKE2B 8e17ade84f7417e493bbd56bd42805ad9fb87749b4705eb09c208384e3537610f478cf0ecb957b2a2007a097efc5e1c2019060b1aaffddf52bd1db559d7af957 SHA512 61a3063d37e2ded4d4065d261f728c862daea04090ac38abe2524089ed1ee253e0d77e501f5b3451b1e011491a8225f90fd4914f28ce2a347ecf561098e6400c
diff --git a/x11-libs/goffice/goffice-0.10.38.ebuild b/x11-libs/goffice/goffice-0.10.38.ebuild
new file mode 100644
index 000000000000..9bf3bf394d80
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.38.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://git.gnome.org/browse/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.38.0:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24:=
+ >=x11-libs/cairo-1.10:=[svg]
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.20:3
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:= )
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/perl-Compress-Raw-Zlib
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}