summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-03 18:26:42 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-03 18:33:31 +0200
commitfb4788a7af80e45d63788ed879b58a9ac2d6ff73 (patch)
tree106e282761e9509e4f6939df356d08b1770a3962 /x11-libs/goffice
parentx11-libs/goffice: Drop old (diff)
downloadgentoo-fb4788a7af80e45d63788ed879b58a9ac2d6ff73.tar.gz
gentoo-fb4788a7af80e45d63788ed879b58a9ac2d6ff73.tar.bz2
gentoo-fb4788a7af80e45d63788ed879b58a9ac2d6ff73.zip
x11-libs/goffice: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'x11-libs/goffice')
-rw-r--r--x11-libs/goffice/Manifest1
-rw-r--r--x11-libs/goffice/goffice-0.10.31.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
index 665bf2b11854..9318073e5910 100644
--- a/x11-libs/goffice/Manifest
+++ b/x11-libs/goffice/Manifest
@@ -1,2 +1,3 @@
DIST goffice-0.10.29.tar.xz 2379280 SHA256 b395dcf062f8575788aeab087b66ae21c2e22a7661309adc81d1825b507b7ff9 SHA512 7e6bf2e3d469f8428e6f0c4c7b381ac9f855b3c491cb70676df15aa33f05555d15a899147d488c8478b57aabd206bfe61b811352c05be0f9d8458a611b7aa6f4 WHIRLPOOL 44d83acd5fd65ee566a25c48fec5b8bbd7bbb6e5843a2aa51b2406991d515399da0ad55831b822f5102c6c30ca065ba05f6282fc24183aed4d0476b6f998cbf6
+DIST goffice-0.10.31.tar.xz 2386264 SHA256 9d1fc2dcc131742348ed6e1597e2fab143cbf73e7067c5c05a3f3565266ed5a5 SHA512 bdc497bd61c9b1e303afba6c9ed5f2d23a09e380702959a64d6877ce5ad7c7c495e63650686135aef137206ebec285227c9ee24cb3f73c64d7e5a504bf49bfc6 WHIRLPOOL c270d7a29a555173ed1d0f2942d50000b32ff90102cbc9ad14e07d307701533bf5f9b8813328457fa122376aaf56eba6df71f971f369fcb7cff7d16f9530cdbe
DIST goffice-0.8.17.tar.xz 1814488 SHA256 165070beb67b84580afe80a8a100b674a81d553ab791acd72ac0c655f4fadb15 SHA512 61a3063d37e2ded4d4065d261f728c862daea04090ac38abe2524089ed1ee253e0d77e501f5b3451b1e011491a8225f90fd4914f28ce2a347ecf561098e6400c WHIRLPOOL 12ac2587af25c41686797b9bd5ff93429687217cb3d14e130067685701fd0685ed1c4f9900eb34a15cfb30dcdfe9ebe9f9856a1b4eb6684555d0a9cb1ef86ff1
diff --git a/x11-libs/goffice/goffice-0.10.31.ebuild b/x11-libs/goffice/goffice-0.10.31.ebuild
new file mode 100644
index 000000000000..1f36ed76e803
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.31.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://git.gnome.org/browse/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.38.0:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24:=
+ >=x11-libs/cairo-1.10:=[svg]
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.8.7:3
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:= )
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/perl-Compress-Raw-Zlib
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+# eautoreconf requires:
+# gnome-base/gnome-common
+
+src_configure() {
+ gnome2_src_configure \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}