summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-05-28 17:11:36 +0200
committerPacho Ramos <pacho@gentoo.org>2016-05-28 17:48:58 +0200
commitab5a4c61da1066d04ecacf291ce1e95a51326e9d (patch)
treed57715db4ad45e1f3e70e85955953e4da2e5d330 /x11-libs/gtksourceview
parentx11-libs/gtksourceview: Drop old (diff)
downloadgentoo-ab5a4c61da1066d04ecacf291ce1e95a51326e9d.tar.gz
gentoo-ab5a4c61da1066d04ecacf291ce1e95a51326e9d.tar.bz2
gentoo-ab5a4c61da1066d04ecacf291ce1e95a51326e9d.zip
x11-libs/gtksourceview: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/Manifest1
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.18.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
index 7bcc0a4dbbe1..d4e86e06153a 100644
--- a/x11-libs/gtksourceview/Manifest
+++ b/x11-libs/gtksourceview/Manifest
@@ -1,3 +1,4 @@
DIST gtksourceview-2.10.5.tar.bz2 1253321 SHA256 c585773743b1df8a04b1be7f7d90eecdf22681490d6810be54c81a7ae152191e SHA512 6f64acef6196bfc5953e0b148d7e460d366073b5e21367c01b01fc4d1c86ffe8aca71ecd77cf0814e47d8fc3085495f25bbbdc69e746987b02fd02fcda64886d WHIRLPOOL 4bd2589d4e06bb5e5c4dc8c55af25c52fd2c2c318a1240d7a430c8cb442cc785b7048f0116d9df714f93c6c1cb87628459239a80ae317d8eb73d27e4c021281a
DIST gtksourceview-3.16.1.tar.xz 1272152 SHA256 669e9846ca744ec4d04ce61377e85df7ca909ad476329922a6abf4da423f1b0c SHA512 8bae196d923d08e58c8f02d7612b32aa7caec8457c2ff35c2bb2322a3013a8f1fe52cbc62540f9d83054811ee517088d4e880b82733b2a73e7724a206b2ad911 WHIRLPOOL c51a0dd6ccad2262b289509f8dfa85675ba90cf4f0242358ca2d1ad857cf06e33ad0495560b726430738d827f9204c2eb63a90209171194a7c8eb163e46a1471
DIST gtksourceview-3.18.2.tar.xz 1317804 SHA256 60f75a9f0039e13a2281fc595b5ef7344afa06732cc53b57d13234bfb0a5b7b2 SHA512 75e502264d7d9f63f9a2c9c884072cfc2d323c7cc49383b9b53916321ce20ef695e7a2dd0f6db67a4daf70ba84a3a907dfc6d9407ba5982adb976210e0589328 WHIRLPOOL 4143a624a0582a5d92de707b5167bc9805a5b484906977c4b0d195703d7bd113ebd677829f6e6c2c2d8d10cdae2041db99e8294e18e7114d53e15da6f233ad80
+DIST gtksourceview-3.18.3.tar.xz 1294704 SHA256 4720710d559c372f6add0b73b5ee1511630ba7cf0502e554461503602400e015 SHA512 29fba52d961137a23cadf50aab220e8bd7f1515727cedf081eb59f4f18e297cff40b0ad5432af7b45686c5f7b1fdbae43df3bf2de820ec91654b03bff175c0fe WHIRLPOOL 66c198cf361c55975111288cea07684c538a9ceeb5a77424e1a698be0a0e0baca2126c0dd64e5f6545b91abb2d6c78301c0f47c8ca8d64b939b93760591ad980
diff --git a/x11-libs/gtksourceview/gtksourceview-3.18.3.ebuild b/x11-libs/gtksourceview/gtksourceview-3.18.3.ebuild
new file mode 100644
index 000000000000..611eefd67cc6
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.18.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+VALA_MIN_API_VERSION="0.24"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3.0/3"
+
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/gtk+-3.16:3[introspection?]
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.24
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-deprecations \
+ --enable-providers \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}