summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libICE
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libICE')
-rw-r--r--x11-libs/libICE/Manifest2
-rw-r--r--x11-libs/libICE/libICE-1.0.8-r1.ebuild30
-rw-r--r--x11-libs/libICE/libICE-1.0.9.ebuild30
-rw-r--r--x11-libs/libICE/metadata.xml5
4 files changed, 67 insertions, 0 deletions
diff --git a/x11-libs/libICE/Manifest b/x11-libs/libICE/Manifest
new file mode 100644
index 000000000000..e347b98d0b7b
--- /dev/null
+++ b/x11-libs/libICE/Manifest
@@ -0,0 +1,2 @@
+DIST libICE-1.0.8.tar.bz2 365762 SHA256 24a991284d02ff0c789bc8d11ad2e4dffe144cb70f24e28f9ce3e8b1ee08b71e SHA512 eac189813df84c0d1b5a4f59855a147c945cb6960bb91dd3d94b2fbe909609a3da1d250bea4a0c8090b4dc64b4f64eb548b67a39de719ebddce19c6c1394532e WHIRLPOOL 3dba49fac7bd5852ef448d6d51408831d24802e5fed0fbb9a3877814c53d971c89db9aa53d388825660f42acf19a0d2b3ad625d58dfb0fa623e5ae5df49c4ac5
+DIST libICE-1.0.9.tar.bz2 384921 SHA256 8f7032f2c1c64352b5423f6b48a8ebdc339cc63064af34d66a6c9aa79759e202 SHA512 daa8126ee5279c08f801274a2754132762dea2a40f4733c4b0bf8e8bdad61cba826939a2e067beb3524e256a98a2b83f23c8d4643f3e75a284ab02cc73da41b7 WHIRLPOOL efdd7bc60416d883b15af7cfd0c152a2b7f7ee539d0717704b89c0621f9cefa718b14af63fb1d10709e7b0cc84d660f30d069ff0b273d304be8f0c5a74fe1090
diff --git a/x11-libs/libICE/libICE-1.0.8-r1.ebuild b/x11-libs/libICE/libICE-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..19bba1959ea8
--- /dev/null
+++ b/x11-libs/libICE/libICE-1.0.8-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Inter-Client Exchange library"
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/xtrans
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_enable doc docs)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+}
diff --git a/x11-libs/libICE/libICE-1.0.9.ebuild b/x11-libs/libICE/libICE-1.0.9.ebuild
new file mode 100644
index 000000000000..b2f278be47b0
--- /dev/null
+++ b/x11-libs/libICE/libICE-1.0.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Inter-Client Exchange library"
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/xtrans
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_enable doc docs)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+}
diff --git a/x11-libs/libICE/metadata.xml b/x11-libs/libICE/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-libs/libICE/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>