summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-05-21 22:18:30 +0200
committerMatt Turner <mattst88@gentoo.org>2018-05-21 18:05:13 -0700
commit6057c95e193bd173984f44b6b3881d832350d2a6 (patch)
tree6ab480ad6f5b69743f242731442d0f8aa74eb5a9 /x11-libs/libXmu/libXmu-1.1.2-r1.ebuild
parentx11-drivers/*: Update dependencies (x11-proto/* -> x11-base/xorg-proto). (diff)
downloadgentoo-6057c95e193bd173984f44b6b3881d832350d2a6.tar.gz
gentoo-6057c95e193bd173984f44b6b3881d832350d2a6.tar.bz2
gentoo-6057c95e193bd173984f44b6b3881d832350d2a6.zip
x11-libs/*: Update dependencies (x11-proto/* -> x11-base/xorg-proto).
Diffstat (limited to 'x11-libs/libXmu/libXmu-1.1.2-r1.ebuild')
-rw-r--r--x11-libs/libXmu/libXmu-1.1.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-libs/libXmu/libXmu-1.1.2-r1.ebuild b/x11-libs/libXmu/libXmu-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..62a672262ca1
--- /dev/null
+++ b/x11-libs/libXmu/libXmu-1.1.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Xmu library"
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ipv6"
+
+RDEPEND="x11-base/xorg-proto
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-2_src_configure
+}